Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - spelger

Pages: [1]
1
General Board / Re: is the structured activity node useful?
« on: December 07, 2016, 04:22:05 am »
oh if only it were that simple. when i do that the sections do change size but when i need to increase the size of the lowest section by sizing the entire node all the sections change size the activities in the middle section end up in the lower section. this has the effect of making the entire node really large and from that point it is a struggle to make it smaller.

the version i am using is 12.0.1214. should have mentioned that in my original post.

2
General Board / is the structured activity node useful?
« on: December 07, 2016, 03:14:06 am »
i'd like to use the structured activity node to model a simple loop. unfortunately it seems that this node cannot be sized to be useful. it appears that the three sections of the node must be the same size. i've seen this questioned a number of times with no response either from anyone who knows how to do it properly or from any rep from EA.

i feel like a kid on the wrong side of the candy store window.

scott

3
General Board / Re: two shape script questions
« on: December 03, 2015, 06:51:23 am »
qwerty: thanks. too bad about not being able to bold the text, it would have given it a more consistent look.

geert: thanks for the code snippit, that worked like a champ. i tried to go the add-in route that qwerty suggested, in fact i found this which i think is yours: http://bellekens.com/2011/01/29/tutorial-create-your-first-c-enterprise-architect-addin-in-10-minutes/

was not able to get the add-in loaded though. some other time.

thanks again,
scott

4
General Board / two shape script questions
« on: December 03, 2015, 04:29:21 am »
Hi,

i'm using shape script to customize a shape. i'd like to be able to bolden some text like EA does for a class object on a class diagram as an example.

also, when a class is defined in say Package1 and exists as a link on a diagram in Package2 EA will prefix the class name with the package name (scoping). how can that be done in shape script? to be clear, when the class defined in Package1 is on a diagram in Package1 i want the name of the class, but when the class is on a diagram in Package2 i want the package name and the class name just like EA does.

i've pulled out lots of hair working out both of these problems and i already don't have much to spare.

thanks,
scott

5
General Board / Re: Type Library?
« on: August 11, 2015, 03:30:25 am »
Thanks,

The XMI approach appears to be satisfactory for the moment.

scott

6
General Board / Type Library?
« on: August 01, 2015, 12:46:25 am »
In my work group we create a lot of different projects that utilize the same c++ libraries. I'd like to be able to create something similar in EA, that is, a library that I can import into many EA projects that would contain defined types like certain classes that are used over and over as well as our own well known data types. Is this possible? I started to look at profiles but that seemed the wrong path to me as from what I can tell they appear to contain only abstract extensions to UML.

thanks,
scott

7
General Board / Show Notes appear to not be working
« on: May 21, 2015, 01:34:54 am »
I'm using EA V11 and am trying to show the notes of an element. i think have the proper check box checked in the "Features and Compartment Visibility" dialog box but nothing happens on my element. Does anyone know if this works or how it works?

thanks,
scott

8
Bugs and Issues / Re: Auto save
« on: February 05, 2015, 08:58:11 am »
thank you roy, that explain what is happening. now, can it be disabled? in other words, can i change some setting that marks the entire *.eap file as dirty if anything changes? in more other words, i want to be in charge of when saving occurs.

fortunately, i am using version control so i can always revert if something changed without an explicit save.

thanks again,
scott

9
Bugs and Issues / Auto save
« on: February 05, 2015, 03:23:17 am »
i am quite new to EA but have noticed something that is a little annoying. when editing a diagram sometimes i need to manually save my change(s) and sometimes i do not. is there some hidden option that controls this? i've searched the forum, help docs, and all menu items.

an example of this is in a class diagram if i move an object i must save it, if i only change the name of the class i do not.

using v11.1.1113

thanks,
scott

Pages: [1]