Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - timhawkins

Pages: [1] 2
1
Suggestions and Requests / object garbage collection
« on: August 15, 2003, 08:58:08 am »
I often find that I create some objects that I subsequently delete from a diagram, either becuase I have created them on the wrong diagram, or as the wrong type.

However deleteing them from the diagram does not delete them from the database, even if there are no references to them.

I would make my life easier if there was an abilty to "display zero usage objects" for any given point in the hierarchy, and then be able to select the ones That I wish to delete. This prevents the need for me to do properties/show usage on each to find the zombie objects.

2
Suggestions and Requests / Re: Support for Web Services
« on: July 22, 2003, 05:48:04 am »
I would like to see this too, however I would like to get XSD import in first as that is a prerequist for wsdl import as wdsl is basicaly a superset of xsd.

It would be nice if ea could handle some of the newer web services languages such as BPEL4WS, which are all xml based. It would make EA a killer web services design tool.

3
Suggestions and Requests / importing XSD
« on: June 09, 2003, 07:36:12 am »
Is there any way to import an XSD, if not it would be a very nice capability and would allow round tripping on XSD projects.

4
Suggestions and Requests / Re: Support for compressed projects
« on: July 22, 2003, 05:45:05 am »
If you are using win2k or winxp, just set the folder you are storing your eap files in to be compressed.

5
General Board / Re: Question - .NET framework classes
« on: December 14, 2002, 05:40:51 am »
>>Is there a trick to importing this?  I encountered the >>ERROR: Root package not found at: >>XMI.content/UML:Model/UML:Namespace.ownedElement/UMLackage

I get the same error with the latest build, I have been carefull to makesure that the DTD path has been fixed up to match the place I have stored the All.xml file in, and I can now open the xml file in Internet Explorer, so the xml is fine.

6
General Board / Re: Problems with latest version under XP
« on: March 15, 2003, 01:30:37 am »
I have upgraded my laptop to 605 and its ok, however I have noticed something different, the menus on the machine with a problem are slightly more to the right, ie the submenu does not overlap the main menu at all, on the system that works, the submenu overlaps the main menu slightly. On the non-working machine there is gray band down the lefthand side of the menus, whereas the working system has no coloured band down the side.

I think this must be something to do with some desktop appearance setting that is confusing EA, ie its causeing it to miscalculate the position of the submenu. Im going to play with the appearance settings to see if I can find the setting that causes it.

7
General Board / Re: Problems with latest version under XP
« on: March 14, 2003, 04:18:05 am »
OOPS : PS:

Im running XP service pack one, on an NVIDIA card, with all the latest windows update security etc fixes.

8
General Board / Re: Problems with latest version under XP
« on: March 14, 2003, 04:16:16 am »
Its happening on all menus, both from the menu bar and from right-click context menues. interestingly I have discovered that with those context menues that are close to the right hand side of the screen, where the pop-out menu flys out to the right of the menu and not the left, the problem does not happen.

I have noticed that the menu visuals are slightly different in EA to other applications, that implies they are owner draw menus, Im wondering if there is some strange interaction problem going on here.

I have 604 and XP on my laptop where this does not happen, im going to update it to 605 on there too and see if the problem is specific to 605 or specific to my desktop machine.

Does anybody know if downgrading to 604 just by saving and restoring the ea.exe will work?.


9
General Board / Problems with latest version under XP
« on: March 13, 2003, 08:20:17 am »
Build (605)

Im having real problems with 605 under XP, when ever a menu has a cascade element, ie it pushes a submenu out to the side, i cant move into the submenu, as soon as the mouse moves off the main menu, the submenu disapears. I dont have the same problem with any other application under XP, and I did'nt have this problem with previous versions of EA

I have turned off all the "visual" effects on XP, such as menu shadows etc, but still have the same problem.

Anybody else experiencing this problem?.

10
General Board / Problems with C++ Parser
« on: February 01, 2003, 12:18:06 pm »
I have a number of software packages that I am trying to import from source. The classes in the package have an "attribute" in the class name ie

//
// Part of object controlled by metaobject
//
class GOODS_DLL_EXPORT object_header {
 public:
  ......
};

where GOODS_DLL_EXPORT is defined as

#define GOODS_DLL_EXPORT __declspec(dllexport)

The problem is that EA is creating multiple classes of then name GOODS_DLL_EXPORT instead of the real name of the class, I bleive this is becuase it is using the first token after the "class" keyword as the class name. It should use the last token instead and assume that the previous tokens are attributes.

I have tried this in 3.51 and its still doing the same thing.


11
General Board / Re: EAToolkit
« on: August 08, 2002, 07:39:30 am »
Steve, I cant get to this site either, I get no DNS resolution.

12
General Board / Re: How to keep track of datamodel changes
« on: September 11, 2002, 03:54:18 am »
The problem there is "changed from what", it would be great if every attribute could have a version IDE and comment attached and then a facility that allowed you show the diagram with element/attribute colours change that are different from version "XXX".

13
General Board / Re: Heading levels in RTF documentation
« on: August 09, 2002, 07:12:14 am »
incedently, why cant you set a description on a view, just curious.... ie the view has no "properties"

14
General Board / Re: Heading levels in RTF documentation
« on: August 09, 2002, 07:10:40 am »
(1) yes thats exactly what I had in mind... It also solves my problem for (2) I can set all the top level packages to level 1, and then generate the whole view, I can then set the root name to something like "Overview" and give it note text that describes the project.

15
General Board / Heading levels in RTF documentation
« on: August 09, 2002, 02:55:56 am »
I would like to see the following changes to the RTF document generator.

1) The ability to set the "heading level" of any package... Ie EA assumes that the node that you are generating rtf for is level 1, and all subsequent nested packages increment the level, I would like to be able to set the heading level of any package. This would make it easy to generate docs that integrate into our documentation standards.

2) The ability to suppress generation of RTF output for the root node, but still have the children generated. The root node is generaly a container view and is not really part of the documentation, for example a "custom view" called "requirements" results in "requirements" being heading level 1,  and results in all the childeren having rtf generated at the next level down. This puts all the documented packages at level 2 which is problematic for us.

3) EA has two options, elements as text or elements as a specific heading level (level 9). This causes us problems with element heading numbering (we are doing requirements with EA). I would like to have an extra option where elements can take either a specific level, or just the next heading level in the heading hierarchy.


Im currently running a SED script on the rtf output to try and fix up the output to match. The automation interface is not really an option for us as it envolves developing a specialised interface to word.

Pages: [1] 2