Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - spirax

Pages: [1] 2
1
Suggestions and Requests / Re: Multiple instances of element in diagram
« on: August 31, 2012, 09:41:43 am »
Just curious here - what is it about the way EA implements "multiple instances of an element on a diagram" that doesn't meet your needs?

On the rare occassions I need to do this, it works as I'd expect it to.

2
Suggestions and Requests / Re: Web interface into repository
« on: October 14, 2011, 01:50:24 pm »
This is something that some of EAs competitors already do - provide both a "rich client" executable, and a limited capability web client (eg ProVision).

The basic problem with the web report is that it creates pictures of diagrams. Whereas the web client would allow a user to double-click an element and read its notes and look at its properties and know that it is the latest (current) version.

I know EALite could do this, but that requires installation onto users pcs (not popular in corporate environments) and configuring to connect to the repository.

3
Suggestions and Requests / Re: Web interface into repository
« on: October 05, 2011, 01:07:56 pm »
The latter.  Generating html reports creates another static view of the models (which is quickly out of date).

There's really two things here. Firstly a web client for viewing the repository, with a simplified version of the project browser or model views window.

Then, the ability to view any diagram via a unique URL, ie the diagram has a unique identifier which is included in the url.

Both of these views should not be pictures (like the html report) but contain objects which can be interacted with (to a limited extent obviously).

This would make it much easier to integrate with corporate intranets/wikis etc.

4
Suggestions and Requests / Web interface into repository
« on: October 05, 2011, 11:27:23 am »
It would be great if there was a standard web interface into an EA repository, so that diagrams can be viewed just within a web browser, and perhaps minor text changes made.
Ideally, each diagram should be able to be found with a unique URL.

5
General Board / Re: Image libraries?
« on: September 18, 2012, 08:59:17 am »
There are a number of royalty free and public domain clip art libraries which I am looking at. However most provide their art as either PNG or SVG.

Since EA does not handle transparency in PNG files (as far as I can tell) that option is out. So I'm trying to find an easy way of converting the SVG files into something with transparency that EA supports. I presume WMF or EMF would be best - is that right?

I'm aware that I can import these one-by-one into a new EAP file, using the Image Manager. Then export them all as reference data into a new "Image Library" which can be imported into other repositories.

Any advice on the best/easiest file format to use for original clipart?

Thanks

6
General Board / Image libraries?
« on: September 13, 2012, 09:53:18 am »
Are there any other image libraries available for EA, or has anyone had any experience in loading other clip-art libraries into EA?

Thanks

7
General Board / Re: Find where images are used
« on: February 27, 2012, 06:40:01 am »
Thanks, I didn't realise I could run a SQL query against the repository.

Unfortunately that query retures zero results. But when I drop the where clause I see that there are around 38,000 results.  The object style column seems (mostly) to be comprised of values like this:
DUID=4D71987D;
The repository I'm searching against is a MS SQL server, not a local EAP file if that makes any difference.
Any other ideas?
Cheers

8
General Board / Re: Find where images are used
« on: February 24, 2012, 12:39:36 pm »
Not in version 8 (build 862) there isn't.

Sorry should've stated that I'm using an older version  ::)

9
General Board / Find where images are used
« on: February 24, 2012, 10:34:42 am »
Hello,
does anyone know of a way of finding where alternate images have been used?

I have a number that have been added to the image library, all named Image<somenumber> which I want to know where they are used so that I can either rename them or delete them.

Clicking the 'Delete' button in the Image Library tells me that the Image is used by 1 Element - but doesn't tell me which one or where it is.

Thanks

10
General Board / Re: Linking diagrams
« on: October 14, 2011, 01:34:00 pm »
Most elements can be turned into "composite" elements, which creates a diagram just for that element. Double-click it and the new diagram opens.

Many elements also have a Files property, allowing you to link to an external file (on a server) - but only accessible via the dialog box.

You can also add text hyperlinks to any diagram which link to any other diagram or external url.

11
General Board / Re: Scenario Notes??
« on: April 20, 2011, 10:52:35 am »
These are note elements linked to the use case scenarios.
To create one:
  • Drag one of the existing use cases onto the diagram,
  • then add a note element to the diagram
  • Now drag a note link connector from the note element to the use case.
  • Right click the connector and choose "Link this note to an element feature" and in the dialog box that opens, select Scenario as the Feature Type, and choose the scenario from the list (eg Basic Path).

When done, delete the use case from your diagram. The note and scenario remain.
 8-)

12
General Board / Get value of inherited tag value in RTF
« on: March 04, 2009, 01:16:32 pm »
Hi all,
Can someone tell me how to get the value of an inherited tag value into an RTF template?

EG. Create an object, add a tagged value.  Now instantiate that object onto a diagram in another package. Create an RTF template to render elements in that package, and try to get the value of the original tagged value.

The 'valueOf' function only appears to work for tagged values belonging to the instance - not those inherited from the original object.

Thanks

13
Bugs and Issues / Javascript error in Generated HTML report
« on: November 14, 2012, 06:58:10 am »
Generating an html report seems to work ok, using default settings.
However when I click the 'View' button, the page does not load. The error is:
Webpage error details

User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 5.1; Trident/4.0; .NET CLR 2.0.50727; .NET CLR 3.0.4506.2152; .NET CLR 3.5.30729; InfoPath.2; .NET4.0C; .NET4.0E)
Timestamp: Tue, 13 Nov 2012 19:46:59 UTC

Message: 'undefined' is null or not an object

Line: 366
Char: 2
Code: 0
URI: file://<path to output dir>/js/displayToc.js

Using IE8 dev tools, this is what I see (lines 365 - 366)
function initPreLoad(content)
{
      var preload = document.getElementById('IndexHeader').parentNode.insertBefore(document.createElement('div'),
            document.getElementById('IndexHeader').nextSibling);
[highlight]      preload.id = "Preload";[/highlight]
The highlighted line is line 366.

This happens regardless of which package I select to generate from.

EA 9.3 Corp Ed, MS SQL Server repository.

Any ideas on how I get the HTML generation to work again?

--
edited to show contents of line 366 of displayToc.js as per error message

14
I'm using the internal (to EA) document template editor.

While there is a menu item called "Edit page header/footer" it only allows editing of the first page header. There is no menu item (that I can find) which switches the editor to the second/follow-on page header.

All I can do is delete it and start again - resulting in unnecessary re-work.

These templates are in a shared repository (MS SQL) - not a standalone EAP file. So I have no idea where they are and would prefer not to try to edit them outside of EA.

Thanks

15
Automation Interface, Add-Ins and Tools / RTF report  template headers
« on: October 14, 2011, 01:29:49 pm »
Hello,
anyone know how to edit an existing header in an RTF template, when there is both a first page header, and a standard header?

The only one which displays is the first page header - which is not the one I want to edit. It seems the only way to "edit" it is to delete it and create it again - is there another way?

Pages: [1] 2