Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - fluxtah

Pages: [1] 2 3 ... 10
1
Suggestions and Requests / Re: Rich Text for UC descriptions
« on: June 22, 2004, 04:30:46 am »
Cool, no probs, I started working on a structured UC tool this week, I might have an alpha demo soon enough, however it's early days though I think I am determined now to develop something that follows the structured UC in usecasemodeling.com book closely.

2
Suggestions and Requests / Re: Rich Text for UC descriptions
« on: June 19, 2004, 12:29:07 pm »
Thomas, link to the software: http://www.serliosoft.com/casecomplete/

I only checked out the 8 minute demo, I was quite impressed however, I could knock something up similar with visual studio, also the price tag on casecomplete is a joke compared to what EA offers only at a fraction of that price.

But the features really do support a more structured UC approach.

Ian

3
Suggestions and Requests / Re: Rich Text for UC descriptions
« on: June 18, 2004, 07:00:35 am »
I have just been checking out a peice of software called casecomplete that provides a lot of functionality that falls inline with the style of http://www.usecasemodeling.com book.

The software does'nt look like it has major advanced features but just enough, however the price tag isnt to good :(

I am really thinking about developing my own use case modeling tool that can be used alongside EA possibly with XMI import/export.

It would be nice if EA use case functionality was improved so it works much like this tool casecomplete which really does offer a good use case authoring solution.

Ian

4
Suggestions and Requests / Re: Rich Text for UC descriptions
« on: June 08, 2004, 05:38:54 am »
Ah cool! I like the way that book uses private extension points and emphasising glossary terms, would be nice to follow this format within EA, I see some work arounds but none I am too happy with.

Ian

5
Suggestions and Requests / Rich Text for UC descriptions
« on: June 07, 2004, 11:01:50 am »
I would like to suggest adding some formatting options to UC descriptions in order to bold/italicise etc the UC text then it would definitely make working with www.usecasemodeling.com book easier, I have embeded html tags into some UC text as a text and the documentation generation shows this fine but it would make it quite difficult to maintain the UC text from within EA if the text is littered with tags... maybe turn the input box into a rich text box? :) with a checkbox to toggle between HTML or Plain Text UC descriptions.

regards

Ian

6
Suggestions and Requests / Re: .NET Framework Types
« on: March 12, 2004, 03:08:28 pm »
ah cool!

Did it make all the associations to the model from the reverse engineer? :]

regards

Ian

7
Suggestions and Requests / Re: .NET Framework Types
« on: February 13, 2004, 01:03:25 pm »
The eap should be on that above page I mentioned too download now, let me know what you think and how it can be improved.

- Fluxtah

8
Suggestions and Requests / Re: .NET Framework Types
« on: February 13, 2004, 12:39:09 pm »
hiya! certainly :] I will try to upload it, my CMS failed too it seemed :(

9
Suggestions and Requests / Re: .NET Framework Types
« on: February 13, 2004, 05:33:52 am »
I have the perfect .NET framework model base file, also created an XMI exporter to create an XMI file that is compatible with EA.

http://www.sunmoonsystems.com/downloads.php

It should not be to difficult to figure out, Let me know if you want my Base file which is a very tidy version of the imports, the EAP file zips down to 7meg but is 40meg EAP Model of the .NET Framework.

10
Suggestions and Requests / Re: HTML documentation suggestions
« on: March 10, 2004, 04:00:16 am »
I have one to add to this subject,

Automatic linking of glossary terms from use case scenarios/descriptions. - Not sure if this is easily done but would be nice if the HTML documentation output was able to scan for glossary terms and make them links or something to the glossary.

regards

Ian

11
Suggestions and Requests / Re: Visibility at the element level
« on: February 24, 2004, 01:05:39 am »
I can agree to that, however as axel says it is possible to hide class members, which will solve that huge XmlDocument problem.

- Fluxtah

12
General Board / Re: Getting started with Subversion
« on: October 09, 2007, 06:19:32 am »
This actually had me confused also, I think (s)he must create their own *.eap file, set up version control as you did and then import those packages that the other (s)he checked in.

So I guess, an *.eap file can be used as a host to version controlled packages but is not actually version controlled itself ???

13
General Board / Re: Debuging ASP.NET 2.0 Website on Vista
« on: August 17, 2007, 10:17:35 am »
cheers :D

I hope so to, I think Vista runs the asp_wp.exe process as w3wp.exe but I am unable to find it, it might be that the process runs under a different user, so thats why I cant see it, going to try logged in as an admin.

EDIT: Think I made that assumption to soon, seems w3wp.exe is related to IIS, which I dont use as most VS2005 web projects run in cassini dev server :(

Well, its not entirely important that it does debug just curious to see it working, quite impressive.

14
General Board / Re: Debuging ASP.NET 2.0 Website on Vista
« on: August 16, 2007, 11:01:00 pm »
Hiya mate,

Yep, been a long time since I posted here, I have never worked at a company that uses EA or UML at all so I only use it casually to get ideas for implementations.

I just started a new job that has quite a rigid documentation process in place so I thought it would be nice to compliment it with EA. (Although they dont know this!)

Fluxtah

15
General Board / Debuging ASP.NET 2.0 Website on Vista
« on: August 16, 2007, 10:42:17 am »
Hi,

I am having problems doing this, has anybody had any success.

I have created a basic ASP.NET 2.0 website in VS 2005 (via File > New website, not the new 1.1 style web application project they later released), reverse engineered it into an EA diagram and followed the guide in help.

I have set up my package build script as follows.



Directory: D:\Projects\Business\MyTestSite

Build

devenv.com /build Debug MyTestSite.sln
(where the .sln file resides in the directory D:\Projects\Business\MyTestSite)

Output Parser: Microsoft.NET

Run
http://localhost:50003/MyTestSite/Default.aspx
(I Have tried it without Default.aspx in the path)

Debug
attach

Use Debugger: Microsoft.NET 2.0



On Vista, I cannot find asp_wp.exe so I am trying to attach to WebDev.WebServer.EXE

I have a simple Default.aspx page that I have a debug point in, when I run, it just pauses for 10 seconds then ends, and it never hits my breakpoint.

Can anyone see what I might be doing wrong?

Any help will be much appreciated!  ;D

Fluxtah

Pages: [1] 2 3 ... 10