Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Fintan

Pages: [1]
1
Suggestions and Requests / YABBC - insert image
« on: October 02, 2003, 12:39:12 am »
Hi Sparx,

Is there a way to insert an image into a topic message on the forums (fora??) without having to reference a live web site?

I do not have a live web site where I can throw up gifs of diagrams, and therefore cannot include them in any posts that I make.

Many thanks,

Fintan

2
General Board / Feature Request - Hide specific attributes / op.s
« on: March 04, 2003, 02:46:03 am »
Hi,

I would like to see the option to choose exactly which attributes and operations to show or hide, rather than using the access privilege (private, public, etc.) which is too general for my use.

Many thanks for considering this,

Fintan

3
General Board / Import Access source code
« on: February 26, 2003, 07:53:27 am »
Hi there,

I have an Access application that I need to analyse (Original programmer has retired - no documentation) in order to be able to maintain the code.

I used EA to import the table definitions.

My question is this - Can I import the code - logic in modules and queries similar to how I would import VB code?

Many thanks for your help,

Fintan

4
General Board / Hide Attributes from reverse engineering
« on: February 05, 2003, 04:39:20 am »
Hi All,

I have just forward engineered some code from my class diagrams and it works great.  In my class I have not specified the links to other classes as attributes.  EA picks this up perfectly and adds the attributes to the code. :) Every thing is good this far

In the code I have changed the signature of some methods and tried to reverse engineer the class from the code module.  However when I do this the attributes which are links to other classes are now shown in the Attribute compartment.  I would like these "link" attributes to remain hidden, but other attributes to still be shown when I import from a code module into the class.  Is there any way to do this?

On a general note :  is there a way to show & hide individual attributes / operations

BTW I am using build 589 - does version 3.51 solve these problems for me?

Many thanks,

Fintan

5
General Board / EA -> Rational Rose
« on: January 24, 2003, 04:15:43 am »
I have been trying to Export the Use Case model to xml and then Import it to Rose.  I have downloaded and installed the Unisys/Rose UML add-on for Rose.

In EA in Local Options - XML Specification I have the following :
Default XMI version = Rose
Format XML output
Write Log
Use DTD

Code Page = 'windows-1252'

and have set my default XML directory to 'D:\XMLXfer'

When I export the Use Case Model I use the following settings :

No Stylesheet specified (left blank)
Export diagrams
Use Unisys/Rose Format
Format XML output
Write Log file
Use DTD

I get the following error message when I try to import the file into Rose
Code: [Select]
Parsing: D:\XMLXfer\AddEP.xml: Error: An exception occured! Type:RuntimeException, Message:Could not create converter for encoding: windows-1252


When I change the encoding in the file to "UTF-16".  I get the following message
Code: [Select]
Parsing: D:\XMLXfer\AddEP.xml: Error: Unknown element 'UML:Multiplicity'

And Rose asks if the UML.DTD is in the same directory.

The files in D:\XMLXfer are :
AddEP.log
AddEP.rim
AddEP.xml
Model.dtd
UML_EA.DTD
UML13.DTD
UMLX13.DTD
UMLX13-11.dtd

Note NO uml.dtd file.

Finally the question - Can anybody tell me what I am doing wrong?  What am I missing?

Thanks in advance,

Fintan

6
General Board / Link note to message
« on: January 15, 2003, 03:53:22 am »
Hi All,

I am having a problem linking a Note to a message on a sequence diagram.  No matter how hard I try I cannot get the link to connect from the Note to the message. :(

The only work around that I have found is to link the Note to the closest object and move the link end so that it looks like it is pointing to the message.

Any suggestions?

Many thanks,

Fintan

7
General Board / Collaboration -> Sequence -> Class
« on: January 07, 2003, 07:48:20 am »
Hi everyone,

I am looking to move from Rose to EA, but I have run into major problems, probably due to my lack of understanding rather than EA itself.

The way that I do my UML diagrams is that first I draw a Collaboration diagram, then I draw the corresponding sequence diagram, and lastly I draw the Class diagram.

In Rose I can draw the Collaboration diagram, and when I draw the sequence diagram the messages from the appear as messages from the sequence diagram.

When I add a message to elements copied from the workspace to a sequence diagram - the "New" button is disabled.  I cannot figure out how to add a message to the class.  Can someone explain how to do this please?

For the Class diagrams I cannot figure out how to show the classes with the operations and attributes showing.  Even if I can add new messages in the sequence diagram, and I drag the class from the workspace onto the class diagram (with or without Ctrl+K) the operations do not show on the class diagram.  Can somebody tell me how this works please?

Many thanks,

Fintan Conway

8
General Board / Display operations in boundary Class
« on: January 08, 2003, 04:21:59 am »
Hi,

I have created boundary and control classes in collaboration and sequence diagrams.  They were created as objects and converted to Class type.  However these classes show up in the Logical View diagram with the boundary and control icons.  I would like to see the operations and attributes for these classes - listed like ordinary classes.

Is there any way to do this?

Many thanks,

Fintan

9
General Board / Convert messages to operations
« on: January 07, 2003, 05:32:41 am »
Hi All,

Is it possible to automatically convert messages from Collaboration and/or Sequence diagrams into operations of the classes that they point to?

I cannot find anything that can do this in EA.  This seems like a simple process to automate and would reduce the amount of duplicate work that the modeller would need to do.

Have I missed something? ???

Regards,

Fintan

10
General Board / Import & Export XML
« on: December 19, 2002, 10:07:24 am »
I am getting very frustrated with the import / export facility in EA.  I export a small simple use case view package to an xml file and then I open a new file and try to import the same xml file.  EA gives me a message saying "Error  Code=0xc00ce014  Source = Line 76; char = 31   Error description = Element content is invalid according to the DTD/Schema.  Expecting #PCDATA,XMI.reference". >:(

This combined with the fact that it does not automatically convert collaboration diagrams to sequence diagrams, or keep the links between objects when placed on a new diagram makes this a completely useless product.

I thought that I had found the 'holy grail' - only to find that EA does not live up to its promises.

If anyone can provide a remedy for these problems I would be most grateful.

Regards,

Fintan

Pages: [1]