Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - molla

Pages: [1] 2
1
Suggestions and Requests / Printing project issues
« on: December 06, 2004, 02:55:57 am »
The RTF file generated from Project Issues contains all issues, even if the Status Filter is put on. I would like to have an RTF file that has only the filtered issues. Of course it would be nice to have other filters based on Developer and the Date of issue (or solution).

2
Suggestions and Requests / Acronyms
« on: September 21, 2004, 03:33:49 am »
I would really like to be able to produce an "Acronyms" section from the Glossary. Now I do a trick like using the "Technical" type for acronyms and "Business" type for the actual glossary items in the RTF files that I produce. In many of the documents I create from EA, I have to have the two sections separately.

3
Suggestions and Requests / Visual Indication of locked elements
« on: August 10, 2004, 04:13:55 pm »
When a package of element is locked, with security enabled, there is no visual indication that it is locked, apart from the fact that for example, the OK button will be disabled when you open the dialog for the package or element, thus disabling any edits. It would be nice to see which elements are locked and which are editable.

4
Suggestions and Requests / Locking newly created packages
« on: August 10, 2004, 04:16:00 pm »
When we create a new package, view or root node, the newly created element is not locked, so we have to explicitly apply lock to the element.

I think it should be locked by default, since if I create a new element, I will probably do something with it (and not leave an empty package floating around, for example)

5
Suggestions and Requests / Matrix Profiles
« on: September 16, 2003, 02:27:11 pm »
I would like to have RTF or HTML generation for Matrix Profiles as well. I think Matrix Profiles are one of the most important tools we can use when modelling with EA. Currently we can only save them as comma-separated text files.

Dr. Levent Mollamustafaoglu

6
General Board / MDG Link for Visual Studio
« on: October 04, 2006, 07:01:07 am »
I tried to find the link to this new 2.5 Release, but the downloaded file shows Version 2.3 on it.

7
General Board / TestDirector / WinRunner interface
« on: April 28, 2004, 05:08:11 pm »
Has any one used EA in combination with TestDirector / WinRunner? I am especially interested in a way to transfer the requirements documented with EA to TestDirector (save for re-typing them in)
???

8
General Board / Subactivities
« on: December 13, 2004, 03:59:01 am »
When I create a sub-activity, it creates an embedded activity diagram for the sub-activity, so that when I double-click on the sub-activity, it jumps to the relevant diagram.

This is fine, especially to describe a hierarchical structure of processes and/or activities that all have their own diagrams.

The problem occurs when you want to use these in a diagram. If you use the "simple link" to refer tothe process/activity, then this double-clicking will be active. But, if you insert some links between these elements in that diagram, then the activities/processes will permanently get that link. (e.g. You use a "flow" between two activities in a diagram) Namely, if I use two activities - that are linked in a diagram - in a new diagram, the link will automatically appear.

If I want to link activities/processes differently according to which diagram I use them in,  then I have to use instances - namely "Actions" as it is now possible in Version 4.50. However, double-clicking on Actions will not make you jump to the relevant diagram for the activity from which the Action is derived. I am not sure if there is any guidance in UML 2.0 documentation for this, or maybe this is an EA topic only.

9
General Board / Labels on diagrams
« on: June 25, 2004, 05:40:55 am »
Does anybody know how to get rid of the labels on diagrams? (e.g. "ad Diagram_Name" for activity diagrams, "od Diagram_Name" for object (class) diagrams and so on...) >:(

10
General Board / Associations and attributes
« on: August 27, 2003, 04:11:24 am »
When we define a named association between two classes in EA, this becomes an attribute in code generation, but is not shown as an attribute in the RTF document generated. In this case the code and the documentation do not match. The association is shown in the documentatioin in the list of associations for the class, but its name is not displayed, and it is also not listed within the attributes.

Am I missing something obvious?

Thanks,

Dr. Levent Mollamustafaoglu

11
General Board / Paper size in RTF
« on: February 23, 2003, 04:06:00 am »
I am using the RTF document generation extensively. I have a strange problem when the generated RTF document ends up having the "Letter" paper size, whereas I have set everything to "A4" in the EA model. I have gone through it severla times, but I could not find out where the "Letter" size may have been set. I did not see any explicit setup for RTF generation paper size.

I use the RTF file as a subdocument to a master Word document that sets up the format, page size, etc. that is required and therefore the RTF file screws up my setup with its Letter setting.

12
General Board / System failure during RTF file generation
« on: February 24, 2003, 04:59:46 am »
I have started having the weirdest failure during RTF file generation with EA. I am using Build 601, Corporate Edition, on an XP portable. I have a model which is quite complex, lots of diagrams. I generate RTF quite frequently, since it produces the main body of an SRS document. When this failure occurs, the software goes into a loop while generating the RTF version of a diagram and does not come out of it. The strange thing is that EA can not be killed even through the task manager. The only way I found to go out of this situation is to take the battery off from the portable and restart the session! I noticed that the diagram it seemed to get stuck in is a dummy diagram, meaning that I define a "boundary" object and attach a JPEG file as apperance, so that the diagram actually displays an image. This is a way to capture non-UML figures or drawings toyour model.

It seemed to me that EA got stuck on one of these digrams (I have 2 or 3 of those). This problem does not persist, and only occurs once every 10-15 RTF generation activities. It may have happened when I produced the RTF file after several updates have been applied to the model, but I'm not so sure.

Any ideas?

Levent M.

13
General Board / Stereotype icons in RTF & HTML
« on: July 11, 2002, 01:24:54 am »
Stereotype icons (and some other icons for the packages) disappear when an RTF or HTML dicument is generated. (Tested it on your new, excellent Sample model)

14
General Board / MS Installer Problems
« on: July 11, 2002, 02:44:28 am »
We were able to use the new MS-Installer based full version installer successfully on Windows 2000 and Windows XP. But, we get an error message stating that we have an old version of MS Installer and should install a SP, when we try it on a Windows NT 4 machine with SP6. It already has Office 2000 installed. We tried to install the MS Installer package itself, Windows NT SP6a and the MS Installer that you have links to. All failed. We had to download the patch and replace the executable, but a full installation is better sometimes (with the new sample, help,etc.)

Any ideas about the problem?

15
General Board / Call by reference to pointer
« on: March 28, 2002, 03:00:56 pm »
Check the following code, which has a method (testmethod) which returns a  pointer that is created in the implementation (theObject) by reference:

class testclass
{
public:
     testclass();
     virtual ~testclass();

     void testmethod(CObject* &theObject, CString *pName);
}


When reverse-engineered, the method testmethod loses the reference and the parameter name. If you forward-engineer, the method becomes

     void testmethod(CObject* prm1,CString* pName);


I have tried it with other reference parameters such as int& and it seems to work, but the treatment of pointer passing by reference seems to be wrong.

Pages: [1] 2