Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - SomersetGraham

Pages: [1] 2 3 ... 8
1
General Board / new forum
« on: January 07, 2016, 07:50:05 pm »
Hi
In the old forum I had set up notifications such that I received an email when a new topic was posted.
I thought that I had set the same in the new forum, but I only receive a small number of newly posted topics.
In the notifications section of my profile I have requested to be notified of all topics on all boards

Has anyone else come across this and how can I fix it

Thanks

2
Suggestions and Requests / Behaviour tab for operations
« on: April 10, 2012, 06:14:23 pm »
Hi
I can add a link to a sequence diagram in the operations behaviour tab.
I can have this shown in the diagrams containing the owning class
BUT I cannot navigate to directly to the sequence diagram
unless I missed something.
I would like to see this functionality in a future release of EA

Thanks

(feature request submitted)

3
Suggestions and Requests / Access to PDATA and other 'magic' fields
« on: March 11, 2010, 08:15:04 pm »
All
I have been trying to create a link between a note and an element feature via automation.
To achieve this I had to update the repository database directly.

It would be good to have access to these fields directly from the API

Would anyone else find this useful?

Graham

4
General Board / Team Review
« on: October 01, 2015, 07:54:33 pm »
Hi
We are experiencing problems with the team review feature for on of our projects.
For some users it takes 3-4 minutes for the team review window to appear and when it does EA is in a strange state - none of the menus have anything in them. An item in the team review window cannot be opened.

As I said this only happens with certain users

Can anyone suggest why this may be happening or what sort of things I can look at?

The said project is held in a SQL server repository

Thanks for any help you can give

5
General Board / C++ code generation
« on: September 15, 2015, 06:37:37 pm »
Hi
I have a model that we use for code generation and up til now this has worked perfectly.
Recently I added a new package and some classes, code gen for these works the first time around; however subsequent code generation duplicates what is already in the code file.

Even stranger is the fact that if I rename the toplevel package code generation succeeds.

So I deleted the original package and recreated it and code generation failed

EA seems to be holding some information about this package

Can anyone suggest how I might be able to track down what is going on?

The mode is stored on a SQL Server

Thanks


6
General Board / Reverse engineer error
« on: September 02, 2015, 07:48:36 pm »
Hi
When reverse engineering a class I am getting a dialog box with the following text

Code: [Select]
Microsoft OLE DB Provider for SQL Server [-2147217900

The multi-part identifier "t_operation.Object_ID" could not be bound

Does anyone know what this means?

I am using V12 with the Visual Studio plugin


7
General Board / c++ code generation for collections
« on: May 29, 2015, 08:37:30 pm »
Hi
I have been trying to get code generation working for collections.
In the C++ source code engineering tab of the options dialog I have added a default collection class
Code: [Select]
QList<#TYPE#>
As I understand it this should be used when I an association with a multiplicity of 1-*. Instead I get a data member defined as
Code: [Select]
*m_a;
There is no type
If I reverse engineer a class with a data member of QList<ClassB> the EA adds the correct association.

Has anyone experienced this before?

8
General Board / DDL generation for column constraints
« on: March 02, 2015, 11:19:27 pm »
Hi
I am using EA V12

I am trying to add a column constraint and the generate the ddl for the table
So I used the constraints button on the Table Detail of the tab of the table properties dialog.
I entered the required information and assigned the required column. However, when I generate the DDL the constraint is missing

The db schema I  am trying to replicate is
Code: [Select]
CREATE TABLE JobDetails(
    Job Name TEXT NOT NULL,
    JobType TEXT NOT NULL DEFAULT 'M' CHECK(JobType IN ('M','R'))
)

I have tried to reverse engineer the table but still no constraints.

Can anyone please help me to understand why this is not working

Thanks


9
General Board / only show certain connector types
« on: July 17, 2014, 07:36:51 pm »
Hi
Is it possible to only show certain connector types on a diagram?
I only want to show realisation relationships on a particular diagram

Any hints gratefully received

Thanks

10
General Board / stop code generation
« on: July 04, 2014, 07:41:47 pm »
Hi
Does anyone know if it is possible to have a class that can be marked in some way such the code generation option is not available

Thanks

11
General Board / Linked Document Templates
« on: June 10, 2014, 05:11:41 pm »
Hi
A while ago I created some Linked Document templates in the Project Resources tab.
Now I want to make some changes but when I open the document template it is locked against editing.
If I right click in the document I am supposed to be able to select other->Protect Lock, but this option is greyed out.

Does anyone have any idea how I can enable editing again?

Thanks


12
General Board / Team Review
« on: June 10, 2014, 01:07:56 am »
Hi
I am using the Team Review facility and have dragged a c++ header file onto the Package under review.
When I try to open this file from the Team Review it is opened with my default editor for c++ files. What I would like is for these files to be opened in EA.

Does anyone know if this is possible

Thanks

13
General Board / V11 default return value for operations
« on: May 03, 2014, 12:26:58 am »
Hi
I have upgraded to V11 and I no longer get a default return value when creating a new operation on a class

Has anyone else noticed this or is there a setting somewhere?

Thanks

14
General Board / Override parent methods
« on: February 05, 2014, 10:56:32 pm »
Hi
I am using EA 10.0.1010
I have a class which derives from a base class that has numerous abstract methods and want to override the base class methods
According to the help I should find a 'Overrides & Implementations' menu option when right clicking on the element.
I see no such option, but I can access via the keyboard shortcut (Ctrl+Shift+O)
Has anyone else noticed this behavior?

Thanks

15
General Board / showing signals on sequence diagram
« on: January 30, 2014, 10:54:20 pm »
Hi
I am trying to draw a sequence diagram
One of classes emits a signal that is processed asynchronously by another class.
How can I show that the first class is just emitting a signal (it does not care who catches and processes it) on my sequence diagram

Hope this makes sense

Thanks

Pages: [1] 2 3 ... 8