Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Knut Paulsen

Pages: [1] 2 3
1
Automation Interface, Add-Ins and Tools / Addin enabled or disabled
« on: January 13, 2017, 08:41:32 pm »
Hi guys,

Does anybody know where EA stores information about weather a given addin is enabled or disabled?
And is this setting per EA project or all or none?

br
Knut

2
I had a discussion with Geert about this some time ago, but can't find it now :-)

Anyway, if you are interested the GUID of the Model Default Diagram is stored in the database table 'usys_system' under property name 'Default Diagram', and the GUID of the User Default Diagram is stored in the database table 't_xref' with Name 'Default Diagram', Type 'User Setting', Client is the GUID of the user (from table 't_secusers') and Supplier is the GUID of the default diagram.

Cheers
Knut

3
Hi Guys,

I have a problem I just cannot figure out. In a reporting program I start an instance of EA and I want to use a Model Search to find some elements. The problem is that GetElementsByQuery seems to operate on the currently selected folder in the project browser, and since I am running without the user interface it is kind of hard to select a folder.

I have had limited success by calling Repository.RefreshModelView with the package id of my preferred package just before running the search.

Does anybody know how to force the model search to start in a given package?

Cheers
Knut

4
Automation Interface, Add-Ins and Tools / Result of a model search
« on: October 19, 2016, 11:42:47 pm »
Hi guys,

How do I get hold of the result of a model search? I want to do stuff to the elements I find.

The repository has a RunModelSearch method that displays the result in EA.
The Project Class has a RunModelSearch where you can select to not display result in EA. If I select not to, where does the result go?

Cheers Knut

5
General Board / EA project suddenly turned readonly
« on: July 01, 2016, 07:00:59 pm »
Hi guys,

The strangest thing happened today. One of our EA projects turned readonly, i.e. we cannot update anything, even with administrator priviliges. All other projects work as normal.
EA Client 12.1 talking to a MySql database via EA Cloud. Restarted MySql server, but it did not help. The are no locks visible in EA (from Project/Security/Manage Locks), but if I write a program that tries to update an element, it fails and the exception says Element is locked. Trying Release User Lock on packages and elements does not help.

Has anybody experiences something similar?

cheers
Knut

6
Using Repository.InvokeConstructPicker works fine for selecting elements and packages, but I need to select a diagram and it seems not to be supported.
But EA does show a dialog for selecting a diagram when you specify Diagram for the open action of a Hyperlink element.

Anybody know how to do this?

Cheers
Knut

7
General Board / Use of Enterprise Architect in a real project
« on: March 17, 2016, 01:11:49 am »
Hi guys,

I am a bit curious how you use EA on a daily basis. Consider the following scenario:

I kick off developers to work on Sprint 1.
I start working on requirements and use cases for next sprint, which includes changes to specifications for Sprint 1.
How do I avoid to confuse developers and keep my changes 'private' until we are ready to start sprint 2?

Cheers
Knut

8
Hi guys,

Is there a way to change the font size of elements in a diagram via the API? The DiagramObject.Style setting does not seem to cover this, at least not according to Thomas' book.

Cheers
Knut

9
Hi guys,

I was under the impression that both doubleclicking an element or selecting properties from the context menu would trigger EA_OnContextItemDoubleClicked. I am pretty sure this is how it used to work. But now it doesn't :-(

I have an addin implementing EA_OnContextItemDoubleClicked with a breakpoint on the first line. Doubleclicking and the breakpoint is hit, selecting properties and it is not. My addin overrides the property dialog, so it is pretty obvious that EA_OnContextItemDoubleClicked has not been called since it is the standard EA property dialog that is displayed in the case of context menu/Properties.

I have disabled all other addins to be sure nobody is playing with me :-)

I am using EA build 12.1.1226

Any ideas?

cheers
Knut

10
Automation Interface, Add-Ins and Tools / Replace diagramobject
« on: January 07, 2016, 11:15:27 pm »
Hi guys,

Background story: I tend to find lots of actors in various sub-packages that are really one and the same. So, I write a small program that can merge two actors, i.e. move all actor-use case links from one actor to the other, which works fine. Next step is to find all diagrams the obsolete actor is in, which also works fine.

Problem: I have the diagramobject representing the original actor and I have the new actor element. Is it then enough to set the element id of the diagrams object to the element id of the new actor? When I do this and then call Update() on the diagramobject I get a COMException with no message and an HResult of -2147221504

Any ideas?

Cheers
Knut

11
General Board / Import package from XMI
« on: August 17, 2015, 12:48:11 am »
Hi guys,
During XMI import I get several message boxes saying:
Microsoft cursor engine
Multi-step operation generated errors. Check each status value

Anybody who knows what this means and which status values to check?

Thanks
Knut

12
General Board / Accessing the EABASE.FDB firebird database
« on: February 02, 2015, 10:21:16 pm »
Hi guys,

I want to peek inside the ea cloud services database and I am creating an EA Firebird ODBC entry. I enter the name of the odbc entry and select the EABASE.FDB file in the Database field, but when I click test connection it says Open database XXX failed. Is there something more I need to do?

br
Knut

13
General Board / Project transfer and security
« on: October 05, 2011, 04:24:50 pm »
Hi guys,

I have small project where security is enabled and I use windows authentication. When I do a project transfer of this project, it looks like security is still enabled in the copy, but none of the users imported from window gets to logo on anymore. I even imported a new user from windows, but still no success.

I believe I have read something about this somewhere, but cannot remember where...

Any suggestions?

14
Bugs and Issues / Ea Cloud performance issues
« on: March 25, 2015, 12:26:54 am »
Hi guys,

We have a setup with our EA database server in Oslo, Norway and quite a lot of users in other locations. Users, especially in India and Ukraine, experience very slow response times. It varies during the day, kind of OK in the morning, unacceptable later in the day, e.g 15 seconds to open a property dialog.

Does anybody have any experience with EA Cloud in a similar setup? Any advice in this are will be greatly appreciated :-)

Cheers
Knut

15
Automation Interface, Add-Ins and Tools / User or model default diagram
« on: November 27, 2015, 07:59:07 pm »
Hi guys,

Is there a way I can find out about user or model default diagrams in EA_FileOpen?

Thanks :-)
Knut

Pages: [1] 2 3