Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - davisr_uk

Pages: [1]
1
The Open Group is working on an XMI specification for the exchange of models between tools. The review can be found here:
https://collaboration.opengroup.org/projects/archimate/documents.php?action=list&dcat=69

Currently we have a lot of models in the free Archi tool but have reached its limitations.

We have purchased several floating EA licenses but are unable to successfully import the Archi models as EA does not currently support the Open Group ArchiMate Model Exchange File Format (csv import has been equally unsuccessful). Are there plans to support the Open Group XMI format in the future?

2
General Board / UML Pattern Images
« on: June 12, 2015, 12:36:07 am »
I'm having a minor issue importing UML patterns into the EA database. They import with no problem but EA is not storing an image of the pattern saying that it was removed as the pattern was too large for the database field.

I've used the exact (and bigger) patterns in previous EA versions where this wasn't a problem. Anyone got any ideas?

3
General Board / Workspace Layouts
« on: June 01, 2015, 09:07:32 pm »
I'm having an issue with Workspace Layouts that hopefully someone can help with.

Basically I'd like a layout for Modelling and a layout for Team Review. The Team Review layout has the Model Mail window docked in the centre at the bottom of the screen and the Team Review window docked in the bottom right under the project browser. The Modelling layout does not include either window.

If I swap from Team Review to Modelling layout the Team Review window disappears (as I would expect) but the Model Mail window remains. If I close the window and revert back to Team Review layout the window does not reappear yet the Team Review one does.

This behavior makes the Workspace Layout function pretty useless as I have to constantly close and open windows; something I though layouts were supposed to prevent.


4
General Board / Active Baseline display
« on: June 03, 2015, 01:26:21 am »
Does anyone know of an easy way to find the currently active baseline for a package?

For example, if I have 3 baselines for a package and restore to version 2 how do I (or more realistically other team members) know that any changes made to this package are being made against version 2 (the "active" baseline) and not version 3?

I could also be missing the point on baselines so if that's the case please let me know - I don't find the Sparx documentation in this area very enlightening.

5
General Board / Automatic Horizontal Scrolling in Project Browser
« on: May 22, 2015, 08:37:50 pm »
Does anyone know how to turn this off and have a horizontal scroll bar instead? It is starting to infuriate me. I've looking in Tools->Options and can't find anything.

6
General Board / Model Search and Pattern File Locations
« on: October 01, 2013, 08:11:29 pm »
Hi Everyone,

Over this last weekend our working environment has been virtualised. This involved wiping local machines and now I connect through a virtual client to my desktop. So far, so good, but when I start Enterprise Architect, all my user defined searches and patterns are no longer available. I had assumed (incorrectly) that my searches and patterns would be saved within my model in the SQL Server database.
I do have access to a backup image of my old machine but only in terms of browsing files. Does anyone know where EA keeps user defined searches and patterns? If it's in the registry I may have a problem. Recreating them all from scratch will take days, particularly the searches.

*** UPDATE ***
Patterns are stored with the model, I was being dumb. I am still missing my searches though.

7
General Board / Archimate Elements and Compartments
« on: January 11, 2013, 03:00:35 am »
Does anyone know if it's possible for Archimate elements to display compartments?
For instance if I add a number of Tagged Values to an Archimate Technology Node I cannot display those values in a diagram - setting Tags to true in the Feature Visibility dialog has no effect. The tagged values themselves are stored correctly as I can see them in the Tagged Values area of the element's Properties dialog.

8
General Board / Archimate multiple object instances
« on: May 05, 2012, 01:09:26 am »
Hi,
Does anyone know if there is a way to have multiple instances of a model object in an Archimate diagram in EA? It is certainly allowed by the specification but I don't seem to be able to do it.
For example, if I have a business process that involves multiiple notifications to roles or actors via an email interface at separate points in the process. I don't want to have to link everything to the same email interface object in the diagram because it quickly becomes messy which isn't really the point of an Archimate diagram. Neither do I want to create multiple email interface objects in the model.
Is there any way around this? I've tried adding objects from the model as instances rather than simple links but the shape you just get a blank box rather than the Archimate representation.

9
General Board / Tagged Value Defaults
« on: January 30, 2012, 09:36:17 pm »
Does anyone know how I can set the default for a tagged value? Specifically, within the Archimate plugin whenever I create a new Role element its iconstyle tagged value is set to true, I would prefer it if this value defaulted to false each time.
I just don't seem to be able to find a place to change this behaviour. I thought perhaps the stereotype editor could help me but there doesn't appear to be an entry for Archimate_Role, or any of the Archimate stereotypes for that matter.

10
Bugs and Issues / Wrong Column type in MySQL DB for UML Patterns
« on: June 12, 2015, 10:02:07 pm »
I've been having some problems importing a pattern into a repository hosted in a MySQL database. At first I noticed that the preview images were being dropped which wasn't that big a deal, however I have since had patterns that I simply cannot import.

The reason seems to be that EA stores the patterns as XMI within a single column (PatternXML) on the t_umlpatterns table. The type of the column is text which has a limit of 64Kb. A basic ArchiMate pattern for a database node with 7 elements and their relationships is 300Kb of XML!

The column type really ought to be changed to mediumtext which will allow for up to 16Mb of text.

11
Bugs and Issues / Team Review Categories
« on: May 26, 2015, 11:08:40 pm »
Not sure if this is a bug or not, but I don't seem to be able to create more than one Team Review category.

After creating a category I am only able to create new Topics. The EA Help documentation has a screenshot that clearly shows several categories that have been created for Team Review but following the instructions (right clicking on an empty space in the Team Review window) I only get an option to create a new topic.

Anyone else seen this? Am I using it correctly? Would like to confirm I'm using it properly before raising a bug.

PS. Tested with both file and database repositories.

Pages: [1]