Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Marian N

Pages: [1]
1
Suggestions and Requests / "The Decision Model" in EA
« on: October 18, 2014, 01:27:49 am »
Hi All,

I have a question if you are planning on adding The Decision Model (http://kpiusa.com/index.php/The-Decision-Model/the-decision-model.html) or the Decision Model Notation (http://www.omg.org/spec/DMN/) to EA.
It will be great to integrate and manage BPM models with BDM ones directly in EA. Currently I am faced with the hard choice to look for an additional tool that handles both and I really want to stick with EA as I am keen fan on EA :-).

2
Suggestions and Requests / Re: Color Code Individual attributes?
« on: October 18, 2014, 01:16:44 am »
I am also looking forward to such a nice to have feature...

3
General Board / Re: How to convert class attribute into compositio
« on: February 09, 2015, 09:24:30 am »
Quote
Quote
Attributes and Associations (be it composite or not) are different things in UML (and in EA).
In EA there is very little connection between the two, but this doesn't come from UML. In UML they are extremely closely related. An association is two or more attributes although they may be owned by the class at either end.

Hi All,

As defined by the UML spec. and also clarified on this site http://www.uml-diagrams.org/property.html,
"Note that an attribute is semantically equivalent to a composition association; however, the intent and usage is normally different." - UML 1.4.2 Specification
"UML 2.x specifications allow to show an attribute using notation for association"
Association end could be owned either by
- end classifier, or
- association itself.

If we refer to the examples shown on the above website, the questions is:
If we have Diagram 1, with the homeAddress and visits attributes of the Patient class
shown using the association notation, is it possible to see them in Diagram 2 just as attributes within the Patient class compartment because Address and Visit Classes are absent?


4
General Board / Viewing Internal Artifact from the HTML report
« on: February 07, 2015, 02:59:17 am »
Hi Guys,

Please share an advice regarding the following issue.
I have created an EA Project with some links to Artifacts Internal (*.xslx files to be precise) using the feature as described: http://www.sparxsystems.com/enterprise_architect_user_guide/11/standard_uml_models/create_artifact_for_external_f.html
While I was in EA, it was very convenient to open & edit the files by double clicking on the Artifact.
The problem occurred when I exported the project to HTML format to share with my colleagues. It appeared that clicking on the Internal Artifact doesn't open the file...and...there isn't any link to do so either. So what are my options? I'd like to export the files along with the HTML generation and when any artifact is clicked to open it with the default program. Note that I checked the option "Hyperlinked Files" when I published to HTML.

5
General Board / Re: Traceability - Find in all diagrams
« on: February 05, 2015, 07:49:36 pm »
Thanks a lot, that will do.
 :)

6
General Board / Traceability - Find in all diagrams
« on: February 05, 2015, 07:19:48 am »
Hi Guys,

I'd appreciate some help with the following issue I have.
I need to generate a report (preferably Rtf/Docx) regarding the elements usage in diagrams. It should be similar to what one can achieve when an element is selected and the option "Find in all Diagrams" (Ctrl+U) is used.
The report should be run on a whole package and look like this:
Package "A" contains the following elements:
Element 1 is found in:
- Diagram 1
- Diagram 2
Element 2 is found in:
- Diagram 1
- Diagram 3

etc.

All clues are highly appreciated!
Thanks a lot.

7
Bugs and Issues / EA hangs when trying to jump from a Linked Req
« on: October 18, 2014, 01:10:14 am »
Since version 10, EA started to crash when trying to jump from a Linked Requirement (in Scenario & Requirements window) to its source in the Project Browser.
I am currently running version 11.1.1111 under Windows 8 and still experience this problem...
Please resolve this issue because it made our life so easier in the past.
If necessary I can provide you with a screenshot.

Thanks and best regards,
Marian Nedelchev

Pages: [1]