Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - brettonwoods

Pages: [1] 2
1
General Board / Default Visibility for Data Modeling Associatoin
« on: January 25, 2012, 01:11:28 am »
The context menu in data modeling diagram for an association has the †option Visibility > Set Label Visibility. It opens a form with all options selected. The all selected default makes data diagrams very noisy. When importing a db schema with many tables it is very tedious to manually change each association.

Is there a way to set default values for the Visibility > Set Label Visibility dialog? (I know you can suppress all labels for the diagram using diagram properties - looking for middle ground)

Thanks for any help.

Tom

2
General Board / Replication Dropping t_operationtag Table
« on: May 12, 2005, 06:41:03 am »
Hello,

I have a master and a replicant on two different machines. They synchronized OK for a while but now the replicant keeps 'loosing' the t_operationtag table and the two will not sync.

I tried a creating a new replicant and the problem reoccurs.

Has anyone had a similar problem?

Thanks

Tom

3
General Board / Embedded Elements In Documentation
« on: March 12, 2005, 09:43:22 am »
Hi!

I'm trying to generate documentation for an activity diagram and no matter what I try it always documents the embedded elements that result from creating an object flow between activities. The elements are presented in a table that will only confuse users. Is there any way to stop the table from displaying?

Thanks

Tom

4
General Board / Re: Sterotype Icon Library
« on: February 15, 2005, 06:21:29 am »
Reto

Try going to http://www.sparxsystems.com.au/uml_profiles.htm
and loading some profiles. They come with icons. The icons path will appear in the export flle in the MFPath value.

Example:
<DataRow>
<Column name="Stereotype" value="ProcessPackage"/>
<Column name="AppliesTo" value="package"/>
<Column name="Description" value="UML Profile NotesA SPEM Process Package"/>
<Column name="MFEnabled" value="TRUE"/>
<Column name="MFPath" value="icons\processpackage.wmf"/>
<Column name="Metafile" xmlns:dt="urn:schemas-microsoft-com:datatypes"

You can also try http://office.microsoft.com/clipart/default.aspx?lc=en-us
which has loads of clip art you can use with sterotypes or as an alternate image (from the context menu on an element select Appearence / select alternate image or Ctrl + Shift + W)

Tom

5
General Board / Re: Sterotype Icon Library
« on: February 14, 2005, 12:27:44 pm »
Not that I know of. If you just want to copy them and modify them for reuse they are easy to find.

Tools / Export Reference Data / Stereotypes. Open the xml file and search for 'MFPath'

Or just search your drive for *.efm *.wfm files.


6
General Board / Re: Sterotype Icon Library
« on: February 14, 2005, 07:15:34 am »
Reto,

I think what you want to do is described in the docs. See Modeling / UML Profiles / Depreciated Task / Save Diagram As UML Profile. Itís marked as depreciated but the option is still there on the diagram context menu.

Let me know if it works.

Tom

7
General Board / Re: Sterotype Icon Library
« on: February 13, 2005, 02:05:48 pm »
From the Menu Bar Select Configuration / UML / Stereotypes...
Choose a stereotype from the Current Stereotypes list.
Enter the path to a Metafile (windows wmf or emf file type)
or
Find a file by clicking the ellipse button.

The stereotype you need is not on the list you can create a new one in this dialog. You have to save the new stereotype then select it before EA will let you assign a windows metafile.

Tom

8
General Board / Re: Sterotype Icon Library
« on: February 10, 2005, 10:08:47 am »
I was looking more for something like a clip art library, Metafile Companion works well as a drawing tool for doing create / modify.

You can paste icons from Visio stencils into MC then save them as wmf or emf files that can be used in EA. I suppose as long as I have a Visio license that should be OK

One other thing is that stereotypes in EA with icons seem to behave inconsistently.

For example in an analysis diagram boundary, control and entity icons respond to the Use Stereotype Icons check box in the diagram properties but actor, process, information do not. They can only be displayed as icons.

Icons set by Configuration / UML / Stereotypes do not respond the diagram properties check box. This is not the desirable behavior for me, is it the intended behavior?

9
General Board / Sterotype Icon Library
« on: February 09, 2005, 02:08:34 pm »
Hi,

Does anyone know of a good library of icons in wmf, emf format to use with sterotypes? I'm looking for something to dress up activity, component and use case diagrams.

Thanks

Tom

10
General Board / Re: CVS - Problem Adding Package
« on: December 27, 2004, 05:17:40 pm »
Never mind. Fixed it. The import directory name, given during import, was not the same as the real directory name. Did a manual import from the command line then everything worked OK.

Tom

11
General Board / CVS - Problem Adding Package
« on: December 27, 2004, 04:50:44 pm »
Hi,

I am trying to place an EA model under version control using CVSNT on a Win XP system.

I set up the Version Control Configuration
Right Click a package and select version control Configure
Click control package, select the version control, save the file name etc.
Click OK
In the Add Package dialog click OK

Results in "Unexpected Response from CVS" - there is no version here "do checkout first"

I've been able to get a test project working by doing a manual import and checkout from the command line the doing the above steps but have not been able to get set up in any predictiable manner. Sometimes it works sometimes not.

Can anyone tell me the correct sequence for setting up CVS?

Thanks

Tom

12
General Board / XMI Import
« on: October 11, 2004, 10:19:00 am »
Hi,

XMI files imported into EA that were generated by Poseidon CE loose a lot of information. Class diagrams loose all of the layout information, activity diagrams do better on layout but still miss a lot of detail. For example object flows are imported as activity flows and constraint information is lost. The lost information is in the Poseidon XMI file but is not making it to the UA model.

Is xmi import a work in progress?

Tom

13
General Board / Re: Can Nor Find Association Class Icon
« on: October 19, 2004, 12:04:27 pm »
Found it - Tools > Options > UML Element Toolbox . Sorry to bother you all - I'm blind.

Thanks
Tom

14
General Board / Re: Can Nor Find Association Class Icon
« on: October 19, 2004, 11:58:43 am »
V 4.1 Build 734

Far as I know I have not changed anything. I've looked but can not find any configuration mechanism for showing or hiding tools.

15
General Board / Re: Can Nor Find Association Class Icon
« on: October 19, 2004, 11:15:15 am »
I have nothing between Aggergate and Assembly.

Pages: [1] 2