Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - kepNCI

Pages: [1] 2 3 ... 9
Thought I would post here before entering a bug report to make certain I am not missing something.
I have been going through my existing rtf document templates to see if anything has changed with v13.  In the rtf document editor, when I click within some text, the document edit ribbon updates the style name, font name, font size and the attributes under the font dropdown, however it is not updating the attribute icons.  For example if the text is bold, the font dropdown will reflect that it is bold, but the bold icon is not highlighted to reflect it is bold. More troubling is that the font color icon is does not reflect the current color not does its dropdown wizard to change the color.

This makes updating current templates difficult.

General Board / Re: Where to set Path Name variable in 13
« on: December 03, 2016, 08:55:24 am »
That's it.
I did not look that close at the Code ribbon, since I do not do any coding. 
Tend to think it is not in the correct ribbon location.

General Board / Re: Main menu in EA 13
« on: December 02, 2016, 04:51:58 am »
I may not be understanding you correctly, but if you mean that you always want to see the expanded ribbon menu...
- Do a right click on the menu tag area where the is no text It should being up an toggle option for "Minimize Ribbon"
- Turn off the option

General Board / Re: Color specific attributes of a class object
« on: December 02, 2016, 04:45:41 am »
I think you are referring to the list of attributes and/or tags (columns, if element is a Table stereotype) when you have set the options to show the Element Compartments for an object. If so, I do not think there is a way to change the font color or any other characteristics on a one-by-one attribute/tag level. As you noted, you can change the font for all attributes (actually for all Compartment text).
Only the Notes area gives more control of the font characteristics. 
It been awhile since I used V9, but I think this aspect has not changed.

General Board / Where to set Path Name variable in 13
« on: December 02, 2016, 04:31:38 am »
I keep a file called "Linked_Docs" on my local PC when I store all of the local docs that I reference in EA.  When relating (linking) a local file to an element, I would use the browse function to find the file within "Linked_Docs", which captures the full path name.  However I replace all of the full path name, up to and including "Linked_Docs" with a path variable that I had set up.  For example, instead of saving:
C:\Users\UserName\Documents\EA\Linked Docs\Folder\SubFolder\document_name.pdf
I would change it to:
This allows me to move the EA project file to another PC that may have a different fill path for the "Linked_Docs" without changing all of the saved related file links.

This continues to work in Release 13, but since they moved menu items around, I cannot find where to update the path variable.

Any clues?


Suggestions and Requests / Re: Beyond JET 4.0
« on: September 02, 2016, 06:02:17 am »
I just tested it. Like Access 2013 as Paolo stated, Access 2016 also reads JET 4.0 files. I therefore do not have a problem.
My "REAL" problem was my own error in that I was using a Jet35 eap project that I thought was JET 4.  I was testing this at home on my home PC which has Office 2016 and where I forgot to replace the EABase.eap file with the JET 40 version.  At work I am still on Access 2010 plus I know I am using the JET 40 base file in EA and thus did not encounter the error.

Geert:  Totally agree, but it is hard to teach an old dog like me new tricks. I have used MS Access for many years. I use it mainly as a quick application to create tools that I need. (I am far from being considered a good application programmer.) In this case I have a set of MS Access programs that reads our Network Config's SQL Server database to create MS Access database snapshot of our network. I then have another MS Access program that reads that Access database snapshot and compares it with a huge EA Project on SQL Server in which I replicate our network config.  In addition, the corporation tends to frown on using free ware.

All of you...Thanks for the input.


Suggestions and Requests / Beyond JET 4.0
« on: September 01, 2016, 01:42:25 am »
Since Access 2013+ no longer supports reading mdb databases, (and I assume MS no longer supports JET 3.5 and 4.0 databases), I was wondering if there are plans for eap files to start using newer versions of the jet engine databases.
I have used Access 2010 to link to eap files so that I can look at the database structure. I cannot do that with Access 2013 and greater. 

General Board / Re: copy/paste sounds
« on: March 05, 2016, 11:41:45 am »
That's what I do now.

Seems to effect my music streaming :<)

General Board / copy/paste sounds
« on: March 05, 2016, 05:13:11 am »
Is it possible to turn off the confirmation sounds when copy/paste packages?

If not, it would be nice to have an options where one can determine the sounds associated with EA.

Suggestions and Requests / Reset Project Home Default
« on: January 11, 2012, 08:19:24 am »
Maybe I am not seeting it, but I would like to reset the project so that it does NOT have a default/Home diagram. Once set, I only see how to change it to another diagram.

Would like to see 2 enhancements to Project Glossary:
1) acronym support.
- ability to denote one or more associated acronyms for a term.
- same acronym value could be associated with multiple terms.
- acronyms would be included in the glossary listing where term would be the acronym and definition would be the fill description of the acronym
- entry is identified as an acronym allowing one to create an RTF glossary document with options to include/not include acronyms in glossary or to create just an acronym glossary.
- full name description of the acronym could be futher defined, if needed, by referencing another glossary record. (see #2 below)
2) term cross reference.
- like an element's note field, the displayed glossary description field would have links to glossary terms.
- would not create links to itself.
This would allow one who is reading a definition to lookup terms used in the description. Also would help support #1 above where the full name of an acronym entry could reference another glossary entry that further defines the full name.  

Currently I have partially implemented #1 by creating an entry where:
- set Type field = "ACR"
- set Term = value of the acronym
- set Definition = full name associated with acronym.
The above solution has the limitations stated in an earlier posting in that I cannot create multiple entries for the same acronym due to the primary key enforcement of the Glossasy table. The earlier poster recommended using the type field as part of the PK, but in this case that solution would not help unless another field is created that identifies the entry as an acronym. I get around this by entering multiple full name values in the description for the acronym. Likewise in the description field of the full name's glossary entry, I include any associated acronyms.

Need a way to compare and possibly update a data model in one project a data model in another project, thus keeping them in sync, including baseline information in both projects and not loosing links.

On our MS SQL EA repository there is an EA project that defines our production environment, including appr 13 data models that were initially created via re-engineering (MS SQL and Oracle). For security reasons, the PCs that access the EA repository does not have access to our producion databases. So I have a eap project on a PC that does have access which I use to ODBC import to update the models,  comparisons to last baseline and then create new baselines. I would like to be able to replace/update the data models on the EA repository with the models from production.

Using package or element export/import via XML or via clipboard does not work because it create new models/elements. If I first delete the model on the EA repository project and then import the new model from the EAP (production) project, then I loose the baselines as well as I break any links to the original data model/diagrams (such as in other package diagrams or model document definitions.

Had the same issue. Was fixed when I updated Oracle ODBC driver to the latest r10 version. Was using the Oracle 8 ODBC driver, which as you stated, worked fine with SQL as well as with ODBC using MS Access and MS Visio. Even Vision was able to re-engineer the database.

Had to install Oracle 10 client in order to get the latest Oracle driver. In addition to creating new ODBC data sources with the new driver, One needs to make sure ORACLE_HOME parameter is set to the location of the new ODBC driver.  

Note: I do not recommend the following, but for non-EA related reasons, I was not able to reset my ORACLE_HOME and/or PATH. Insetad I took a risk and copied the v10 ODBC DDLs into the existing ORACLE_HOME file (as seen in my PATH), thus overwriting the v8 DDL files. I looked at the documentation on Oracle for Instant Client to identify the ODBC DDLs. This worked and I did not have to create new ODBC data sources.)  

General Board / Re: Object status colors displayed in diagrams
« on: May 27, 2015, 12:23:40 am »
Apparently the Update() function when called within a script, not only updates t_object.status, but also some display properties of linked objects on diagrams that are not updated when a diagram is opened.

When using MS Access ODBC to directly update t_object.status, I am not triggering the other functions performed in the update(). Thus I see the status change when viewing the object's properties, but the status color on any diagram does not change.  I was hoping that when EA opened a diagram, it would display the color of the object's current status, but instead it must be displaying the color as indicated somewhere else in the database that only gets updated via the update() function.    

General Board / Re: Object status colors displayed in diagrams
« on: May 23, 2015, 06:32:00 am »
I am on 12 (1214) and I still see the color. The elements, like requrements, that use the left as part of the box to show status color still works the same.  For other objects, like database tables, that rely on the box shadow, it is there, but difficult to see because the shadow is so thin.
I think it was v9 or maybe 10 where they made a change regarding the element's borders, but for some reason did not implement the entire change. It was explained that they were going to allow the user to define the placement of the shadow and the thickness, but that so far has not been done. So now we are stuck with a very thin line that does not even appear sometimes. On line, sometime changing the diagram's zoom will reveal the shadow.  On documentation, it is hit or miss.

I wish they would either pull the change back out or complete the change as intended.

So...back to my initial question... i was hoping you (or someone) might be able to tell me why just changing t_object.status (via MS Access ODBC) to "Mandatory", does not change the color displayed in the diagram. Assuming there is another place(s) in database that gets updated when one changes the status in the properties.

Pages: [1] 2 3 ... 9