Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - haltekx

Pages: [1]
1
General Board / Re: IIS + SPARX CLOUD, Installation problem
« on: October 28, 2016, 12:36:37 am »
That explains a lot.

But... i still have the service started with the same NT user from wchich I am trying to connect to Cloud (on localhost)

It should work?


And qestion - if start with NT\user, is other users in AD can normaly login to cloud?
The "work" (diagrams etc.) will be seen as they jobs? (not as job NT\user)


Thanks for explain, and sorry that i do not know any thing about EArchitect (true).
My job is to install it for client who used to use it only in EArchitect version, it
do not make me an expert  ;D

Thank You for helping me out, with that problem.





2
General Board / Re: IIS + SPARX CLOUD, Installation problem
« on: October 27, 2016, 04:12:17 am »
After change to HTTP MODULE (didnot helped)
i change to ISAPI MODULE again and...

i have only HTTP STATUS 500 ..

 :-X

3
General Board / Re: IIS + SPARX CLOUD, Installation problem
« on: October 27, 2016, 01:42:42 am »
Hmm - know every time i am trying to connect i have got:
"Database connection Error. Reopening connection to database"
...

was working - now is not working..
grrrrr

Any Idea?
-- Architect is connecting to database directly without problem..

4
General Board / Re: IIS + SPARX CLOUD, Installation problem
« on: October 27, 2016, 12:55:37 am »
It works with settings:

IIS - port 804.
sparxcloudlin.sseap - port 803
SSCloudService.config - port 803

1.
 'Invoke handler only if request is mapped to'  - unchecked /default was checked/
tab mappings: script. /default/

2.
I change to:
tab mappings: execute. /default/

working

3.
After option checked ->

 'Invoke handler only if request is mapped to' 

IIS connection to SPARX not working

I REALLY advise to change manuall, cause:
" Note: The 'Mappings' tab should be left with the default settings, that is 'Invoke handler only if request is mapped to' is not ticked."

is not acctullly true.

Also there is not mension about user who should start SPARX service (it is mension in troubleshooting only)


OK.


Moving on -> now trying AD, HTTPS.


Thanks for clue - It Helped me a lot!!!

 ;D




5
General Board / Re: IIS + SPARX CLOUD, Installation problem
« on: October 27, 2016, 12:04:02 am »
Hi,

I unchecked (default was checked!!) option:  'Invoke handler only if request is mapped to' and checked with Mappings tab to "script" /"execute"
(all 4 combinations)

Also i have:
sparxcloudlink.sseap:
port=804

SSCloudServices.config:
SERVER_PORT=803

iis (http):
port=804

I check/try to use IIS on port 803 -- IIS cannot start. (sparx listning on 803)

Any help?



ps.
Client require AD+HTPPS. On SPARX Web Server - it is working (on http)





6
General Board / IIS + SPARX CLOUD, Installation problem
« on: October 26, 2016, 03:57:21 am »
Welcome,

I am trying to setup IIS + Cloud.

After 3 days of help from SPARX (Thank you for tips) i figured out (by myself..) that instruction have some bugs
(like there is nothing said about which user should start sparx cloud service - only in troubleshooting mention...).
 >:(

Anyway..

Now I have working SPARX Cloud, connected to database, and Architect (trial) on the same server. They are working on ports 804, http - nprbl.

I configure IIS with module isapi, after it with module http (deleting isapi configuration) - but it still do not working... in both cases:
Architect answer: "The webservice is currently unavailable. Http Status Code: 404"
But on IE i can see on localhost IIS default webpage..
 :o

Look like IIS cannot go throuh HTTP/ISAPI module to SPARX Cloud...

Can any one say some help tips? I read that manual ten times so far..(and obviously www sparx manual pages)

Any one?

Greetings,
Haltekx

Of course firewall off
Of course Windows 2012R2 Standard + IIS8.5



Pages: [1]