Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mcamack

Pages: [1]
1
It worked, thank you very much! Not sure how I would've figured that out reading the documentation.

2
BTW, I am using Javascript and I have tried the line below, but it says EnumScenarioTestType is undefined... even though it changes text color to purple which means it recognizes it as something...?

Code: [Select]
var test = EnumScenarioTestType.stInternal

3
I've spent a few hours trying to figure this out... I know I'm missing something simple, but can't figure it out. I want to Generate Internal Tests for each scenario. I am obviously using the ScenarioTestType enumeration wrong, can anybody help? I am trying to use the stInternal enumeration. I'm at the point of blindly trying any combo of Repository, EnumScenarioTestType, ObjectType, .'s  , ()'s , and am totally lost now.

Excerpt of the basic code I'm using:
xmlguid = Project.GUIDtoXML(currentScenarios.GetAt(j).ScenarioGUID);
   //This returns: EAID_CF4FF1DB_0834_472e_ADD1_2A05843C12DF   
Project.GenerateTestFromScenario(xmlguid, stInternal)
   //This returns 0 indicating it failed and no tests are created



4
It worked! Genius!

Thanks  :D

5
I want to show a mapping of UseCases to Requirements in the Relationship Matrix, but I don't want hundreds of unlinked requirements to show up. I only want the ones to show up which I have linked with a trace arrow on a Use Case Diagram.

I came up with the SQL query below to find the requirement names for the ones that actually have an Abstraction trace to a Use Case. However, when I use this saved search as my 'Target' in the Relationship matrix, nothing shows up. Is this because the SQL query isn't returning an "Object" and is only returning the name? When I set the target to Requirements, they all show up (only some of which have an arrow showing a link).

SELECT O.name FROM t_connector C INNER JOIN t_object O ON C.end_object_id = O.object_id WHERE connector_type = 'Abstraction';

6
Thank you for the reply, but it turns out the schema file was not being run properly... which makes sense why it couldn't find the Tables. Problem solved.

7
We are working with EA from Windows 7 machines, but trying to transfer the EA project onto a Linux server PostgreSQL database. After installing postgres and running the script to setup the tables we try to transfer the project, but get lots of errors in the log similar to what I've copied below. It makes me think the schema was not setup correctly, but our Linux and Windows machines have updated ODBC drivers, is there a step I'm missing trying to do this between Windows and Linux machines?


Why does it start with removing data??
+--------------------------------------------
| Data Transfer model log file
| Generated by Enterprise Architect
| Source DBMS: JET
| Target DBMS: POSTGRES
| Created On : Thursday, 19 January, 2017
+--------------------------------------------
2017-01-19 11:56:26  Removing data in: t_rtf
2017-01-19 11:56:26  Removing data in: t_secuserpermission
2017-01-19 11:56:26  Removing data in: t_secusergroup
2017-01-19 11:56:26  Removing data in: t_document
2017-01-19 11:56:26  Removing data in: t_seclocks
...
...
...
ERROR: relation "usys_system" does not exist;
Error while executing the query
  ERROR: An error has occurred:
Microsoft OLE DB Provider for ODBC Drivers [-2147467259]

ERROR: relation "t_secpolicies" does not exist;
Error while executing the query
  ERROR: An error has occurred:
Microsoft OLE DB Provider for ODBC Drivers [-2147467259]

ERROR: relation "usystables" does not exist;
Error while executing the query

8
Nevermind, I found out how, but I'm going to post it here if it helps somebody else because I didn't find the answer on this forum.

Search for the xml file in your working copy of the repository, right click and use the SVN menu to Get Lock and use the Steal Locks option. Going back into EA, I was able to check-in now, the program almost crashed, gave me some error message, but now the folder is locked and I can "check out" once again.

9
I created an SVN server on my desktop and then checked out a working copy there as well. Within EA, I set it up to use SVN and then checked out a package. I opened, edited, closed EA multiple times and performed an SVN commit from the windows file explorer, all without ever checking that package back in. Now, when I try to check in that package it gives me an error saying:

Subversion reports the following error:
svn: E195013:
'filepath\blahblah.xml' is not locked in this working copy

Is there any way to fix this?

10
Thanks very much, I will give this a try!

11
Hi!

I am trying to figure out how to auto generate and export an ordered list of the operation calls for one of the lifelines as they would execute when you run through a sequence diagram. Any help would be greatly appreciated!

Pages: [1]