Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - steve.m

Pages: [1]
1
Bugs and Issues / Difference between List and List View in Wireframe
« on: April 30, 2015, 10:00:26 pm »
Hi,

I am looking in to the wireframing tools. I would like to know the difference between a List and a List view and what cases they are meant to be used.

I see in the List, I can edit the list values. The list view does not provide such options. The odd thing with the list view is that the default object when placed in the diagram is horizontal. Is this expected behavior?


2
Bugs and Issues / XSD Schema generation hangs
« on: April 30, 2015, 09:56:16 pm »
I am attempting to generate a simple XSD. As per the documentation, I select the package and Package - XML technologies and generate XSD. It gets as far as displaying "Loading package information" and just hangs.

This is happening on release 12 build 1213

Any suggestions or tips would be appreciated.

3
Uml Process / Re: Adding Parts sections to Block Diagrams in Sys
« on: May 13, 2015, 11:58:31 pm »
Thanks Robin,

As I say, I am new to SysML and getting a bit bogged down with the different notation styles between revisions. There is just a discrepancy in the resource material I have and the way it was being displayed in EA. If the consensus is that the compartment should be "properties", then I can work with that.

Regards,
Steve

4
Uml Process / Re: Adding Parts sections to Block Diagrams in Sys
« on: May 13, 2015, 10:14:48 pm »
Quote
Also note that in SysML 1.3 Parts are known as Properties and the Block compartment is labelled Properties and not Parts


Although you had it in bold, I only took note of it now :-[ That the compartment is labelled as properties and not parts. This is the base of my question.

In the EA Example, the compartment is labeled as parts which is what was confusing me.

I have a work around though I don't know what issues will be down the line. The workaround is to create a block diagram from under SysML 1.2 and there the "part blocks" will be in a compartment labeled "parts".

Thanks.

5
Uml Process / Re: Adding Parts sections to Block Diagrams in Sys
« on: May 13, 2015, 09:19:47 pm »
Thanks for the reply Phil.

I am on 1213 and just quickly tried out what you suggested.
I created a new EAP and selected SysML 1.3 - Systems Engineering Model from the model wizard
I opened the generated Design Module - Design Model diagram
Added a block and named it "System Block".
I then added a second and called it "Sub System".
Created a part association between the two blocks (black diamond at the System block side)
Added a role called sub to the "Sub system" side.
Closed and re-opened the diagram and the System block does not contain "Parts". It only contains "Properties" section with the entry of "sub: Sub System".

I tried the above with a new Block Diagram also after selecting "EXTENSIONS - SysML Technology - Load SysML Technology".

I am just not sure what I am missing.

Regards,
Steve

6
Uml Process / Adding Parts sections to Block Diagrams in SysML
« on: May 12, 2015, 05:10:49 am »
HI,

I am new to the SysML component of EA and am having trouble working out how to model parts on a block. I can see on the example that the main block as a parts section. In the Internal Block Diagram, the parts are modelled with the property stereotype. In my model, no matter what I do, they all appear in the block in the properties section - even if I use a Part form the SysML 1.2 or 1.1 tool boxes.

Is there any definitive tutorial which can help with this - apart from the sample EAP as that does not show how these models were achieved.

Any feedback would be appreciated.

Pages: [1]