Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Robert Lelieveld

Pages: [1] 2 3
1
Solved!

Found that this can be done by creating a SQL fragment and using the .Formatted option in combination with HTML code.
Nice.


Kind regards,
Robert

2
Hi Anna,

While trying to create my own hyperlinks I found that for this you could:

1. Create a fragment
2. Use a SQL fragment
3. Add the fields to the custom section

In the template:
1. Add the fragment template

When the query of the SQL fragment return no records, no output is generated.

Kind regards,
Robert

3
Hi,

Is there a way to generate a link using tagged values?

Something like this:
Link Text   {Element.valueOf(value1)}
Link Code  https://www.link.to/{Element.valueOf(value1)}

Inserting a hyperlink with the above value just create a hyperlink named '{Element.valueOf(value1)}' pointing to 'https://www.link.to/{Element.valueOf(value2)}'.
Ideally, when value1 is not set, the link is not created at all.

While browsing the forum, I noticed an option to link to elements using GUIDs.
However, no word on generating links like this.

How could this be accomplished?

Thanks!


Kind regards,
Robert

4
I ended up looking at the first template and when selecting both:
Package -> Diagram -> Element, as
Package -> Element -> Requirement
the document contained elements and its requirements (formatted) without SQL statements.

As I noticed I would like to only have a subset of the diagrams elements in the output, I am now looking into virtual documents.

Good stuff!

5
While I can retrieve all data, the text in the requirement is added without conversion.
In other words, the markup in HTML is put in the document without actually marking up the text.

Do you know whether there is a way around this?
Or maybe better to use the virtual document option?

6
Hi Geert,

Thanks for your quick reply!
I will check out the fragment custom query and see what is possible.

- Robert

7
Hi,

When elements are part of the package being documented, it is possible to use its requirements by enabling:
Package -> Element -> Requirement

To use a diagram as subset it is possible to use linked elements, and thus enable:
Package -> Diagram -> Element

Is it possible to somehow to get to the requirements of the elements in the diagram?
Thank you.

Kind regards,
Robert

8
Bugs and Issues / Re: Project transfer empty
« on: November 23, 2016, 06:41:46 am »
Same problem here. It turned out that the table usystables, which lists all EA tables, was empty in the source project. After I populated this table with data from another EA project I could transfer the source project to a file.

Yes, this indeed fixed it!

After that, I had an issue with the t_taggedvalue table that apparently contained an orphaned value. You can recognize this because the ElementID is NULL.
Just remove it.

Then, the project transfer worked again without issues.

Looking at the various types in the project, it seems a lot more is missing somehow. I'm now analyzing the database against the base.sql file available in the download section to search for differences and applying them to the database.
No idea though, why many types etc are not in the database.

Kind regards,
Robert

9
Bugs and Issues / Re: Project transfer empty
« on: August 16, 2016, 08:50:47 pm »
In the options I found a flag saying to Use JET 4.0 - requires restart.
With or without the flag doesn't change the outcome of the data transfer action.

Who came across this same behavior and was able to solve it?

@Roy: were you able to solve it?


Thanks,
Robert

10
Bugs and Issues / Re: Project transfer empty
« on: August 11, 2016, 09:32:45 pm »
Same issue here, when trying to transfer data from the DBMS to an .eap file the process completes immediately. Nothing was actually transferred.

Project Transfer
- DBMS to File

Source Project
- Microsoft OLE DB Provider for SQL Server, 'Test Connection' is OK
- security on the database: public, db_datareader, db_ddladmin

Target Project
- test.eap, just created, saved and closed

Contents of the log file:
Code: [Select]
+--------------------------------------------
| Data Transfer model log file
| Generated by Enterprise Architect
| Source DBMS: SQLSVR
| Target DBMS: JET
| Created On : Thursday, 11 August, 2016
+--------------------------------------------
2016-08-11 13:12:10  Removing data in: usystables

EA version 12.1.1224 is used.
Database Version: 7.0
SQL Server 11.0.5623 is used.

There are no issues with working with the DBMS version, via a server connection or via a cloud connection.
Restarting EA does not fix it.

What could be wrong?

11
General Board / Re: Draw a 'hop' when links are crossing (like Vis
« on: November 03, 2015, 01:05:36 am »
Fully agree with trying to avoid crossing lines! ;)

Tried once more in Visio and it allows to choose from a range of line types (dashes, dots, etc).

As a workaround, I'll use the line thickness. While that makes (non-)crossing lines clearer, it looks a lot less attractive.

12
General Board / Re: Draw a 'hop' when links are crossing (like Vis
« on: November 02, 2015, 11:47:36 pm »
Indeed, the solid lines are drawn with this 'hop'.
I tried it with a quick ArchiMate diagram:


Would you consider this to be a feature request or a bug?

13
General Board / Re: Draw a 'hop' when links are crossing (like Vis
« on: November 02, 2015, 10:12:31 pm »
OK, I see.

How can I make an Information Flow be drawn solid?

When right clicking on an IF connector, it doesn't seem to be available in the context menu:
- Properties...
- Advanced
- Line Style
- Visibility
- Appearance...

Can't find it in the Current Connector toolbar menu.

Still learning EA  :)

14
General Board / Draw a 'hop' when links are crossing (like Visio)
« on: November 02, 2015, 08:14:02 pm »
Hi,

How can I make EA draw a 'hop' when connectors/links are crossing each other?

Like so:


Drawing a big deployment diagram (or any) with a lot of links, it's easier to read when links cross or not.
Without loosing the ability to put connectors 'on top' of each other.

For example, see picture below:
- the links marked with the black circle are actually crossing
- the links without the circle all move in the same direction



How to do this?

Thanks,
Robert

15
General Board / Re: Generate documentation - exclude tagged value
« on: April 17, 2015, 07:32:17 pm »
One more thing, I looked for {Element.notesOf(...)}, is something like that possible as well?

Pages: [1] 2 3