Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Maggie

Pages: 1 2 [3] 4
31
General Board / code generation
« on: February 15, 2011, 09:01:21 pm »
Hi
I have a be trying the code generation features of EA
I created a class and generated the code for it successfully
I then added an operation and regenerated again successfully
I then went back to the model and added some notes for the new operation and regenerated.
The added notes do not appear in the code as expected.
Has anyone else experienced this?

TIA

Maggie

32
General Board / uml specification
« on: January 22, 2011, 02:51:11 am »
hi all
can some one please tell me where i can obtain the offical uml specifiaction for download

TIA

Maggie

33
General Board / MDG Technology
« on: December 14, 2010, 10:35:59 pm »
Hello
I am developing a MDG Technology and was wondering if there is a way of including the 'preprocesor macros' used in reverse engineering

does anyone know if this can be done

TIA

Maggie

34
General Board / Updating profiles
« on: December 10, 2010, 10:21:34 pm »
Hello
I have a profile with a class stereotype defined.
I have used this profile in another model and classes with my stereotype are as expected.
I then updated the class stereotype by adding another tagged value.
Now in the project using the profile I reimorted the profile but classes with the stereotype do not show the tagged value.
If I create a new class with the stereotype the tagged value is present

Is this a bug or have I done something wrong?

TIA

Maggie

35
General Board / Import C++ file
« on: December 09, 2010, 10:02:44 pm »
Good morning
Can anyone tell me how to get access to the
 Project->Source Code Engineering->Import C++ files menu option
It always appears greyed out.
I dont want to import the complete source directory only a selection of the files
Is this possible

TIA

Maggie

36
General Board / what does "shighlight" do?
« on: December 02, 2010, 10:12:44 pm »
Hello
I am playing with code generation templates.
When I search the forum I come across code such as
Code: [Select]
%[shighlight]WRAP_LINES[/shighlight]

Can anyone tell me what the term shighlight does as I cannot locate it in the help documentation

TIA

Maggie

37
General Board / Code generation with std libs
« on: November 29, 2010, 09:15:41 pm »
Good morning
I am using EA to develop my Qt application
I have created a package structure to hold the standard Qt classes
Now when I set up an association between one of my classes and a Qt class the generated code contains the fully qualified name
Code: [Select]
Qt::corelib::kernel::QTranslator *applicationTranslator;

What I would like to achieve is a forward declaration to QTranslator and the declaration to look like
Code: [Select]
QTranslator *applicationTranslator;

Is there a way to achieve this

Thanks

Maggie

38
General Board / Relationship Matrix and RTF
« on: October 27, 2010, 08:22:43 pm »
Hello everyone
I realize (after searching the forum) that I cannot include a Relationship Matrix profile in an RTF report.
Has anyone found a suitable workaround for this?

TIA

Maggie

39
General Board / Normal.rtf
« on: October 04, 2010, 07:21:21 pm »
hello all
I am new to EA and am looking at producing rtf documention.
As I understand it, if I change the styles in the the normal.rtf file these should be refelected in my document template when i apply 'Update Styles' from the template editor.
So I edited the normal.rtf file and set the normal style to arial 10pt.
Then from within the template editor i applied 'Update Styles' but the now the normal style is Times Roman 12pt >:(

Have I misunderstood or is this a bug

TIA

Maggie

40
General Board / MS Word and bookmarks
« on: October 01, 2010, 08:59:58 pm »
Hi all
I am trying to insert a rtf bookmark into a MS Word document and get it to automatically update.
Steps taken

Select package in project browser
generate a rtf document
Right click on package -> Documentation - > Copy RTF bookmark

Open MS word
Insert file
Select RTF File produced above
press Range
Paste in the bookmark copied in EA
Insert as Link
[/list]
This results in the correct MS Word document.
If I now change the package in EA and the regenerate the RTF document the changes are not reflected in MS Word.
I have the update automatic links on open select in MS word

How do I get MS word to update its links?

TIA

Maggie

41
Hi
I am trying to add a compartment to show the status of an element by am having some difficulties
My shape script is defined as
Code: [Select]
shape main

  {
//        SetFillColor(100,100,100);
            DrawNativeShape();
  
 

      addsubshape("statuscompartment", 100, 20);

        shape statuscompartment
            {

                  h_align = "center";

                  rectangle(0,0,100,100);

                  println("status: #status#");

            }
  }
This does display a compartment, but at the top of the element
How can I get the compartment displayed at the bottom of the element ?

Thanks

Maggie

42
Automation Interface, Add-Ins and Tools / Automation
« on: March 11, 2014, 10:21:39 pm »
Hi
Does anyone know if it is possible to set properties on an object that no interface exists for?
For example I can set an object's status field (element.status)
but not something like concurrency or cardinality.
How would I do something like that

Thanks

Magie

43
Automation Interface, Add-Ins and Tools / Update Diagrams
« on: February 08, 2014, 03:41:16 am »
Hi
My addin sets up a generalization relationship when a class of a given sterotype is added to a diagram.
However, if the class being generalized appears on the diagram then the relationship is not drawn.
How can I make this happen from my addin

Thanks

Maggie

44
Automation Interface, Add-Ins and Tools / Delete a connector
« on: February 08, 2014, 03:51:08 am »
Hi
I am trying to delete a connector from within my addin -
Code: [Select]
                   short index = 1;
                    foreach (EA.Connector conn in clientElement.Connectors)
                    {
                        //EA.Element clientElement = Repository.GetElementByID(connector.ClientID);
                        if (conn.Type == "Generalization" &&
                            clientElement.Stereotype == "abc" &&
                            conn.SupplierID == QObjectElement.ElementID)
                        {
                            clientElement.Connectors.Delete(index);
                            conn.Update();
                            clientElement.Refresh();
                            clientElement.Update();
                            supplierElement.Refresh();
                            supplierElement.Update();
                            break;
                        }
                        index++;

When I debug the addin the code to delete the connector is executed but the connector is not deleted from the model

I would be grateful if someone could tell me what I am doing wrong

Thanks

Maggie

45
Hi
In an addin I can get the name of an EA.Element.
However, I want to get the fully qualified name i.e. one that includes the namespace.
e.g. class xyz lives in namespace abc so I want something that returns abc::xyz

Is this possible

Maggie

Pages: 1 2 [3] 4