Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Topics - akede

Pages: [1]
General Board / Incompatible XMI files?
« on: February 10, 2006, 07:12:24 am »

we started using the XMI files (based on UML 1.3/ XMI 1.1) to exchange models between EA and other tools such as Umbrella.

The way from EA to the other tools is working fine.

But now I'm getting back a XMI file created by (in the special case Umbrella) and all that I do import is an empty folder. The importer says everything is fine.

Does someone knows what kind of problems this could be?

Header of the XMI file:

<?xml version="1.0" encoding="UTF-8"?>
<XMI xmlns:UML="org.omg/standards/UML" verified="false" timestamp="" xmi.version="1.2" >



PS: if you like to see the whole file that's not able to be imported:

General Board / MySQL BaseModel
« on: December 01, 2005, 01:54:40 am »

I just tried again to install a MySQL repository for my project. Actual MySQL 4.1.15 including UTF-8 support.

Now I get the error

CREATE TABLE t_objectproblems(
Object_ID int( 11 ) NOT NULL default '0',
Problem varchar( 255 ) NOT NULL ,
ProblemType varchar( 200 ) NOT NULL ,
DateReported date,
`Status` varchar( 50 ) ,
ProblemNotes text,
ReportedBy varchar( 255 ) ,
ResolvedBy varchar( 255 ) ,
DateResolved date,
`Version` varchar( 50 ) ,
ResolverNotes text,
Priority varchar( 100 ) ,
Severity varchar( 50 ) ,
PRIMARY KEY ( Object_ID, ProblemType, Problem ) ,
INDEX ObjectID( Object_ID ) ,
INDEX ObjectRequiresRequirement( Problem )
) TYPE = InnoDB COMMENT = "InnoDB free: 87040 kB"

MySQL error:
#1071 - Specified key was too long; max key length is 1024 bytes

Basically I do understand what this means, but is there any other solution than removing ProblemType, Problem from the PK?


PS: I'm wondering how you created these tables in first place - may be there is a configuration option that I can't find.

General Board / Shareing RTF Templates
« on: December 21, 2004, 05:14:10 am »
Hey all,

I'm still trying to read all the manuals and provided documentation for EA but it's soooo much - excellent work the Spar team did  ;).

So one thing I didn't found out yet is:
Is there a way to share RTF template resources within different projects?

I found out that I can create and modify them but I can't import/export them like I do it with the patterns or profiles.

Thx for help


General Board / ERD class 2 OO class conversion
« on: December 13, 2004, 09:36:37 am »
Hello everybody,

I was wondering if there is a possibility to automatically generate a OO class based on the ER table definition (which is stored in a class symbol).

The idea is the following. After I generated my whole DB I would like to automatically generate the objects for the database abstraction layer. For that I would need a class which has the same attributes as the ER table and get/set methods to access these attributes.

Is there a way to generate these classes, I had a look at EA but couldn't find it directly.



Bugs and Issues / Frame around included UML diagrams
« on: February 11, 2009, 09:35:47 pm »

Including a second UML diagram by using the feature "drop diagram as: diagram frame" is a great concept.

I have the issue that all of these frames however do not keep their proportions (size) after I change the default size (to smaller). I verified that the included diagram is the size I want and as long as I keep the diagram open all is fine. After closing and reopening again the diagram frame is changed again :-(.



Bugs and Issues / EA & MS SQL very slow
« on: February 19, 2008, 01:45:10 am »
Hi all,

We have a strange issue. Using EA with MS SQL as database is on some clients extremely slow and on others as fast as using a local file. It seems there is some reason related to the database connection.

Is this a known issue?



Bugs and Issues / EA & MSSQL; Allocated Time stored wrong
« on: February 11, 2008, 06:34:21 am »
Hi all,

We are using EA corporate edition in combination with MS SQL Server.

I started to add the resource information in the project management view. Resource Allocation -> allocated time creates a funny behavior.

Entering any value such as 1 results in a 100,000000 after stored and reviewed the value.

EA is used and configured to use English as default language as well as the SQL Server, but the OS is a German one.

Testing with various formats such as 1.0 or 1,0 does not have any effect. Using different numbers e.g. 4 results in 400,000000 as stored value.

Any ideas?



PS: I tested a local EA database which does not have this problem. This is why I assume it is related to the combination EA & MS SQL

Automation Interface, Add-Ins and Tools / MS Project integration
« on: January 14, 2008, 12:36:23 am »
Hi all,

Does somebody knows a possibility how to use the ressource information of EA for MS Project?

I'm trying to find a suitable and very easy solution for a client and they are using MS Project already. From my perspective it would make a lot of sense to synchronize the information between EA and MS Project related to the ressource information.

Thanks for a hint



we are setting up a project with several folder structures. I found the packaging options including the sub-version integration quite helpful.

The system is working so far. There is only one thing that's a bit difficult.

We would like to use small XMI files that include only one package without all of it's subpackages.

Is there a option which I can check in order to automatically generate only these limited XMI files?



Automation Interface, Add-Ins and Tools / SQL DDL fails with MySQL
« on: April 11, 2005, 05:24:12 am »

I'm using the MySQL ODBC 3.51 driver. So far the import utilities can determit the tables within my database.

But anytime I import the tables the EA crashes while checking the foreign keys between the tables.

I tested it with a clean import and also with a sync. I tested one table or all. But always the same effect.

Does someone have and idea what's going on there?



Pages: [1]