Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - VKN

Pages: [1] 2 3 ... 13
1
Currently, there is no support added in the API.
When you select a connector that is connected to another connector, a proxy object is displayed on the connector end.
The link from the proxy (object) to the connector is in the t_object.Classifier_Guid.

2
General Board / Re: Help - element colours, defaults and resetting
« on: June 05, 2018, 11:14:12 am »
- If I change the Local Appearance (using the toolbars) is there any way to reset that element back to the element's Default Appearance?
Before you could do that you'll have to reset the default on the Default Appearance dialog (F4) first.

- If I were to manually change the colours back to match (using the toolbars), does that actually reset the appearance, or just make it look the same (ie to EA the element still has Local Appearance that just happens to be the same a Default Appearance)
Interesting question. Curious to know why you'd want to know. Anyway, the answer is that when you create an element then change its color EA notes it down as an additional setting and when you set it back to default EA uses the same additional setting to set it as default. So if one wants to know that if a particular element was ever changed since it was created then yes, by looking at t_diagramobject.ObjectStyle


3
General Board / Re: Archimate requirement aggregation in EA 14
« on: June 04, 2018, 05:34:17 pm »
There are few updates being made for that functionality.
As a workaround, you can turn off Strict Connector Syntax option to avoid that error.

http://www.sparxsystems.com/enterprise_architect_user_guide/14.0/user_interface/links.html

4
A parameter need to be in context/selected to be able to edit those fields.
Make sure that the Features&Properties->Operation Properties window is vertically long enough then add the parameters in the bottom part of that window.

5
General Board / Re: System Resource Exceeded on Large Deletes
« on: May 28, 2018, 01:11:27 pm »
That error is from the DB engine, not EA itself.
There is no workaround for it, you'll need to delete in smaller chunks.

6
The only way that I see to achieve our desired goals would be to show the Visio users how to improve their drawings so they give the EA import at least serviceable diagrams. Problem is that I have completely eschewed Visio and other tools in favor of EA for so long that I just have no idea where to tell them to begin.
To start with, open a diagram in Visio then check for Template property at File | Info
As Nizam mentioned, if there is no relevant template specified like UML, BPMN Diagram, etc then EA wouldn't understand what type of elements are being imported.
If your Visio guys are able to port those diagrams to other new Visio diagrams containing the right templates and if the element types in the diagram does match with the elements in the template then importing those diagrams should work fine.

7
Bugs and Issues / Re: Deleting Packages
« on: May 17, 2018, 03:24:33 pm »
Did you try this method?
http://www.sparxsystems.com/enterprise_architect_user_guide/14.0/team_support/managelocks.html

Do you have any diagrams in that package with note or other elements which don't appear in the Project Browser?
If those elements are locked by other user then you won't be able to delete them.

8
Must avoid ::

9
Suggestions and Requests / Re: Multiple Project Browser Windows
« on: May 15, 2018, 09:33:41 am »
One other workaround could be is opening the target package as a list and then drag the items back and forth.

10
General Board / Re: Display project path
« on: May 09, 2018, 06:02:51 pm »
That's not possible and probably won't be added.
Depending upon the length of the path the menu could become too big.

11
Also if I could find in which diagram this legend has been used will more useful
CTRL+U

12
Automation Interface, Add-Ins and Tools / Re: Use Alias if available
« on: April 27, 2018, 11:38:30 am »
The problem stated here is bit confusing. You say that you've turned on an option and EA is behaving according to it. But, you don't want that to happen?
Or, do you mean that you don't want the effect of that option to be applied for package elements?

Going by the above conversation I can suggest to check if your model has set a Project Template Package

13
And, without populating GUID column it won't work.

14
General Board / Re: Displaying A Banner When Accessing A Model
« on: April 17, 2018, 05:55:39 pm »
I did consider using the default diagram but I cant stop people from changing this using the EA permissions.
You may find yourself in the same situation even with some other approach.

15
General Board / Re: Text protection error.
« on: April 17, 2018, 04:37:02 pm »
That's not a bug. For removing that kind of text, uncheck that section from the Sections window.

Pages: [1] 2 3 ... 13