Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - DanielB

Pages: 1 [2]
16
General Board / Project transfer (DBMS to DBMS) from command line
« on: January 28, 2015, 03:31:40 am »
Is it possible to execute project transfer (DBMS to DBMS) from command line?

17
General Board / Information flow
« on: March 25, 2014, 09:51:18 pm »
Hi,

Can I find diagrams where interfaced is used as a part of information flow? It doesn't appear in links section of the interface, find in diagrams functionality doesn't work as well. Is there any other way I can use to locate this diagrams?

Regards,
Daniel

18
General Board / Class header colour
« on: November 28, 2012, 08:59:12 pm »
Hi,

Does anybody know how to set class header color only, not the whole class. Here is what I wanna achieve:


https://docs.google.com/open?id=0B1QcgiFN-wPhRGcwZlJiZmhfdVU

Please, don't laugh if it's obvious feature :)

Regards,
Daniel

19
General Board / Re: Linked document
« on: October 25, 2012, 01:28:00 am »
Quote
No, and EA doesn't provide functionality for add-ins to customize the project browser, so you won't find an add-in that does it. The closest an add-in could come is implementing its own docked window to define such a tree.

Simon, is there any chance that Sparx will add such feature to EA? It is really inconvenient to work with extensive project browser which has many linked documents under its objects.

Regards,
Daniel

20
General Board / Linked document
« on: September 04, 2012, 10:49:19 pm »
Hi,

Does Enterprise Architect allow (using out-of-the-box functionality, not a plugin) to visualize in "Project Browser" tree which element has "Linked Document" defined?

If EA doesn't have such feature than is there any plugin which has it.

21
General Board / Re: BPMN Simulation
« on: September 27, 2012, 05:12:44 pm »
Well, that explains a lot :) I have a corporate edition only. Thanks for a quick reply.

22
General Board / BPMN Simulation
« on: September 26, 2012, 11:10:57 pm »
Hi,

Documentation says: "In general, you do not need to set up a Simulation script (...) For most diagrams it is possible to start a simulation simply by opening the diagram of interest and pressing the "Play" button on the Simulation control window."

I would like to start simulation on "BPMN 2.0 - Business Process" model but a "Play" button is inactive. Do BPMN diagrams require Simulation scripts or is there a different reason of inactive "Play" button?


And one more thing. When I try to set up a simulation script I need to set a Platform: "For BPMN diagrams, click on the drop-down arrow and select BPMN.". Unfortunately I have only two options: "none" and "UML Basic". What could be a reason? (I have 935 build of EA).


Thanks in advance for any help.

Regards,
Daniel

23
Bugs and Issues / Re: Project security
« on: July 08, 2014, 06:24:06 pm »
Thanks Aaron, that answers the problem. However it's going to be very inconvenient to work in multi-EA version environment and this is the case in every project I'm currently working on :/

24
Bugs and Issues / Project security
« on: July 08, 2014, 02:30:00 am »
Hi,

I migrated old reposiotry created in EA 10 from one DBMS to another DBMS but using EA 11. Now only users that use EA11 can log into repository. Users  using EA10 can't even though they are configured in Security Users.

Removing and adding user doesn't help. Changing password neither.

Can anybody help with this? Do I have to change something manually in EA DB in order to allow users with EA 10 access to the repository?

Best regards,
Daniel

25
Thank you for qucik response.

I would like to avoid if it is possible. If not then I don't mind to put few lines of code in C#. Do you have a link to documentation which describes how to include C# libs in scripts?

26
Hi,

Is it possible to open Element usage window from Script? Or something similar.

Regards,
Daniel

27
Automation Interface, Add-Ins and Tools / Re: Information flow
« on: March 19, 2015, 01:00:51 pm »
Quote
You know the GUID of your selected object. Search for that GUID in t_xref.Description where t_xref.Behavior='conveyed'. Then t_xref.Client should contain the GUID of the information flow connector.

Thank you, that helped a lot.

28
Automation Interface, Add-Ins and Tools / Information flow
« on: March 17, 2015, 02:08:09 pm »
Hi all,

I know that there are numerous threads around this but I still didn't find the answer I'm looking for.

I'm trying to write a script which after clicking on an object in Project Browser will show all connectors where this object was used as an Information Item.

One possible way would, which I really don't like due to low efficiency, will be to list all connectors in the repository, then for each of them call connector.ConveyedItems function, and verify which connector has the object in it's ConveyedItems collection.

Do you know any other solutions?

Pages: 1 [2]