Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Boron

Pages: 1 2 3 [4] 5
46
General Board / Re: Version controlled packages: Replace xml file
« on: November 22, 2011, 12:55:01 am »
I feared that answer :(.

A checkout of the file does not work as EA shows an error messages saying that I have to choose another filename. EA refuses to replaces a file, no matter if the file is checked in or out.

Thanks anyway. You are always a good help.

Kind regards
Boron

47
General Board / Version controlled packages: Replace xml file
« on: November 21, 2011, 11:47:32 pm »
Hello,

we have enabled version control for our packages in our project models (EA 9 with ClearCase as version control system). This means that we have many version controlled xml files, each containing the design of one packages. Together they form the complete design of our software.
Up to now we have no big problems with this approach.
Just for one thing...

If we want to enable version control for a newly designed package and store it with the file name e.g. Package.xml what can we do  if we want to replace an already existing file with the same name?
I know that deleting the original file from version control system and create it new by setting the EA package under version control would be the straightforward method (EA exports the package content to xml and sets the file under version control).
But let us assume this is not an option.
What if I just want to replace the already existing file?
Is this possible with EA, and how?

48
General Board / Re: Automated project transfer
« on: October 28, 2011, 05:48:16 pm »
A year ago we switched from checking in the XMIs to EAP files because our UML profile is not part of the XMI.
So when someone wanted so see the model he imported the XMI into an empty model and all diagrams looked not the way we are used to, because in our UML profile we have many customized elements with own shape scripts.
An EAP file is much more comfortable. Everything is in it. Even in ten years!

49
General Board / Automated project transfer
« on: October 27, 2011, 07:41:23 pm »
Hello,
I often need to make baselines of our project models. Our models are stored in a SQL database. We have about 10 different model ().
We don't use the EA baselining mechanism as we want eap files to be checked in our version control system.
Therefore we make a "project transfer" (DBMS to .EAP) for each single model in the database. This is very time consuming and prone to erros (e.g. selected model X for the transfer when you meant Y).

Is there a way to automated this? Maybe via the automation interface?
Thanks for any idea?

50
General Board / Decouple EA model from version control
« on: September 22, 2011, 06:46:13 pm »
Hello all,

I have an EA model that is under version control (ClearCase). Means: several packages are version controlled and subpackages of the "parent packages" are separately version controlled too.

My question is if there is an easy way to completey decouple all version controlled packages from version control without checking each single package manually?

Kind regards,
Boron

51
General Board / Delete tagged values on many elements
« on: July 22, 2011, 04:50:48 pm »
Hello,
in our model we have over 6000 elements (classes and ports) where each has a tagged value name "CA_version".
As we don't need that tagged value any more I wonder how I can delete all these tags without doing it manually (selecting the tag in the tagged value window and clicking on the delete button).

How can thousands of tagged values (identical name) on thousands of elements be deleted?
By directly manipulating the database?
Other idea?

52
General Board / Re: Swtich off color gradient in class elements?
« on: July 14, 2011, 04:38:23 pm »
It is directly in front of my face and I didn't see it  :(. So easy!

Thanks a lot RoyC.

53
General Board / Swtich off color gradient in class elements?
« on: July 13, 2011, 11:24:25 pm »
Hello,
EA version is 9.0.907.
I wonder if it is possible to switch off the color gradient of a class element in a diagram.
In the Tools -> Options... dialog it is possible to switch on or off the "gradient fill for paper color". Is the same possible for the gradient fill in diagram elements like classes?
This gradient look awful when a diagram is printed or stored as PDF file.

54
General Board / Sort the elements of a class?
« on: April 07, 2010, 11:35:58 pm »
Hello EA users,

I would like to ask if it is possible to sort the elements of a class in the project browser?
If allowed I would have attached a small snapshot of the project browser, but so a the following text must be suffucient:
Code: [Select]
TestClass
- <<servicePoint>> servicePort_2
- <<requestPoint>> abcPort
- <<servicePoint>> servicePort
- <<requestPoint>> defPort
- <<myPort>> myPort
New elements seem to be alphabetically sorted when added to the class. Sorting can later be done via the context menu entries "Move up" and "Move down".

But if the elements are not sorted, eg. someone "moved up" and "down" the elements, is it possible to let EA resort the elements, e.g. sort by stereotype and/or alphabetically?

Many thanks for your help in advance.
Boron

55
Bugs and Issues / Re: Problems with images / image manager
« on: August 11, 2014, 10:36:22 pm »
Today I found the time for checking the Project Transfer.
I always get a "Transfer Error" message window telling (text a bit shortened):
"Error from Microsoft Cursor Engine
Data provider or other service returned E_FAIL.
[Select * from t_xref]
Field: link"

A project transfer from one model to another model within teh old server works without problems.
A project integrity check show no issues.

Something is strange with PostgreSQL 9.3 in conjunction with EA.

56
Bugs and Issues / Problems with images / image manager
« on: August 06, 2014, 05:00:01 pm »
Hello,
we are planning to migrate our EA model repositories from PostgreSQL 8.4 to 9.3.x.
After having set up the new server and database we transferred a model to the new server:
- On old server: create a backup file using pgAdmin III
- Copy file to new server
- On new server: restore the backup file into a database

When connecting from EA on a client PC to the new database EA 11 does not display images  that have been imported to the model.

All images accessible via the Image Manager (menu Settings -> Images...) cannot be displayed by EA.
Clicking on a bitmap "File Type" image shows only a black preview image.
Image of "ENHMetafile" type are commented with a message box telling "Not a PNG file", which is obviously correct.

I checked accessing the model with EA 9 and EA 11. Both version show the same behavior when using PostgreSQL 9.3.x as repository server.
When connecting to the old server with PostgreSQL 8.4 all EA versions don't have problems with the embedded images in the models.

I cannot image what might be different between PostgreSQL 8.4 and 9.3 concerning images in an EA model. Images are stored as binary data in the database.
So what is wrong here?

57
Bugs and Issues / Re: Text in note elements loose line breaks
« on: May 16, 2014, 05:02:09 pm »
Sorry for answering so late.
@qwerty:
Yes, we have central repositories for the Ea models on an PostgreSQL server.

@Geert
Other PCs that show no problems have the same regional settings (Win 7 everywhere; German region everywhere)

@Aaron B
The note elements are really just notes :). The content is not used for code generation. The problem is not bound to text that is source code. It might happen to any text inside a note element.

As I am experiencing other strange behavior on my PC I shortly before telling our IT department to make a new installation of my PC :(.

58
Bugs and Issues / Re: Text in note elements loose line breaks
« on: May 12, 2014, 06:24:57 pm »
We are not working with add-ins. Especially no add-ins working on "notes".

I just found out, that on other PCs the note texts are OK, which means the text is shown with line breaks as they have originally been set.
It seems to be my PC that causes weird displaying of note texts.

59
Bugs and Issues / Text in note elements loose line breaks
« on: May 09, 2014, 05:33:45 pm »
Hello,
I have a really strange and annoying problem with EA 9.3 (I also tried the new EA 11 but it shows the same behavior).

In the last few moth there are more and more note elements in our EA models whose texts have somehow lost the intended line breaks.
E.g. sometimes we have tiny code snippets (are any other text, doesn't matter). This snippet has been entered with line breaks:
int myFunction(void)
{
    //do something
}

One day this snippet was shown the following way in the diagram and in the note properties dialog:
int myFunction(void){   //do something}

Sometimes it helps to type in the text again with line breaks, but it is impossible to cover all notes throughout all the models.

I have not found a similar problem in this forum.
Reinstalling EA did not help (regardless the version, see above).

Any idea what might cause this problem?
Any idea how to solve this?

60
Uml Process / Re: V12 - Add new package to Version Controlled pa
« on: September 11, 2015, 04:39:57 pm »
I hope I understood you correct in what you want to achieve.

When you want a newly created "sub-package" below a version cotrolled parent package to be part of the "version control" of the parent package you have to do no further steps.
When checking in the parent package the newly created sub-package (and its complete content) will automatically be exported as well and checked in inside the *.xml file of the parent package.

When you want a newly created "sub-package" below a version cotrolled parent package to be separately under "version control" you have to right-click on the sub-package'/Package Control/Configure', thus creating a separate *.xml file with only teh content of the sub-package.
The *.xml file of the parent package will then only reference the other xml file (after the "parent xml" has been exported and checked in of course).

Kind regards

Pages: 1 2 3 [4] 5