Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mrblack12

Pages: [1] 2 3 ... 5
1
General Board / Autonumbering on stereotype level
« on: June 23, 2017, 12:36:48 am »
Hi,

I posted this question a few moonths ago: "I was wondering if there's a way to use auto-numbering on a stereotype level. The default function is to set auto-numbering on Type level, e.g. Requirement. In my project we distinguish functional requirements and business rules as two dffierent stereotypes of a requirement type.

We would like to have the functional requirements and business rules automatically numbered on creation, both with a dfferent prefix, let's say "FR-" for a functional requirement and "BR-" for a business rule.

Any suggestions whether this is possible?".

The only reply I got then was that this could only be done through (writing my own) add-on. By now I'm wondering if anyone else has come across this issue since and already had a working solution for it. If not, how does one go about writing their one add-on?

Thanx,
Rick

Thanx in advance,
Rick

2
General Board / Settings spell checker in virtual environment
« on: May 16, 2017, 08:18:13 pm »
Hi,

in my current project we're using EA in a Citrix environment. Because we are a Dutch company we're using the Dutch spelling checker. I noticed however that restarting EA resets the main dictionary language back to American English. Apparently the custom choice of a different main dictionary language isn't maintained in the project repository or anywhere else (e.g. Workspace). However, I also use a local version of EA privately on my laptop, and there the setting to the Dutch dictionary language is preserved. So I'm guessing this has something to do with EA running in a virtual environment?

Does anyone else have these issues? And if so, is Sparx resolving this in future releases?

Rick

3
Geert,

of course! Should have seen it myself so I was a bit to hasty in posting this question. Thanx again for your speedy reply!

Rick

4
Hi,

I'm working on a template for generating documents on class diagrams, but I can't seem to find how to set the template up so that it shows only the class diagrams and classes. I tried using the Exclude filter option and then setting Exclude details for "Class" (Attribute is not shown in the list since it's not an element in its own right) and Exclude connector type to "All", but neither one does the trick.

Any suggestions on how to solve this?

Thanx
Rick

5
General Board / Re: Supress inherited attribute visibility
« on: May 05, 2017, 01:06:17 am »
As in "No, that is not possible in the current version"?

6
General Board / Supress inherited attribute visibility
« on: May 04, 2017, 06:41:14 pm »
Hi,

I was wondering if it's possible to suppress the visibility of inherited attributes in a subclass, just like you would for its own attributes. In the feature and compartment visibility window the only thing you can do is check the box to show inherited attributes, but I don't see how you can set which inherited attributes to show and which not.

Any thoughts on this?

Much appreciated...
Rick

7
General Board / Wireframe and tables
« on: April 10, 2017, 11:08:40 pm »
Hi,

I'm trying out the wireframing toolbox to see if we can use it for our GUI designs. It seems that the properties of some of the objecttypes are restricted: for instance, when using a table it's not possible to indicate how the values are to be justified (centered, left or right), it uses the Anglo style decimal separator ('.' instead of ',') which causes decimal values separated by a comma to be placed in the adjacent column and there's no way to lay-out indvidual cells (border or fill colour).

I've noticed that the table properties are described in a tagged value note (memo): is it possible to manually manipulate this note?

Thanx,
Rick

8
General Board / Diagram filter: show only some attributes in class
« on: March 29, 2017, 12:01:11 am »
Hi,

I was wondering if it's possible to filter a class diagram based on a specific type of attribute, perhaps on datatype or tagged value? I already found the Show Visible Elements function, which already does some part of what I'm looking for...

Thanx
Rick

9
General Board / Generate tables from classes?
« on: February 23, 2017, 01:13:44 am »
Hi,

I have a class model setup with classes that contain attributes. The attributes all have data types and scope (protected, private or public). Is is possible to generate a physical model (e.g. tables and columns) from this?

Thanx a bunch....
Rick

10
Thanks to qwerty, but we solved it by using the "Link to element feature"....

Rick

11
Hi,

I want to link a user-field on a screen object to a specific attribute in a class, so I drag the attribute from the project browser to the diagram. But it then transforms into an object instance and is placed seperately in the package where the diagram resides. Is there some way to prevent this, because now I basically have two definitions of the attribute: the one in the class and the seperate object instance....

Thanx in advance
Rick


12
General Board / Re: Searching for special characters in element name
« on: February 01, 2017, 01:44:26 am »
Found it! Turns out you have to use the square brackets: so using
  • as search term will find all elements with an asterisk in them, instead of returning everything....

13
General Board / Searching for special characters in element name
« on: January 23, 2017, 11:44:30 pm »
Hi,

I'm trying to construct a search query that searches for elements with a special character - like &,*,+,), etc. - in the name. I'm doing this using a wildcard search but the only character for which it doesn't work is the wilcard character itself: '*'. Using just an asterisk as search term results in the entire repository, duh!

I'm thinking there might be a way by using an escape character like a forward or backward slash but that doesn't seem to do the trick either. Any suggestions on this?

Thanx,
Rick

14
General Board / Auto-numbering element on stereotype level
« on: November 21, 2016, 09:07:07 pm »
Hi,

I was wondering if there's a way to use auto-numbering on a stereotype level. The default function is to set auto-numbering on Type level, e.g. Requirement. In my project we distinguish functional requirements and business rules as two dffierent stereotypes of a requirement type.

We would like to have the functional requirements and business rules automatically numbered on creation, both with a dfferent prefix, let's say "FR-" for a functional requirement and "BR-" for a business rule.

Any suggestions whether this is possible?

Thanx in advance,
Rick

15
General Board / Re: script implementing cut-and-paste functionality
« on: November 18, 2016, 12:26:00 am »
Thanx to Simon,

your idea did the trick. Seeing I'm not that big of a scripter.... ;)

Rick

Pages: [1] 2 3 ... 5