Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - mrblack12

Pages: 1 [2] 3 4 5
16
General Board / Re: script implementing cut-and-paste functionality
« on: November 03, 2016, 02:10:02 am »
Hi Uffe,

cheers for your speedy reply: I will definitely try out the first option. The second option is something we already tried but if you have a very long list of objects you need to scroll through, then drag-and-drop can become a bit difficult. Apart from the risk of letting your finger of the mouse button and EA dropping the object somewhere you don't want it.... ;)

17
General Board / script implementing cut-and-paste functionality
« on: November 03, 2016, 01:34:33 am »
Hi,

I'm working on a project in which a rather large number of business rules have been imported to a general package in EA, using a CSV import. But now we have to get each BR placed in the right functional package. We are still using EA version 10 which does not support (bulk) cut and paste, so each BR is manually copied to the clipboard and then manually pasted from the clipboard in the right package. To prevent double instances of the same BR we then have to get back to the general package and remove the original BR.

This is mind-numbingly boring work, especially when you have over hundreds of BR's to process. I was wondering if there's someone out there who has come up with a script of sorts to simulate the "Cut and paste" function.

18
General Board / Custom search queries not showing in model view
« on: October 30, 2016, 01:49:49 am »
Hi,

I'm constructing a number of model views, based on search queries I have built and saved as My Searches. It looks as though the 'Properties' window of a (search) model view does not show all the queries I've stored under My Searches, in the 'Search' dropdown list (just some of them). When I go to the 'Manage views' window however, the searches are displayed in the 'Searches' dropdown. And when I select one and run it, it performs the search correctly.

But when I close the 'Manage views' window and return to the 'Properties' window again, the selected search is still not showing in the 'Search' dropdown list. This is bugging the hell out of me >:( : is it really a (known) bug or am I doing something wrong?

Any nsights on this would be greatly appreciated! ;)

Rick

19
General Board / Re: Visualizing element complexity
« on: September 07, 2016, 12:21:28 am »
Qwerty,

works like a charm, man! Cheers... All I have to figure out now is what the most appropriate colours are and whether I want the how fill to bechanged or maybe just the border (= SetPenColor, i'm guessing?).

And @OpenITSolutions: I was aware of the diagram filtering option, gonna give that a try as well....

Thanks alot you guys!

20
General Board / Re: Visualizing element complexity
« on: September 06, 2016, 07:54:51 pm »
Qwerty,

without coming over like a complete noob: what do I do with this? It looks like a script but I'm not really that comfortable with scripts. How do I run it?
Rick

21
General Board / Visualizing element complexity
« on: September 06, 2016, 06:46:01 pm »
Hi,

I'm wondering whether it's possible to show an element's complexity - defined in the General properties window - on a diagram, perhaps by use of colours (like how you can show the status of an element). Any thoughts on this?

Thanx,
Rick

22
Bugs and Issues / Re: Poor performance 4 users using shared eap file
« on: August 22, 2016, 11:54:09 pm »
Maybe you should consider using replica's....

23
General Board / Solutions for migrating data from Oracle Designer to EA
« on: August 13, 2016, 12:54:01 am »
I've already read some threads on this topic, but the most recent one is from 2011 so I was wondering if in the meantime some possible solutions have come to light. I am looking for an automated way to transfer data (i.e. datamodel, business rules, etc.) from an Oracle Designer repo to EA v12 or 13. I'm kinda hoping some forum member has developed a script for this. ;D

24
General Board / Status bar not showing query results
« on: July 14, 2016, 10:06:15 pm »
Hi,

in pre 12 versions of EA, the statusbar would show the results of an executed query (e.g. number of rows selected: #), but somehow I can't get v12 to show this as well. Any ideas on how to bring that to the surface?

Thanx in advance,
Rick

25
Thanks for your replies! It was the latter:I did try to change the case of an existing glossary item....

26
HI,

i'm trying to update a few glossary items but I keep getting the blocking message that "A glossary with the same name already exists". Anybody knows how to prevent this from happening?

Thanx,
Rick

27
General Board / Re: Search use cases with no structured scenarios
« on: July 02, 2016, 12:26:37 am »
Geert,

as always your solution works like a charm!

Much obliged....

Rick

28
General Board / Search use cases with no structured scenarios
« on: June 29, 2016, 10:09:49 pm »
Hi,

I'm looking for a way to search for use cases for which no structured scenario has been defined yet. Trying to do something with a query that joins the t_object and t_scenarios on object_id's but then I only get the use cases where a structured scenario has been defined, and I'm looking for the ones without.

Any thoughts?

Thanx in advance
Rick

29
Hi,

does anyone know of a simple solution to this pesky MS Access error, without having to delve into Access itself?

Thanx in advance

Rick

30
General Board / resultset query in search folder not ordered
« on: March 09, 2016, 03:04:41 am »
Hi,

I've created a search folder under Model views and populated it with the results of a self-defined search query. In the query I've used the "order by" clause and the results from the query itself are neatly ordered, but the same list in the search folder is not. I can't seem to find where or how this list can be ordered as well. Apart from that, it's strange that apparently not all sql statements in the query are processed.

Is this due to the fact that the 'order by' is just a clause and not a proper SQL statement in its own right?

Any thoughts on how to solve this?

Thanx,
Rick

Pages: 1 [2] 3 4 5