Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - nestevao

Pages: [1]
1
General Board / Fields in Header/Footer in RTF documents
« on: January 25, 2012, 04:55:24 am »
Hi,

Is it possible to insert fields in the header or footer of RTF templates?
How?

Thanks.

2
General Board / How to change Source safe database
« on: March 24, 2011, 01:50:20 am »
Hello,

We are controlling versions trough MS Visual Source Safe. We had to change the SS database and we made a copy of the old one and created a new database. All files were checked-in and synchronized.

How can I change in EA Version Control (EA 8.0.864), the SS database to use.

Thanks in advanced,

Nuno

3
Bugs and Issues / Win32 User Interface to RTF Document
« on: July 07, 2011, 01:08:47 am »
As anyone tried to generate a RTF Document including win32 user interface diagrams? It's a mess.  :-/

I've made a screen prototype design using win32 user interface diagram and elements and when I tried to copy paste a win32dialog to a word document or tried to generate an RTF document, the result is miserable.

The 'dialog window' background does not maintain the same size as the window designed, the text in the elements appears outside the elementsm etc...

Is there any 'option'/feature to generate this kind of diagrams correctly?

Thanks in advanced.

P.S. I'm using EA 9 build 907.

4
Bugs and Issues / Connect EA 9 with TFS2010 - How??
« on: June 28, 2011, 12:30:43 am »
Hello,

We're using EA for a long time and now we'll start using TFS.
We want do share requirements and features between EA and TFS.

I've installed MDG Integration for Visual Studio 4.5.1 (the add-in About Window says MDG Link and not MDG Integration, is this correct?) but in EA I don't have any option to connect to TFS Server or any option to integrate requirements or other artifacts as work itens in TFS.

In TFS I've a new option to view EA but nothing happens.

How do you connect EA and TFS and share requirements as I saw in one of Sparx videos (http://www.sparxsystems.com/resources/demos/MDG_VSTS/TFSIntegrationDemo.htm)?

I've EA 9.0.907 and TFS 2010.

Thanks in advanced.

5
Bugs and Issues / Use-cases - unable to resize elements
« on: May 24, 2011, 08:33:34 pm »
Hello,

Not sure if is a bug or a feature but I no longer can use the 'Same Height', 'Same Width' and 'Same Height and Width' in the use-case diagrams.

In other diagrams is working.

I'm using version 9, build 905.

6
Bugs and Issues / Version Control Settings - No SS available
« on: October 15, 2010, 10:29:50 pm »
Hello,

I want to configure the version control settings in a machine with MS Source-Safe installed but when I want to select the scc provider, it does not appears Source-Safe.

I've done this is several machines, all with the same sw installed in the same way and this is the first time it happened.
Only difference in this case, I've installed EA before installing MS-Source Safe, but, I've reinstalled EA after installing Source-Safe.

Any hints?
How and where EA looks for the installed SCC providers? Any way I can indicate the correct Source-safe path?

Thanks.

7
Bugs and Issues / Check-in branch: bug or feature
« on: November 25, 2009, 10:41:58 pm »
Hello,

I'm using MS Source-safe to version control my EA project. Recently we had the need to check-in all project existing packages, which are a lot, and I thought that the 'Check-in branch' functionality was the best way to find out which packages were checked-out and check-in them.

The problem is that when using the Check-in branch we only get the checked-out packages that are currently visible (expanded) in the project browser tree. If we have more checked-out packages that aren't expanded they don't appear in the check-in branch list. This is not very useful.

Is it a bug or a feature?
If it's a feature, is there any better way to quickly find out which packages are checked-out?

Thanks.

8
Bugs and Issues / The Euro symbol in labels
« on: September 07, 2009, 09:53:35 pm »
In all EA diagrams, when I use the € symbol, after saving the diagram and re-open it, it replaces the € symbol by an inverted question mark symbol.

I've version 7.5 build 848 and all my computer language settings are in Portuguese.

Does anyone else have the same problem? Is there any language setting that I should configure.

9
Bugs and Issues / Tagged Values for Table columns
« on: August 18, 2009, 01:52:24 am »
I can't add tagged values for table columns trough the new tab in the column property window. The new value button is disabled.
I can add it trough the 'old' tagged values window so it's not an access problem.

The new feature works fine for other types of objects.

I'm using build 847.

10
Bugs and Issues / RTF documents - Hebrew and Arabic
« on: August 18, 2009, 02:01:42 am »
Since build 846 I'm having problems creating rtf documents because in the middle of the document, with no apparent pattern, EA formats some exported element information in Hebrew or Arabic language. It basically write from right to left and puts the last character in the beginning of the paragraphs.

It's very hard to fix it, even using Word, because it's not a very well defined text that we can easily select and change the language. I'm spending more time to locate and fix this mistake in my documents than producing the document it self.

All rtf template formats are common for all text so I can't understand why some objects, of the same kind, are exported correctly and other are wrong.

Am I doing something wrong?

11
Bugs and Issues / Problems with RTF  with model documents
« on: June 20, 2009, 03:35:15 am »
Hello,

I'm having some problems when creating RTF documents trough Master Documents and  Model Documents.

I've created a few RTF templates that worked fine when creating RTF documents directly from the Package. It creates a document with the page layout I defined in the template and with all fields inserted correctly.

When I use the same templates trough a Master Document it does not respects the page layout I defined in the template but it stills inserts alf correct fields.

The worst is when I use the same template with a Model Document, it does not respects the template page layout and I started to have problems with Element fields. In the produced documents instead of the field content I only get the field tags.

After producing a first document with errors I begin to have problems in the template editor with erros when including or excluding some sections and they've never worked again forcing me to create new ones from scratch.

I alsso have problems with child packages. I don't want to include existing child packages in my template but when I produce a document, through Model Document, with a template without child package but for a package with child packages, the document produced is blank. If the template has the child package, the document has the fields I defined, with the Element filed problems, but it also includes information about the existing child package which I don't want to include in that Model Document.

Is there any particular way, precautions, limitations or something else that we should considerer when creating RTF templates to be used trough Master Documents / Model Documents or is just a lot of bugs with these features?

EDIT: I've done more tests and I think all problems are due to the child package section in the RTF templates. With child package in the template it works well, without the child package in the template the documents have problems.

Thanks in advanced.

Nuno

12
How can I include in a RTF template document linked elements from other packages than the selected one?

It's possible to do this with the RTF Report generator when the 'Document Linked Elements' option is on but, I can't find a way of doing the same trough RTF templates.

Any help, please?

Pages: [1]