Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Helmut Ortmann

Pages: [1] 2 3 ... 7
1
Hi,

with EA 13.5.1 it looks as if 'Search Folder' in the 'Model View' can only be defined for Build-In Searches.

In previous versions this was also possible for own searches or MDG searches.

Kind regards,

Helmut


2
Hello,

I am trying to develop an Add-In Search with C# according to http://sparxsystems.com/enterprise_architect_user_guide/13.5/automation/add-in_search.html.

The Add-In works correctly but EA doesn't recognize the Add-In Search. I would expect to see the Search in 'Find in Project' category Addin. Nothing shows up.

I tried the following signatures and checked it in the DLL with ildasm.exe. The methods are public methods in the Add-In Class.

Signatures:
- public string AddInSearchSample2(EA.Repository repository, string searchText, out string xmlResults)
- public string AddInSearchSample2(EA.Repository repository, string searchText, ref string xmlResults)
- public object AddInSearchSample2(EA.Repository repository, string searchText, out string xmlResults)
- public object AddInSearchSample2(EA.Repository repository, string searchText, ref string xmlResults)


Has someone experiences, examples or ideas?

Thanks,

Helmut

3
Hello,

I try to auto name newly created  Requirements with the EA Broadcast Event 'EA_OnPostNewElement'. It mostly works as expected.

When I add requirements, e.g. Functional Requirments, with the Specification Manager EA don't send the Broadcast Event 'EA_OnPostNewElement'.

Any idea?

Thanks for your help!

Helmut

4
Hi,

I want to set an EA Property like 'ShowConstraints' (EA.DiagramObject) in C# dynamically / by reflection.

For datatypes 'long' or 'string' it works well by e.g.:
diaObj.GetType().InvokeMember("ElementDisplayMode", System.Reflection.BindingFlags.SetProperty, null, diaObj, new object[] { 2 });

On the first view, it looks as if 'true 'isn't correctly translated to the COM 'true'. I tried 1, 255, 65535, -1, ... - no success.

For datatype 'boolean', I can set it only to 'false' but never to 'true'. I tried a lot - no success. According to the documentation, it should work for COM interop. Yes, setting to 'false', 'reading' works well.

One of my tries:
diaObj.GetType().InvokeMember("ShowNotes", System.Reflection.BindingFlags.PutRefDispProperty, null, diaObj, new object[] { (true });

Any idea, experiences?

Thanks for your help.

Helmut

5
Hi,

Is there a possibility to visualize for an action of type "accept event" the associated trigger, signal,...?
"Send signal" action is quite intuitive by visualizing the signal as type.

Well, I can drag the signal or trigger to the canvas and make a dependency or so.

Kind regards,

Helmut

6
General Board / Show type of call behavior action
« on: December 13, 2016, 06:22:53 pm »
Hi,

Is it possible to show in an Activity Diagram the type (the Activity called) of the Call Behavior? It should appear as usual 'name:type'. I tried a lot and found nothing.

Thanks,

Helmut

7
Hi,

the EA Example model has the media player to explain SysML concepts with EA.

The IBD shows for a property '<name> / <type>' like ' cpu / Processor - TMS320VC5507'. I would expect simple the name like 'cpu'.

If a select 'show element type' than I see the type with the well known ':' like ' cpu / Processor - TMS320VC5507:Processor - TMS320VC5507'.

How does that come and is there a possibility to switch it off.

Thanks in advance,

Helmut


8
General Board / Modelica: initial equation
« on: December 12, 2016, 12:12:20 am »
Hello,

is it possible to define a Modelica 'initial equation' (SysML)?

Thanks,

Kind regards,

Helmut

9
Hi,

Editing properties in SysML are no fun. In essence, they are similar to attributes/values.

It would be a good idea to edit them like attributes.

Kind regards,

Helmut



10
Automation Interface, Add-Ins and Tools / TaggedValue types in profile
« on: October 30, 2016, 10:26:53 pm »
Hi,

I want to integrate TaggedValues types in my profile. It works fine but the profile don't contain the tagged value types.

If I've read the documentation correctly used TaggedValue Types are automatically put into the profile. The xml contains TaggedValueTypes but they are empty.

Is there a trick?

Thanks,

Helmut

11
Hello,

when I drag an Interaction to an Activity Diagram I would expect a Call Behavior Action. I get an Object.

Kind regards,

Helmut

12
Automation Interface, Add-Ins and Tools / SYSMOD MDG, release V2. or...
« on: September 15, 2016, 05:27:11 am »
Hi,

does anyone know where to download the SYSMOD MDG?

http://model-based-systems-engineering.com/download/ contains the download. It mentions V2.0 but the MDG is V.1.0 and it looks as if there is something missing. May be I expect to much.

It was developed by SPARX and LieberLieber according to definition by Tim Weilkiens.

For example:
The Use Case should have a stereotype "Variation Point". The stereotype has no assignment to "UseCase". I can fix it by editing the *.xml.
The Properties of ibd don't allow the Stereotypes like "User",...

Has someone experiences with this MDG?

Thanks a lot,


Helmut

13
General Board / Receptions in SysML, Receive Signal in UML by a class
« on: September 03, 2016, 06:47:01 pm »
Hi,

has anyone a good idea how to model receptions in SysML or receive Signals in UML by a Class.

The help recommends: Using Stereotype <<Signal>> and name the operation according to the Signal name. http://www.sparxsystems.com/enterprise_architect_user_guide/8.0/modeling_languages/signal_element.html

I don't like the idea of same Name.

Has anyone a good idea?

Thanks in advance,

Helmut

14
Hi,

I tried to extend the EA stereotypes EAUML::testset. When I drag my stereotype to the canvas the tab for EAUML:testset is missing. Only my new stereotype is there.

I tried the same with EAREQ::FunctionalRequirement and it works fine. XML looks also similar. The same content, generalizes, baseStereotype, only the names are different.

Is there something special about testset, testsuite and testcut?

Any idea?

Thanks for your help!

Helmut

15
Bugs and Issues / Chart (Pie,..) black, also in example model
« on: August 08, 2016, 04:13:58 pm »
Hi,

the charts in the EA - Example model and in my own are black. Refresh don't help. Creating a new one leads to the same result.

I know that some time ago they properly rendered. I even tried to make a new model and a lot more.

Are there any experiences or workaround.

I found in the forum the same issue with the promise of further information:
http://sparxsystems.com/forums/smf/index.php/topic,30366.msg221389.html#msg221389

Thanks a lot,

Helmut

Pages: [1] 2 3 ... 7