Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - ufechner

Pages: 1 2 [3] 4 5 6
31
General Board / Re: Error when copying diagrams
« on: November 20, 2007, 02:51:23 am »
OK, I reported this bug to sparx on the 13th of November, but got no reply yet.

In which timeframe should I expect a reply to a bug report?

Does it make any sense, to write another email to regsupport AT sparxsystems.com.au?

Regards:

Uwe Fechner

32
General Board / Error when copying diagrams
« on: November 12, 2007, 12:51:31 am »
Hallo,
if I copy a diagram with the option "deep copy" I get the following error:

Microsoft OLE DB Provider for ODBC Drivers[-2147467259]
ERROR: function val(character varying) does not exist; error while executing the query.

The diagram is copied, but the links between the notes and element features are are broken.

We are using EA 7.0.818 with psqlODBC 8.2.500 and postgreSQL version 8.2.4 with ssl encryption enabled.

Any hints appriciated.

Uwe Fechner

33
General Board / Order of packages and elements in packages
« on: November 07, 2007, 04:27:34 am »
Hello,

I created a package diagram and draw a package (package A) onto it.

First case:
It contains only packages
Second case:
It contains only requirements

The packages and the requirements within package A are shown on the diagram. Thats fine.

BUT:
The order of the requirements and the packages is very different from the order, that they have in the project browser. If I change the order in the project browser, nothing happens in the diagram.

Is there a way, to fix this behavior?
I want to have the same order in the diagram and the project browser.

The option "Sort features alphabetically" is already switched off.

Regards:

Uwe Fechner

34
General Board / Visibility of class name prefixes
« on: October 12, 2007, 06:16:41 am »
Hello,

I create a class with the name TParent (no attributes,
no methods). Than I increase it's size on the diagram
with the mouse.

Then I create a class TChild.

Then I move TChild on top of TParent. Now the name
TParent::TChild is displayed as name of TChild.

Sometimes this is fine, but is there an option, to hide the prefix, so that only TChild is displayed in the diagram as name of the class?

Any help appreciated:

Uwe Fechner

35
General Board / DAO.QueryDef[3074] Error with SysML
« on: August 21, 2007, 10:35:10 pm »
Hello,

I use EA 7.0.815 on Windows XP with the SysML plugin.

I added a Block Definition Diagram to an existing Model with Audit Tracking enabled.

I get the following error message, if I add a new Block to the diagramm:

DAO.QueryDef[3074]

Syntax error (missing operator) in query expression
'[Object_ID]=- AND[Property]='isEncapsulated'.

Any idea?

Regards:

Uwe Fechner

36
General Board / how to add a block property?
« on: August 22, 2007, 12:39:28 am »
Hello,

how can I add a block property to a block in sysml?

Regards:

Uwe Fechner

37
General Board / Re: Using PostgreSQL as UML repository
« on: August 07, 2007, 10:01:05 pm »
Quote
Performance-wise we have typically seen better results from MySQL than from PostgreSQL.

When using ISAM or InnoDB tables?

PostgreSQL often does need a little bit of tweaking of the configuration settings, to achieve a good performance.
My experience is, that MySQL is a little bit more performant with very simple queries, but PostgreSQL is much more performant, if you use complicated queries with many tables and relations.

And PostgreSQL uses an additional object ID field by default. You can switch it off, if you don't need it (this brings a little bit better performance).

Regards:

Uwe Fechner

38
General Board / Using PostgreSQL as UML repository
« on: August 07, 2007, 04:03:01 am »
Hello,

we bought a couple of EA licences and want to migrate to an SQL server.

Our admin suggested using PostgreSQL instead of mysql.

Does EA work well with a PostgreSQL 8.2.4 database server?

Regards:

Uwe Fechner

39
General Board / Re: Revision of UML-Model in database
« on: August 06, 2007, 02:43:05 am »
We want to use EA together with RA-Quest.
RA-Quest already allows to audit changes of requirements and to restore old versions of a requirement.

Therefore I would prefer to avoid using an external version control system for the model.
(We keep the code in SVN.)

For our development cycle it would be sufficient to use the audit logs during the development of a new version and to create a baseline for each released version.

Regards:

Uwe Fechner

40
General Board / Revision of UML-Model in database
« on: August 05, 2007, 11:30:40 pm »
Hello,

if we store the UML Modell in an sql database, e.g. MySQL, using transactions:

In this case it SHOULD be possible to have a revision number of the model, that is automatically calculated.

Is this sort of mechanism already implemented?

Working with audit trails would only be useful for us, if there would be a way, to identify a curtain revision of the model. This revision number should be included in the printouts.

Is this already possible, or do I have to write a feature request?

A timestamp is not really usefull, because it can easily happen, that a pc doesn't have the correct time, or that different pc's in a team have different times.

Regards:

Uwe Fechner

41
General Board / Link requirement to method?
« on: July 12, 2007, 05:02:03 am »
Hello,

is it possible to link an requirement to a method or an attribute, or only to a class?

Would it be sufficient to link requirements to classes, to fullfill the demands of the FDA (Federal Drug Administration)?

Regards:

Uwe Fechner

42
General Board / How to avoid model corruption?
« on: July 11, 2007, 11:17:45 pm »
Hello,

we think about transfering our .EAP files into a MySQL (or other) database.

Does EA use transactions, to avoid any data corruption, if a client (or the network connection) crashes?

Regards:

Uwe Fechner

43
General Board / Re: RaQuest Error
« on: July 11, 2007, 10:57:34 pm »
Hello,
I solved the problem :) .
It was related to corruption of the EAP File.

I could repair it using the the menue entries
Tools -> Manage .EAP file AND
Tools -> Data Management.

I wasn't aware before, that there are two different
repair tools for corrupted EAP Files.

It works fine now.

Thank you:

Uwe Fechner

44
General Board / RaQuest Error - SOLVED -
« on: July 11, 2007, 04:12:16 am »
Hello,

I am evaluation RAQuest and get the following error message:

Unable to open project.
(Object variable or With block variable not set)

Before I could open this project, now I can't.

Any idea how to fix this problem?

Regards:

Uwe Fechner

(Using EA 7.0 professional and RaQuest Trial 2.4 Build 048 )

45
General Board / Re: How to copy a submachinestate?
« on: July 17, 2006, 01:24:43 am »
Hello,

I found a workaround myself:

- copy the diagram first (deep)
- select all elements of the copy
- create a new submachine and double-click it
- paste the copied elements as link

Still it would be nice, to have the possibility to associate
a submachinestate with a state diagram freely.

Regards:

Uwe Fechner

Pages: 1 2 [3] 4 5 6