Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - tzafrir

Pages: 1 [2] 3 4
16
hi,

The problem:
I am creating a report and I need to have 2 values (each from a different query) presented in one fragment

Is it possible to put 2 queries together in one fragment? If yes, can someone give a simple example what the correct way that it should be done because currently I am only able to put one.

Thanks,
Tzafrir

17
General Board / Creating EA APP that connects to AWS
« on: December 05, 2016, 08:21:08 am »
Hi,

Does anyone have some APP example and\or some documentation
how to create an APP the connects and retrieve data from AWS (Amazon Web Services).

Thanks

18
General Board / Location of element description in DB
« on: November 16, 2016, 04:55:59 pm »
Hi,

Does anybody knows where the description part of the element exists on DB?

Thanks,
Tzafrir

19
Hi,
I am trying to add a fragment with SQL query I have created to a template I have also created.

In order to to that I followed the following user guide instructions:
http://www.sparxsystems.com/enterprise_architect_user_guide/11/reporting/adding_fragments_to_a_template.html

or to be more specific:

In the Content panel, at the appropriate point within one of these sections, right-click and select the Insert Template context menu option.
The Select Template dialog displays.

When clicking right click, I am only getting the System Templates and not the one I have created.

Does anybody know how I can see the custom ones?

Thanks


20
General Board / Generating a report for a specific diagram
« on: November 04, 2016, 08:08:20 am »
Hi,
I am trying to generate a report through customize template I have created.
I want to run it on a specific diagram has a unique name (and only on that diagram)

I have notices that you can generate report only to a package, and then it drills down to the diagrams below.

Is there a way to activate a filter (by parameter, or built in mechanism) to find my desired diagram underneath the package?


21
General Board / New border element questions
« on: September 12, 2016, 12:24:29 am »
Hi,
I have created a new border element questions as follows:

EA.DiagramObject diagBorderElement = (EA.DiagramObject)diagram.DiagramObjects.AddNew("l=" + leftPos + ";r=" + rightPos + ";t=" + topPos + ";b=" + bottomPos + ";", "");
diagBorderElement.ElementID=borderElement.ElementID;

It was created fine on the diagram but I have 2 questions about it:
1. How can I change the borderElement color (to Red) for example

2. I have noticed that this element creation, the partitions (swimlanes) in the diagram disappear.
Does anybody know how to create the new element without harming those swimlanes?

22
General Board / Drawing a square on a diagram
« on: August 28, 2016, 03:57:50 pm »
Hi,

I want to draw a square around an element on a diagram.
I have its left, right, top and button positions.

Does anybody know if there is any graphic API that i can use to do this?

Tzafrir

23
General Board / Getting a value from EA.Attribute
« on: August 01, 2016, 05:55:17 am »
Hi,
This is probably pretty simple but I can get the value from EA.Attribute.

I am getting all the attributes in the element (using element.AttributeEx)
Then running on all the attribute I am getting, I am seeing that I am getting the attribute name.

But I cant get the attribute value,
I tries to get a collection EA.Attribute attribute.TaggedValuesEx\TaggedValues and attribute.Notes
None of these is working even though I have values for the attribute in the Model.

Does anybody knows the correct API for this matter?

24
General Board / Using web service in EA
« on: July 14, 2016, 03:51:17 am »
Hi,
I have created a webservice, tested it (in visual studio) and saw that it is working properly.
I am now trying to make it work from AddIn.
I have added the ServiceReference Service.wsmx file to my references.

I have then added the using declaration:
using MyAddIn.MyServiceReference;

as needed for the webservice to be recognize.
Now I compiled and opened EA, EA loaded my AddIn and everything was OK.

When I added the line:
private MyServiceSoapClient client = new MyServiceSoapClient(); (which compiles ok)
But when opening EA and looking in the Manage AddIns, I am getting Error missing 0x80040154, and AddIn is not loaded.

As anyone encountered in such behavior, or know what is missing? because the error is not informative...

Tzafrir





25
General Board / Updating Diagram.StyleEx attribute
« on: July 03, 2016, 01:19:55 am »
Hi,

I am updating StyleEx variable with new data. (i.e. modifying its one of the ; separated variables, the MDGDgm one, with a new value) and updating the diagram with this new string:

currentDiagram.StyleEx = newStyleEx.

after that I am doing
currentDiagram.Update().

I have noticed that the variable is not getting updated.
Is this a read only variable that can not be modified?
or there is another way to have the diagram updated with the newStyleEx value.

Tzafrir







26
General Board / How to determine the profile of a diagram
« on: June 23, 2016, 05:20:45 am »
Hi,

Does anybody know how to determine either by API or field in table (t_diagram was my thought but its not there).
the profile that contain the diagram type.

Example:
I have a diagram type that is called basic flow that extends Activity diagram, this definition resides in profile named 'ABC'.
When I have the type of diagram (ABC) I would like to know the profile.

Another note, the profile are imported to the model using the MDG technology.

Thanks

27
General Board / Get a collection of diagrams the Model
« on: June 22, 2016, 03:19:30 pm »
Hi,
I need to get all the diagrams in my model
I tried to do it by getting all the IDs\Guids of all the diagrams in my model.

I used the repository API (for IDs):
sql = "select Diagram_id from t_diagram";
string result = repository.SQLQuery(sql);
But then I need to parse the resulting string xml.

(GetElementSet API did not help me for that matter as well)

Is there a more efficient way to do it by getting a direct EA.Diagram collection by using EA API?

28
General Board / API for marking an element on tree
« on: June 05, 2016, 03:20:38 pm »
Hi,
Is there an API that sets the tree focus on a given element?
(Assuming I have the element GUID).
Only found a getter API (repository.GetTreeSelectedItem())

Thanks,
Tzafrir

29
General Board / Adding new table to DB
« on: May 19, 2016, 05:49:20 am »
Hi,

Is it possible to add a new table to the DB or is it closed DB only for internal use?
If it is possible, what api is the best to use in order to run queries on it?

Thanks,
Tzafrir

30
General Board / Shrinking open package tree
« on: May 10, 2016, 12:02:11 am »
Hi,

I am doing some manipulation on elements underneath a package which results in opening of the package in the model tree.
Is there a way to collapse the package back to its original closed position in the tree after I am done?
I did not find an API that does that...

Thanks,
Tzafrir

Pages: 1 [2] 3 4