Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - bob

Pages: [1]
1
General Board / Re: Will EA work with an Orcale 12c DB
« on: February 14, 2017, 07:28:54 pm »
Another question came to my mind... does anyone know if I'd be able to connect to a 12c Oracle DB with an 11g ODBC Connection savely!? Or will all my users have to update their ODBC Connections?

2
General Board / Will EA work with an Orcale 12c DB
« on: February 14, 2017, 07:08:56 pm »
Hi there,

is EA able to work with an Oracle 12c DB? This site http://www.sparxsystems.com/enterprise_architect_user_guide/10/projects_and_teams/createaneworacle9iserverrep.html doesn't mention it.

But I think a former colleague of mine still had that setup... So is it working and/or supported or not? We are about to upgrade to 12c and if EA is not able to work with it we cannot do it.

Thanks for your support in advance,
Bob

3
Hi guys,

due to backup purposes I'm creating backups of the EA model on a daily basis.

I just realized doing it the first time in EA13 the resulting .eap file is now 20MB instead of 15MB before i switched to EA 13.

repository.GetProjectInterface().ProjectTransfer() is doing all the work, same logic on both ends just the EA version increased by 1.

Anyone any idea what could be the cause of this?! Data seems to be the same...

Many regards,

4
Thanks guys, I will keep on trying today and will either post my solution or further question later today for sure!  ;)

5
Thanks for the quick answer. I just realized, that under "Manage Add-Ins" Visual Studio and Eclipse are not loaded. (Error - Missing (0x800401f3)).

I'm guessing that the missing Visual Studio causes my Addin to fail!? Maybe any idea how to fix that? (They werent failing to load in EA12)

Im on the latest version 1309? What do you mean EA_GetMenuItems() could help? This is for Menu only right? I need EA_GetRibbonCategory to steer my ribbon placement, or no?!

6
Hi guys,

I really am stuck here.... I have written an c# addin for EA12 which is working well.

Now I finally upgraded to EA13 and my Addin simply doesnt get loaded. At least I dont get a ribbon entry (no matter what i do).

I tried with public String EA_GetRibbonCategory(EA.Repository eaRepo) and without (then it should get added to Extend).


BUT ALWAYS NOTHING. My MessageBox.Show even gets executet in EA_GetRibbonCategory and EA_OnInitializeUserRules, that means that EA has a handle of my addin... But still no chance of getting my menu entry.

Any idead what i  >:(could be missing migrating my Add-In from EA12 to EA13?!  :'(




7
Thanks, I will try updating and if that doesnt extending the ribbon myself. I will get back here as soon as I find something out.

8
Hi everybody,

i just installed EA 13 Test. to check if we can use it in the future and experienced one major problem so far.

I've written an Addin which parses .doc(x) files and creates EA entities automatically. Before the user could find it under "EXTENSIONS->MyAddin->Useroperations".

Now I registered my Addin with EA 13 and the menus to start it is nowhere to be found. Is there maybe a difference now to create menu items with the new ribbon interface? Has anyone met this problem? How can I make my Addin accessible again?!

Cheers,
Nils

9
Well try it yourself then in EA 12.1

10

I got one more question though:

Do you know of the issue that one cant even use the same Initial Value if its already beeing used as a name for any attribute?!

Is that supposed to be too? Is there maybe a workaround you know about? In v.11. EA didnt care about the Initial Value being identical to the value!


Cheers,
N.o.

11
Uml Process / Re: Enumerations - Empty attributes?
« on: May 19, 2016, 11:14:08 pm »
That sounds like a plan, how would I define that kind of behavior?!

12
Uml Process / Re: Enumerations - Empty attributes?
« on: May 19, 2016, 10:06:07 pm »
Well maybe this one wasnt defined clearly either:

I have an Enumeration type with the values:

A
B
C
D

now i want to add a fifth value which is empty..

So it would be:

A
B
C
D
" "
Hope this clarifies what i need :P

13
Ok I'll try :)

Well lets say we have a stereotype containing some values with aliases and initial values... Everything as usual so far no problems.

Now imagine you want to have the initial value changed in a future release but need to keep the old values because of the older releases.

Release Information is defined in the tagged values of every attribute.

I just need a way to have multiple attributes with the same name but different initial values under one Stereotype (in my case a simple enum)!

For Example:

Enum : EgEnum

Values: name type alias initialvalue
1)         val1   string v1  displayval1
2)         val2   string v2  displayval2
3)         val3   string v3  displayval3

Now i want:
4)         val3   string v3  displayval33

Another problem i just faced is that is isnt even possible anymore (in EA 11 it was, just tested) to have a different value and only the same alias and/or display value eg like that:
 
4)         val33   string v33  displayval3

In every of the described cases the error message is: Attribute with the same name alrdy exist!

14
Uml Process / Enumerations - Empty attributes?
« on: May 19, 2016, 07:24:41 pm »
Hi :)

Is it somehow possible to give an enumeration type's value the possibility to be empty?

I know that is was possible in EA 11 but doesnt seem like it is in 12.x!

Thanks again in advance,
N.O.

15
Hi there,

I'm facing a requirement to have release dependent display values (initial values) of Enums (our stereotype).

Is it possible to do that? Its important, that only the display value changes not the DB-Value (Name) of the stereotypes value?

Thanks for any help in advance!,
N.O.

Pages: [1]