Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - msdb

Pages: [1]
1
General Board / Task Scheduler
« on: September 12, 2016, 06:12:03 pm »
Hi

I've written a C# console program that uses the EA Api to access a repository and export an xmi file. I'm trying to make this program run automatically on a windows server 2008 with the task scheduler which works fine when I'm logged on to the server, however, I'd like it to be able to run when I'm not. This doesn't seem possible though, no matter what settings I use. Thus far, I've assumed that windows was the problem, not EA.

Has anyone tried something similar or know whether EA is unable to be launched without a logged in windows user?

2
Automation Interface, Add-Ins and Tools / Cannot update connector
« on: June 01, 2016, 06:30:34 pm »
In my C# program i have a method that should create a connector between two elements but it's throwing this error:
Quote
An unhandled exception of type 'System.Runtime.InteropServices.COMException' occurred in SparxProject.exe

Additional information: Cannot update connector as either the Start or the End object is NULL

The method:
Code: [Select]
static void LinkToSuperDepartment(Element subDepartmentOrEmployee, int superDepartment)
        {
            Connector aggregationConnector = subDepartmentOrEmployee.Connectors.AddNew("", "Connector");
            aggregationConnector.Type = "Aggregation";
            aggregationConnector.Stereotype = "Archimate2::ArchiMate_Aggregation";
            aggregationConnector.ClientID = subDepartmentOrEmployee.ElementID;
            aggregationConnector.SupplierID = superDepartment;
            aggregationConnector.Direction = "Source -> Destination";
            aggregationConnector.Update();

        }

The error occurs when Update() is called.

Do ClientID and SupplierID not specify the start and end objects of the connector?

3
Automation Interface, Add-Ins and Tools / API autostart
« on: May 27, 2016, 06:15:31 pm »
Hi

In my c# project im accessing EA with

Code: [Select]
App eaApp = (App)System.Runtime.InteropServices.Marshal.GetActiveObject("EA.App");

but it requires EA to be running. Is there a way to open EA automatically via code?

4
Bugs and Issues / GetElementSet query failure
« on: May 18, 2016, 10:21:21 pm »
Hi

I'm using GetElementSet to query some data in Sparx EA which generates the following error, seemingly when the amount of data becomes too large:

"DAO.QueryDef[3219] Invalid operation"

However, it works fine with smaller amounts of data.

How do I query my data without getting this error?


Pages: [1]