Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Eamonn John Casey

Pages: [1] 2 3 ... 7
1
OMG recently released a UML profile for ArchiMate in XMI. Why would the two profiles be different? Or is the OMG one more open to interpretation?

Thought these guys were basically the same and worked together!

Maybe something to do With OMGs Unified Architect Framework and aligning ArchiMate to that...

2
General Board / Windows Authentication & User Principal Name
« on: June 19, 2018, 08:15:13 pm »
Has anyone experience With using User Principal Name instead of the usual Domain\Username Method of logging into EA?
Would I have to create a New set of users using the UPN instead?
Would this affect the SSO feature - that we would have to log in each time?

Thanks for any feedback on this!

3
Sunshine - I agree. I looked at the XMI and it doesn't make sense to map active elements to Class and not Activity. Think Open Group has got it wrong  :D. But for UML-only Tools like Magic Draw maybe it is a benifit for them?

4
Is there any plans t updae the ArchiMate MDG to be more in line With the OMG UML Profile ?

5
Automation Interface, Add-Ins and Tools / EU GDPR MDG Technology
« on: April 11, 2018, 05:46:53 pm »
Hi!
This question is specific for people modelling information flows in preperation for compliance to the European Unions General Data Protection Regulation.

1. Is anyone using EA to model and document data flows for GDPR?
2. Anyone made or knows og MDG Technologies that can be used? I came on this one https://www.linkedin.com/pulse/gdpr-data-flow-mapping-approach-tim which is basically UML Activity.

Input appreaciated,
Eamonn J.

6
Thanks for the post.

Almost got it working. In UML Types I got Base Class set to class. That is the same base class for ArchiMate3: Components. But the shape script will only draw when I remove the ArchiMate3 stereotype from the Component.

Seems like ArchiMate3 shape script hides the rengering I am trying to do.

EjC

7
Hi,
I am using ArchiMate v3 and one of the things in the specification is placing a letter in the top left corner to signify which layer the element belongs to. I am New to schape scripting but don't know where to start.
I have added Project Template Package as in the documentation buut need now to change the script.

Thinking maybe something like:
Code: [Select]
drawnativeshape()
orientation = ne
print("A")

Which menu in Enteprrise Architect v13.5 need I be using?

Thanks,
Eamonn J.

8
harshvir

>> 1. Strong Programming skills.
I have fumbled my way through the documentation og the EA API and definitly used this forum MANY times. When scripting diagram generation it was the complexity of X,Y coordinates and ensuring nothing overlaps. Enterprise Architect Diagram Layout usually gives very bad results in my opinion.

>> 2. Citrix
We use a locked down network as weill. To "program on the outside" you'll need an development environment like SharpDeveloper. Not an option here (or for me). Luckily we develop alot of our own software for ourselves - so we got a developer environment With more freedom. Don't have one? Then you will need to "program on the inside" within EA as indicated by Arshad.

Another tip: You can use EA to reverse engineer the database to discover attributes that are not available in the API. The EA API responds With JSON format. But using JSon2CSharp free online convert you get classes to deserialise anything.

Check out my GitHub link I sent. I admit I am no guru either but thankfully we got Internet.

/ EjC //

9
Automation Interface, Add-Ins and Tools / Re: WebEA user authentication
« on: February 20, 2018, 02:34:53 am »
Uffe,
 I registered this With Supprt a few weeks back and the response is that Windows Arctive Directory login "does not work as intended".

I do not want to og to the bother of:
a. Creating a Enterprise Architect account for each Active Directory user (e.g. AD/Account --> EA/EA_Account).
b. Neither do I want to open the WebEA for "Public Access" (no user).

If you post it as a Bug, I will +1 it. Just simply have not the time right now.

Here is Support:
Quote
Re: Reference Number: 17127682 : WebEA: 400 Request does not contain User ID

Unfortunately there is not currently any workaround to login to a security enabled model in WebEA without entering an ID/Password. Currently you will need to use login_prompt = "true" and enter credentials to log in.

Please also note, WebEA does not support automatic login using Windows Authentication. When functioning as intended, the only way to login (to a Security enabled model) in WebEA without a User/Password prompt is to use...

From this it seems that Active Directory Security MUST be switched off....

Eamonn J.

10
General Board / Export elements from several subpackages to CSV
« on: February 18, 2018, 10:17:00 pm »
I have a package With subpackages containing elements. Is there a way to Select the parent package and export all elements in the subpackages to a CSV file? Some wort of SQL maybe?

11
General Board / Adding bends to existing connectors
« on: February 13, 2018, 11:27:48 pm »
I see that there is functionality to hold Down Shift while drawing a new connector. But is there a way to draw bends on existing connectors? I got loads of diagrams using the same connector and I only get to choose the defalut Routing types after the first diagram. Makes it very hard to make the diagram look pretty (and readable).

12
Scripting is  the way to go. There are some EA wrappers on GitHub to get you started.

Here is a wraper (and diagram code) I have made and used.

https://github.com/EamonnJCasey/Sparx-Enterprise-Architect-Wrapper

Using the Diagram Loayout functionality was not good enough. So there is alot of coordinates to keep track of.

Enjoy,
Eamonn J.

13
General Board / Re: Using a central local help library
« on: February 03, 2018, 01:13:55 am »
Hei,
Thanks for replies. Was able to move Help System to an alternative location on the network that is mapped up on login. So that Works fine.

I am going to try out hosting it on Internation Server.  ;D

14
General Board / Using a central local help library
« on: February 01, 2018, 08:47:14 pm »
Is there any way in EA 13.5 to point to a Central help file? Our users run in a secure environment With no internet Access and no permissions to install software. Software gets pushed out to Virtual machines and I do not want to replicate help system for Our user base.

Thanks
Eamonn J.

15
General Board / Diagram Details hide when publishing
« on: January 16, 2018, 10:14:03 pm »
Hi!

Is there an option or setting where I can show Diagram Details in Enterprise Architect but when I copy to clipboard or publish that I can hide the details?

Eamonn J.

Pages: [1] 2 3 ... 7