Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - kotrick

Pages: [1] 2
1
General Board / Version Control While Accessing Model Via Citrix
« on: November 16, 2016, 04:15:52 pm »
We are using Oracle Database for Architecture Model which is  located in Frankfurt

Its difficult to access this model for Users from different location's as its very slow. We use Citrix Server to make the Model Access Faster from different location.

Recently Version Control was introduced in model to maintain history using SCC Integration

Issue:
Currently we are not able to use Version Control via Citrix as we get error's when multiple user's connect to same citrix server to perform check-in check-out operations

So we are in a situation were we cannot use Version Control via Citrix. And to access model directly remotely its very slow so user's cannot perform check-in check-out operations Locally without Citrix and with version controlled model.

Can you provide any suggestion to solve the problem above?How can we make model access faster irrespective of database location so that user's use version control locally OR How to make Version Control working for multiple user's via Citrix?

Thank You

2
Hello Everyone,

I am developing add-ins for EA using Visual C#. Do anyone know what is best approach to setup a automated testing of these add-ins.

Do anyone is already doing Automated testing. If yes then what method are you using to do.

I feel its difficult to test all add-in for every release or for every change we do to check impact on other add-ins due to my changes.

Can anyone please help or provide suggestions.

Thank You in advance for help



 

3
Bugs and Issues / Re: DAO.QueryDef[3131] While executing query in .e
« on: January 10, 2014, 07:10:02 pm »
Hello,
I am able to execute query without any errors in oracle and also if Enterprise Architect Project is in oracle

But if i run the same query in .eap file EA throws the error which i have specified in subject line.
I did not understand your reply can you please suggest clearly how i can handle the issue

4
Bugs and Issues / DAO.QueryDef[3131] While executing query in .eap
« on: January 10, 2014, 05:43:50 pm »
Hello,
I have a very complex query with subqueries,JOINS used in that which executes succesfully when EA is in oracle.

But if i execute same query in .eap file it throws below error
DAO.QueryDef[3131] Syntax error in FROM clause

Can anyone please help or provide suggestion to solve this issue

5
Hello,

We have developed many plug-in's for Enterprise Architect and we are interested to do this activity in TestDriven Development.

We are developing plug-ins using visual c#(Visual studio 2010)

I want to write test cases for these add-ins.But have below issue:

How to get the repository object and start running test cases?
Can anyone please suggest or help me to identify solution for testing EA add-ins

Thanks in advance

6
Hello,

I want to find number of diagrams currently open in EA.Based on that need to do some further processing.

7
Automation Interface, Add-Ins and Tools / Api to get all open diagrams in EA
« on: September 15, 2014, 04:48:02 pm »
Hello,
I want to get list of diagrams which are open in EA.
Can any one help?

Thank You

8
Thank You for reply.

I am interested in setting "Allow Duplicates" checkBox of a FlowPort or Port using api.


9
Hello,
I need to set  "Allow Duplicates" and "Multiplicity is ordered" checkBox for port using EA api.Can anyone help

10
Hello,
I want to keep the connector direction as Unspecified for itemflow.

When we create new connector EA_OnPostNewConnector event returns a connector with Unspecified direction but after the execution of above specified event it automatically sets itemflow direction to                Source->Destination in the opened diagram.
Can any one suggest at what point the direction is updated.or how to set the connector direction in EA_OnPostNewConnector event and retain it in opened diagram

11
Automation Interface, Add-Ins and Tools / Re: EA 10 Diagram objects issue
« on: December 05, 2013, 09:53:33 pm »
i found a work around using Repository.Execute(SQLQuery) api am able to set the diagram objects at specific locations.

12
Automation Interface, Add-Ins and Tools / EA 10 Diagram objects issue
« on: December 02, 2013, 11:15:54 pm »
Hello,My automation script creates a diagram and places the ports at some co-ordinates.
In EA 8 it was working fine.When i move to EA10 i see the diagram is completely spoilt..All ports are placed at top left corner of objects.
In Debug mode i found While updating and refreshing the diagramObjects the co-ordinates of ports change automatically..which is not correct.
can any one suggest solution.
I want to place the port at some location of the parent object

13
Hello,
I was using Repository.Execute(sql) api in EA version 8 or below for my automation script.
In EA 10 i dont find any such api.
Do we have any similar api ?
can any one help me to solve this issue
Thank you

14
Thanks i got the expected result

15
Thanks a lot,

i need to disable few addins based on username how can i do it.Am writing in c# for addins development.


Pages: [1] 2