Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Thiyagaraj A

Pages: [1] 2
1
General Board / Z-order of an element?
« on: February 05, 2008, 02:08:38 am »
I am creating an AddIn through C# in .NET. How to set the z-order of an element in the diagram through AddIn methods?

2
General Board / link between the parent class method argument ...
« on: February 04, 2008, 03:55:54 am »
Is there any way to link the parent class method parameter with the child class method parameter?

3
Bugs and Issues / Bug in rendering.
« on: February 28, 2008, 11:32:57 pm »
I have created a ActivityParameter profile. when I try to add that profile to an activity the parameter got added, but it doesnt get added to the border of that particular element. But if we move the particular element, it gets added to the border(As like embedded elements). Is there any way to avoid it? Or is it a rendering bug ?

4
Bugs and Issues / Parameter inclusion notification?
« on: February 06, 2008, 09:00:33 pm »
I am creating an AddIn. I wanna a get a notfication when a parameter is added to the method. EA_OnNotifyContextItemModified() gives me the class that has the particular method not the method itself.

5
I have created an Add-In where in a  pop up window will be shown when an user add a new element. On that I am getting values for Tagged Values of that element. But when i update it, the TVs are not getting updated. I am showing the same dialog when an user double clicks the particular element. Surprisingly this time TVs are getting updated. Does any body had this problem before?

6
Automation Interface, Add-Ins and Tools / Dynamic Tagged Value type?
« on: February 11, 2008, 03:32:05 am »
I am creating an AddIn. I wanna add a taggedValue which accepts say only boolean values. I know we can do that Tagged Value Types in EA. But I need to know how to do that through AddIn APIs. Any helping hands?

7
I need to give choices for the value field (options in a drop down) of a tagged value. I know it can done through profiles. Is it possible to do the same through AddIn APIs?

8
I have an IntteruptibleActivityRegion in my profile, when i add it in a diagram it again asks for what selection for InterruptibleActivityRegion or ExpansionRegion, though there are two different meta classes in profiles. Is there way to directly include Int.ActivityRegion as part of our profile?

9
Automation Interface, Add-Ins and Tools / Can we group tagged values?
« on: April 21, 2008, 04:10:40 pm »
Can we have groupings for tagged values?
For ex., tagA and tagB are grouped under XX, and another tagA and tagB are grouped under YY. Is it possible?

10
Hi I have created a profile. I wanna to show only that profile in the toolbox when a user opens a particular file(.eap). I think it has to do with rep.activatePerspective(). Can any one worked on this?

11
Is there any way to grab a key board event from an AddIn. If there is no direct way is there an indirect way?

12
Hi,
Can CTF be applied to elements other than class. Can it be applied to elements like Activity,Region,Parameter. Because in the documentation I couldn't find much related to this.

13
I need to hide the particular element connectors from an AddIn. Is there a way in AddIn API. (It can be hiding connector by connector.)

14
I am having a MDG technology imported.
Is it possible to take an element from the technology and add it to the diagram without users drag and drop. That means, when a user clicks an AddIn menu option we should be enable to take an element from the technology and draw it in the diagram.

15
Automation Interface, Add-Ins and Tools / Rendering problem?
« on: February 27, 2008, 09:33:15 pm »
I have created a ActivityParameter profile. when I try to add that profile to an activity the parameter got added, but it doesnt get added to the border of that particular element. But if we move the particular element, it gets added to the border(As like embedded elements). Is there any way to avoid it? Or is it a rendering bug ?

Pages: [1] 2