Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - damo1978

Pages: [1]
1
General Board / Object hyperlinks in published HTML
« on: November 18, 2015, 02:06:03 am »
I am publishing a model to a web server and I would like for objects that are used within sequence diagram operations to link through ultimately to the domain model object that is reference in the input/output of the given operation.

For example in the sequence model, the operation: getAnObject(ObjectA) : ObjectB

ObjectA and ObjectB are from the domain model.  When I publish the HTML of the entire model, the messages on which the descriptions of this input/output parameters are presented on the page are not click-/hyperlink-able.

The operation has been defined against the target domain object, say DomainObjectA, which is hyperlinkable and contains the list of all its operations, of which getAnObject is one.  So in the notes of this operation I intended to compensate that lack of hyperlinkability by using the EA hyperlink to an element functionality.  But when I publish this to HTML, it is linking to an object GUID and therefore doesn’t link to the HTML of the page containing this information, say EA23.html.

I have tried other EA hyperlinking methods and none of them seem to translate to the published HTML output.  The only way I see this as possible is that if I publish the entire model, then manually identify the HTML web page, and then copy this back into the model as an absolute link.  This is painfully inefficient.

Have I completely missed something?  :-/

Thanks

2
General Board / Sequence objects not underlined in v12
« on: July 01, 2015, 06:32:01 am »
Could anybody explain why my objects in the sequence diagrams since version 12 are no longer underlined to represent an object instance vs. a class?

I've search as many visual options as I could find.

3
General Board / Lifeline note links to activation line
« on: July 01, 2015, 06:35:34 am »
Can anybody advise if there is a way in EA to extend the length of a note's link/relationship to the lifeline's activation line?  The note link seems to stop at the outer edge of the lifeline, as if there is an invisible edge of the same size as the object at the top of the lifeline.

There are random times, which I find very hard to replicate, where the note links all the way to the centre of the lifeline.  I want this to be the default action.

Thanks

4
Bugs and Issues / XSD Export - Truncating similarly named packages
« on: October 02, 2015, 04:43:38 am »
I've had this issue for a long time so I thought it's about time to raise it.

I have quite a large class model which is a platform-independent model used as a canonic model, which I then export to an XSD for implementation into our middleware platform.  The model has many packages, general only with one sub-package per main domain area.

Example of package structure:

ConsumerApplication
Party
PartyRelationship
    PartyRelationship_BU
CRM
    CRM_BU
Document
DocumentTemplate
FinancialAccount
    FinancialAccount_BU
FinancialTransaction
    FinancialTransaction_BU
Order
OrderEvent
SuccessError

The sub-packages are simply specialised area per business unit, and I don't think particularly important.

When one package references another, say a PartyRelationship object is used in the Party model, the following happens in the Party model XSD export

<include schemaLocation="../CRM/CRM.xsd">
<include schemaLocation="../SuccessError/SuccessError.xsd">
<include schemaLocation="elationship/PartyRelationship.xsd">

When it should be:
<include schemaLocation="../CRM/CRM.xsd">
<include schemaLocation="../SuccessError/SuccessError.xsd">
<include schemaLocation="../PartyRelationship/PartyRelationship.xsd">

Similarly, if Order references OrderEvent:
<include schemaLocation="vent/OrderEvent.xsd">
Instead of:
<include schemaLocation="../OrderEvent/OrderEvent.xsd">

This only seems to happen where there are packages that are similarly named, and have a reference to each other.  It doesn't happen to the Financial* starting ones, but that may be because there isn't a stand alone package, e.g. Party and PartyRelationship, where Party is stand alone.

I've tried doing a transform to an XSD stereotyped model first before then exporting this.  And direct to XSD.

I believe it's some sort of but with the XSD export script but I cannot be sure.  If anybody has any ideas it would be very much appreciated.

Thanks in advance.

5
Bugs and Issues / Association Owner - Default
« on: October 01, 2015, 09:04:53 pm »
Since upgrading to v12 (12.0.1215) when working with associations between classes, EA will add set the 'Owned' attribute to True by default when manipulating the association, for example....

If I have created ClassA and ClassB and have an AssociationA between them, newly created, this will not have the Owned flag set, or will at least be False.  If I were to create a new ClassC, and the drag the AssociationA from ClassB to ClassC, this then sets the Owned flag to True.  This is visibly indicated by the solid circle at the endpoints of the association.

I've not used Owned associations in any of my UML modelling in the last 10+ years, and for the most part I do not need to use it - not entirely sure what semantics/syntax it is providing.

Is there a way to switch off this default action because it is very irritating having to go into the association properties > role > advanced, and then for each Class change the flag.  It's painfully slow.

Thanks


6
Bugs and Issues / Sparx Cloud / FDB Issue
« on: July 03, 2015, 05:54:58 pm »
Below has been sent to support.  Has anyone else experienced this issue that can help?

====
We are trialling the Sparx cloud services so that we can eventually rollout a shared repository function via it.  We are aiming very soon to have a MS SQL-served repository, but whilst we’re waiting for that to be provisioned, we are using a Firebird DB on a VDI drive, and accessing this with our client EA application via the Sparx cloud service.

The errors can be said to be intermittent, but generally the occur on the client EA app when adding things in the repository.  They particular occur when moving elements under other elements, say an Activity into an Activity on a diagram, which results in the expected move of the Activity element in the repository moving subordinate to the parent Activity element.  But, the errors also occur when adding new elements directory to the repository.

This occurs on any shared repository that is set up.
We have only a small number of users with access, up to 2 or 3.  This occurs even when there is only one user accessing the repository.
We have currently not added any 3rd party version control to any of the tested repositories.  We are planning to do this with SVN, but until we have bottomed out this issue we don’t want to add further diagnostic challenges.

Even though these errors occur, it does seem to affect the overall function of the shared repository, i.e. the changes are reflected by to the repo, and each other user can see those changes.

The configuration details below show that we’re on an early version of 12, but a recent version of the cloud service.  It has taken us quite a while to get v12 through our packaging process.  So if there recommendations to upgrade before continuing with diagnostics, please bear this in mind that this may be a challenge.  We may be able to have single users upgrade to test this, but we will need dispensation from our package deployment team.  Please also note, these errors occurred even with the earlier versions of the cloud service.


Configuration
EA version: 12.0.1209
Sparx Cloud version: 1.0.10.1 (the installation binary is stamped @ 29.04.2015 @ 05:24)
Database: FDB
Server/VDI: 8GB / 4 cores

Client Console - System Output
@07:19
Cloud Services: Query in batch execute failed with message: FAIL: Microsoft OLE DB Provider for ODBC Drivers [-2147467259]

[ODBC Firebird Driver][Firebird]deadlock
update conflicts with concurrent update
concurrent transaction number is 44865                
Cloud Services: Query in batch execute failed with message: FAIL: Microsoft OLE DB Provider for ODBC Drivers [-2147467259]

[ODBC Firebird Driver][Firebird]deadlock
update conflicts with concurrent update
concurrent transaction number is 44869                

Server Logs
2015-07-03 07:18:21 [WARNING]: Microsoft OLE DB Provider for ODBC Drivers [-2147467259]
2015-07-03 07:18:21 [WARNING]: [ODBC Firebird Driver][Firebird]deadlock
update conflicts with concurrent update
concurrent transaction number is 44865
2015-07-03 07:18:21 [WARNING]: Microsoft OLE DB Provider for ODBC Drivers [-2147467259]
2015-07-03 07:18:21 [WARNING]: [ODBC Firebird Driver][Firebird]deadlock
update conflicts with concurrent update
concurrent transaction number is 44869

Pages: [1]