Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - qwerty

Pages: 1 ... 9 10 [11] 12
151
When I try to assign a value (off or standard as suggested by the help) the compiler claims
Quote
Error: Invalid value for orientation. Acceptable values are: "nw", "n", "ne", "e", "se", "s", "sw", "w", "nw",  and "center"'off

Has anybody at Sparx tested this shape script in any way? I do not expect an answer to that question >:(

q.

152
Can someone confirm that the following shape produces non-sense:

Code: [Select]
shape main {
      MoveTo(50,50);
      ArcTo(0,0,100,100,100,50,0,0);
}

Even worse:
Code: [Select]
shape main {
      MoveTo(50,50);
      ArcTo(0,0,100,100,100,50,100,0);
}

q.

153
Someone getting sick of this? Well, I am...

I tried to use sub-shapes with 2 parameters where layoutType="border". It seems that only "N" and "CENTER" produce results, both being the same. Using "S" shows some strange result in the preview, but none at all on the real diagram.

q.

154
Automation Interface, Add-Ins and Tools / #classifier# in shape script
« on: January 15, 2014, 11:47:01 pm »
Has anyone an idea what this and the associated dot-notated hash tags will print? I have used Advanced/Parent and a Generalization. None seems to influence the tag. Bug?

q.

155
How do I do that? Println ("""") causes a compiler error. Println("\"") will print both the escaping backslash and the quote. Is there a #QT# or something crude alike?

q.

156
Automation Interface, Add-Ins and Tools / Creating a custom toolbox icon
« on: October 04, 2013, 07:43:30 am »
I was asked by someone how to create a toolbox icon in a MDG. I thought having done that in the past but could not remember. So I started trying and reading the help. Neither worked :-(

The EA help states
Quote
To set the icon for a toolbox item, locate the item in the Toolbox Items list and click within the Toolbox Icon column. Click on the ellipsis () within this column.  The Select a Toolbox Icon dialog displays. Locate the image file and click the Open button
But there is no Toolbox Icon column in the Toolbox Items list. They are plainly displayed as simple attributes - which don't have something like an icon.

Any help available?

q.

157
Automation Interface, Add-Ins and Tools / Wow!
« on: June 13, 2013, 04:26:14 am »
Instead of "Error - Missing" I now get "Error - Missing (0x80040154)"!

Which incredible step forward! An error code!

Would someone from Sparx be so kind to explain what this error code means? I mean, I'm no wizard nor a clairvoyant.

Honestly, I'm quite pissed off by the level of debug info we get from EA when it comes to automation or MDG deveolpment >:( >:( >:(

q.

158
Diagram.SelectedObjects

q.

159
I have just published a new e-book about EA's API at http://leanpub.com/ScriptingEA

It starts with a help yourself section so beginners are introduced into the basics. Quite some "bits and pieces" summarize inside information which is not obvious. A final cross reference from GUI to API (not yet complete) ends it up.

Although this is "under construction" I think the current state is worth while to be published. I'm planing to complete it over the next one or two months. Next chapters to be completed: final cross reference; object creation/manipulation.

Hope you enjoy it.

q.

160
I guess there are not many using just their own profile with everything else turned off. However, here's my observation: every now and then EA decides to enable the Extended profile. This can be seen when hitting the space key on a diagram. On top of Other/MyProfile the Extended menu is offered. Also the QL shows entries which are not from my profile but likely taken from the Extended profile.

I have no clue when this happens. For a time it did not happen but today it is turned on each time I start EA. After dis-/enabling my profile the situation is cleared but only after the next EA restart when the Extended profile is activated once again.

Before sending a bug report I'd like to know if anyone else experienced this behavior.

q.

161
It seems that when you create a stereotyped package from a profile and EA fires OnPostNewPackage it does not seem to supply the stereotype. Can anyone confirm that (9.3)?

q.

[edit:] I tried also to check for other profile data. The URI which appears in t_xref is created AFTERWARDS. At least I can not find it during OnPostNewPackage. A Tagged Value also seems to be created AFTERWARDS. Why, why, why? Should the method be called OnSomeWhereInbetweenCreatingPackage?

162
When you right click any element or connector in a diagram then EA offers the addin-menu in the context. I faintly remember a method to retrieve the selected element(s) in a diagram. But I can't find it now. How can I find out which element(s)/connector is/are selected in the diagram from an add-in?

q.

163
I wanted to create some elements based on the name of an element. But OnPostNewElement is called BEFORE the properties window is closed. So I guess the method should actually be called OnPostNewElementButBeforePropertiesAreEntered.

Any geert-around for this? (Just a rhetoric question...)

q.

164
Automation Interface, Add-Ins and Tools / Activating MDG vs. enabling
« on: April 06, 2012, 12:07:47 am »
Can anyone explain what Activating a MDG actually means. Once enabled the technology is visible an (I'd say) active. So what does Activating put on top of enabling (except for the asterisk in the list)?

q.

165
When defining a connector in a toolbox it is possible to choose the type. But how can I specify the direction? I want to define an undirected association but the connector is always created Source->Target since there is no way to set this default.

(I tried setting the notes to direction="undirected" and direction="Unspecified" but that does not work.)

Help!

q.

Pages: 1 ... 9 10 [11] 12