Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - qwerty

Pages: 1 ... 5 6 [7] 8 9 ... 12
91
General Board / Missing Cross-References on VC save - meaning?
« on: July 30, 2011, 02:40:40 am »
I don't remember since when this pop-up appears during check-in to VC. I always confirmed with OK. But I would like to know what it actually means. When I check in, how can the previous XMI contain things EA will preserve? Isn't the new XMI export telling the opposite? That does not seem to be logical.

q.

92
General Board / Difference btw. Scan XMI and Get All Latest
« on: August 18, 2011, 02:58:56 am »
After reading the documentation it looked to me as if Scan XMI and Reconcile Model would be a part function of Get All Latest (obviously called in the end). Further I believed it would just read the XMI files. But actually when invoking Scan XMI EA is in a busy loop just like for Get All Latest (the heavy network traffic is a good indicator for that). So my question: what is the advantage of Scan over Get? Or is it just one more bug?

q.

93
General Board / Disable Spell Check
« on: June 16, 2011, 03:30:45 am »
I'd like to know whether there is a way to disable the spell checker. I couldn't find one. Even removing the dictionaries did not help (it underlined all words). The reason is simply that we have two languages mixed in one model and of course you can't tell EA which text is of which language. So either the one or the other gets underlined (more or less completely). (Further I don't like spell checkers, but that's a different story.)

Does anyone have an idea or should I request a new feature?

q.

94
General Board / Beta period
« on: June 08, 2011, 02:01:37 am »
Today I got a message "The beta period has expired...". But I have the latest version installed. Well, it's just that annoying and wrong message which simply needs to be confirmed to start EA. But I want to get rid of it! And I don't want to spend time in un-/re-installing and loosing screen layouts a.s.o.

q.

95
General Board / V9.3 diagram window usage
« on: April 20, 2011, 11:27:02 pm »
Is it with V9.3 or has this been introduced before: The diagram window has a Format menu on top.

Can this be turned off? It cuts the diagram frame. I already have all these nifty buttons in one line.

q.

[edit:] Ah! There's a button to close it near the closing box.

96
General Board / Working offline with VC packages
« on: April 14, 2011, 08:58:31 pm »
I wonder if there is a simple way to work offline with a VC package. With offline I mean that I also do not have VC on the offline computer. What I currently do is the following:
  • Check out package (let's call it PKG)
  • Copy the according XMI to the remote machine
  • Import the XMI for PKG remotely. (The remote model had once been created from a root model export/import.)
  • Work remotely and change elements in PKG.
  • Create a dummy package called TRANS inside PKG.
  • Move everything inside PKG into TRANS so PKG just contains TRANS.
  • Export TRANS to XMI
  • Import that XMI in the VC repository into PKG
  • Now changes are present in the VC PKG
  • Move everything out of TRANS and delete TRANS
  • Check in PKG
This looks not only clumsy, it is...

I wonder if there is an easier way to achieve the above.

q.

97
General Board / Bug tracker
« on: April 07, 2011, 12:48:53 am »
Hi there,
I just thought it would be easier for me to manage my tickets with Sparx using a bug tracker. So I googled a bit and landed here.

I just posted the mail correspondence I found for each report along with the reference ID from Sparx.

If you think it's a good idea to share the bugs you reported then leave a reply here. All you need is a free registration at this site and it will be possible to share the list.

q.

98
General Board / Bugs and features
« on: March 14, 2011, 09:18:21 pm »
This post is triggered by the discussion about the V9 beta.

So I just wrapped up my activities of the last year.

23 Bugs reported
6 of them did not receive a reference id at all
2 were lost (as I now noticed) as I only got that "Thank you" reply

12 Features requested
2 did not get a reference id
2 were lost

What I can say is that Sparx actually reacts (on most) reports quite fast. Also the supporters are competent in what the say. This is the positive side.

On the other hand it seems that only very few of the discussion finally reaches implementation state. I haven't verified yet how many bug/feature requests have been implemented but from a rough guess is definitely(!!) below 10%. It was quite cumbersome to sort out the reports according to mails and I actually do not have direct feedback to what has happened to single reports. (Well, I could ask using the reference id but that's not only cumbersome for me but especially for the Sparx supporters.)

Additionally the lost requests (4 out of 55 which is almost 10%!!!) give me a very bad feeling of what is happening behind the scenes. The bad thing is, that I reported bugs (and feature requests) with a description but I only get that simple "Thank you". I do not remember the details and I have no chance to dig into the subjects. If simply the "Thank you" would echo the complete details I would have a chance to inquire at a later time but that way...


q.

[edit:] further investigation shows for above bug reports
5 are being investigated (means I have to poll)
5 have been logged for bug fixing (ditto)
1 is not reproducible
3 have been fixed (at least with V9)

for the features
3 still under invetigation
2 logged for bug fixing
3 fixed

[edit2:] I realized that in a few cases I sent a "the error was in front of the keyboard" message right after the bug submission. So some of the un-replied reports might be counted on that. However, definitely not all of them and at least the traceability is shown to be "improvable".

99
General Board / Using Baseline Compare to merge models
« on: January 12, 2011, 04:18:47 am »
Has anyone successfully used a Baseline Compare to merge updates? When I try that (and it's not only a single element but a package with lots of new elements) the merge process is more than tedious. You have to ctrl-click each and every element, package, relation, etc. instead of "merge the whole package contents". Am I missing something or is it not intended for a real merge?

q.

100
Bugs and Issues / Wrong use of extends
« on: November 02, 2015, 10:01:24 pm »
Someone really tried to learn something from http://www.sparxsystems.com.au/resources/tutorial/use_case_model.html. Dear Roy: would you care to at least draw the extends into the right direction. And - if possible in any way - do not use Login as use case. It is none.

q.

P.S. Thinking about "the wrong way" I come to the conclusion that the direction can't be told. Simply because Login is no use case it can not be extended. I first thought of "you need to optionally log in to Register".

101
Bugs and Issues / SQLQuery and time stamp
« on: September 22, 2015, 07:03:06 pm »
I tried retrieving a time stamp like this
Code: [Select]
my $v = $rep->SQLQuery("SELECT ModifiedDate FROM t_diagram");
print $v;
but EA returned only the date and not the time. But ModifiedDate is a time stamp as you can see when running the query in the SQL pad.

Bug reported.

q.

102
Bugs and Issues / Change multiple elements
« on: August 09, 2015, 06:11:12 am »
Using Element/Advanced/Change type I can have selected multiple elements. But the change is performed only on one of the selected elements. I faintly remember having ranted about this some time ago. So once again to cool down my anger: rant, rant, rant!

q.

103
Bugs and Issues / Missing features in states
« on: June 10, 2015, 03:27:20 am »
Unlike classes and other elements the properties dialog for states does not have a link to the attributes/operations. You need to use the context menu. EAUI  :(

q.

104
Bugs and Issues / State machine move operation
« on: June 10, 2015, 02:21:45 am »
When trying to move an operation from one state to another I get "requested move is not supported". Reason for doing it: I want to move an exit operation to the next state and make it an entry. Why shouldn't I be allowed to do that with a simple move?

q.

105
Bugs and Issues / Pasting rich text into notes
« on: March 20, 2013, 03:04:22 am »
I'm on V10. When pasting rich text into class notes I see two effects:
- The original size appears when pasting, but once re-opened the font has the default size
- Leading blanks seem to be stripped off
(FWIW: The paste buffer is filled from my Mac and travels through Parallels into the windoze environment, but that works fine for other applications.)

Anyone seeing the same result?

q.

[edit] The leading blank stripping seems to be an issue with EA/Parallesl paste buffer. When I paste into Wordpad first the leading blanks are preserved. Only when pasting directly into EA they get stripped. However, the size issue is still there.

Pages: 1 ... 5 6 [7] 8 9 ... 12