Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Knut Paulsen

Pages: 1 ... 4 5 [6]
76
Actually, it turns out that the second process also disappears, but it just took forever. Maybe 5-10 minutes.

It is the Repository opened with OpenFile that disappear when my process exits, the one opened with OpenFile2 remains.

I'm still interested if anybody has ideas to why it takes so long before the process goes away.

77
Hi Guys,

I have a problem getting rid of the EA.exe process after using the repository via the automation api. The following test code will open two different DBMS repositories, one using OpenFile2 and one using OpenFile and then close them again. After the two calls to CloseFile, both EA.exe processes appear in the task manager, but after my program exits, only one of them disappears, hard to tell which of the two processes that refuses to go away. Using C#, Win XP and MySql.

Any ideas?

try
            {
                m_RepositorySource = new Repository();
                m_RepositorySource.OpenFile2(c_SourceConnection, "user", "password");

                m_RepositoryTarget = new Repository();
                m_RepositoryTarget.OpenFile(c_TargetConnection);

                m_RepositorySource.CloseFile();
                m_RepositoryTarget.CloseFile();

                Environment.Exit(0);
            }
            catch (Exception ex)
            {
                MessageBox.Show(ex.ToString(), "Something failed", MessageBoxButtons.OK);
            }

78
Hi guys,

I managed to get this to work, but I set the SuppressEADialogs property to true in EA_PostNewElement(), then opened my custom property dialog.

like this:
if (element.Name.StartsWith("Use"))
                    {
                        Repository.SuppressEADialogs = true;
                        KnutForm form = new KnutForm(element);
                        form.Show();
                    }

79
Automation Interface, Add-Ins and Tools / Add-In Description
« on: November 22, 2011, 06:40:55 pm »
Hi guys,

When you open the Manage Add-Ins dialog from the Add-Ins menu and click on an Add-in, a description appears below. I would like to control what is written here, but I haven't been able to find a way to do this.

Any suggestions?

BR
Knut

80
Hi guys,

I would like to set the font color, then draw the native shape of an element. But I cannot find any way to set the font color from the shape script. Any ideas?

br
Knut P.

81
Automation Interface, Add-Ins and Tools / Re: Ghost language profile
« on: October 05, 2011, 04:38:13 pm »
Quote
Yep. Settings/UML/Stereotypes should be clean washed...

q.
Thanks a lot  ;D

Worked like a dream.

82
Automation Interface, Add-Ins and Tools / Ghost language profile
« on: October 04, 2011, 04:14:23 pm »
Hi guys,
I have created a language profile in which I do a simple modification of a use case element by setting a different fill color. And this works fine in the project where I maintain my language profile.

However, if I open any other project the use case elements do not have the expected color, instead they are decorated according to a language profile that I have removed long ago. I used to decorate the use case element with a small image, but this image is no longer part of my MDG file.

So, it is obvious that EA in some way remembers this old language profile, but I have scanned the installation directory and the registry without finding any trace of it. Anybody have a clue what is going on?

Pages: 1 ... 4 5 [6]