Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Geert Bellekens

Pages: 1 ... 6 7 [8] 9 10 ... 16
106
General Board / EA installed on SQL Server 2008?
« on: April 07, 2009, 05:51:24 pm »
Has anyone already installed EA on SQL Server 2008?
Is this still supported by Sparx?

Our database department is pushing to get all databases upgraded to 2008 but I'm afraid that we might loose support if we upgrade the EA database.

Geert

107
General Board / Shared model in TFS
« on: September 22, 2009, 06:25:57 pm »
We have following setup:
One repository (sql server database) with the model for department1
One repository (als sql server) with the model for department2
One model that is shared by the two department, this model resides in both repositories.
This shared model is the only one that is version controlled in TFS.
This setup works pretty good, I can checkout a shared package in any of the two repositories, edit it and check it back in. After such a change i can do a get Latest and I can see the latest version of the package in the other repository.
The problem i have is with the function "Re-sync all statusses with VC providers". If I have checked-out a package in dep1 repository and I perform this function in dep2 repository it sets the vc status of the package to checked-out, and it allows me to check it back in from the dep2 repository.
That is of course NOT the desired behaviour since this will wipe out all changes I was making in dep1 repository. This is a very dangerous situation to have.
I was thinking I could possibly solve this by having two seperate local folders for my version controlled files, but it looks like that is not possible with TFS.
Does anyone have an idea on how to solve this?

Thanks

Geert

108
General Board / When will 849 be released?
« on: September 15, 2009, 04:13:17 pm »
I have a feeling that it won't be long now.
Does anyone have more info?

Geert

109
General Board / How to link Activity with Operation
« on: September 25, 2009, 05:38:40 pm »
Hi,

I'm trying to figure out how to model the "method - specification" relation between an operation and it's behaviour (in this case an Activity).
According to UML there is such a relation, but I just can't figure out how to model it in EA.
Does anybody have an idea how to acomplish this?
Or otherwise, how do you link the behaviour of an operation (Activity, Interaction, ...) to the operation itself?
This seems lik such a basic type of thing, but I just can't find a proper way to model it in EA without resorting to custom tagged values.

Geert

110
General Board / Select type dialog in build 846 is great!
« on: July 15, 2009, 07:08:34 pm »
The new select type dialog in the build 846 is great!
This new feature is reason enough for me to upgrade the whole team.

Geert

111
General Board / Advanced properties messing up Compare
« on: July 08, 2009, 04:24:05 pm »
Hi,

I'm in the process of merging a "shared" model that was replicated in different models back into one single model.
Obviously, over time, there are some differences between the various "copies" of this shared model, but most of it it still the same.
I'm trying to use the compare utility to find the differences between the package in my model and an xmi export of this same package from another model.
The problem is that most of the classes come up as changed. When I inspect the changes I found that the only field that is different is the "Advanced Properties", but I'm not sure what exaclty is kept there and how to interpret it.
If I manually compare the classes in the two models I cannot find anything different about them.
Here is an example the difference on the "Advanced Property" field of a class.

From model 1:
Code: [Select]
$XREFPROP=$XID={254FB558-630B-4185-88A9-79D03A267CC4}$XID
$NAM=CustomProperties$NAM
$TYP=element property$TYP
$VIS=Public$VIS
$DES=@PROP=@NAME=isActive@ENDNAME
@TYPE=Boolean@ENDTYPE
@VALU=@ENDVALU
@PRMT=@ENDPRMT
@ENDPROP
$DES
$CLT={0751D80E-16CD-459d-9F18-628E7E5FA3F3}$CLT
$SUP=<none>$SUP
$ENDXREF
$XREFPROP=$XID={371C62C7-54F9-42b0-9891-C921F7308F2A}$XID
$NAM=Stereotypes$NAM
$TYP=element property$TYP
$VIS=Public$VIS
$PAR=0$PAR
$DES=@STEREO
Name=type
GUID={07B9FF09-13A6-461f-AD53-3CB48FF4FA24}
@ENDSTEREO
$DES
$CLT={0751D80E-16CD-459d-9F18-628E7E5FA3F3}$CLT
$SUP=<none>$SUP
$ENDXREF

and the same from the baseline (model 2 xmi file):
Code: [Select]
$XREFPROP=$XID={254FB558-630B-4185-88A9-79D03A267CC4}$XID
$NAM=CustomProperties$NAM
$TYP=element property$TYP
$VIS=Public$VIS
$DES=@PROP=@NAME=isActive@ENDNAME
@TYPE=Boolean@ENDTYPE
@VALU=@ENDVALU
@PRMT=@ENDPRMT
@ENDPROP
$DES
$CLT={0751D80E-16CD-459d-9F18-628E7E5FA3F3}$CLT
$SUP=<none>$SUP
$ENDXREF

Does anyone know if there is a way to ignore the differences in the advanced properties, or how to manipulate them so that they are the same in both models?

PS: I'm using 7.5 v844

Thanks,

Geert

112
General Board / Name Only for Show Parameter Details
« on: May 08, 2009, 10:24:46 pm »
Hi,

Since we upgraded to version 7.5 all of our diagram have reverted to "Type only" for the option Show Parameter Details. In the previous version all diagrams had "Name Only" selected.
What would be the best way to set this back to "Name Only" for all diagrams? I've looked in the Tools/Options, but I can't seem to find it something helpfull there.
Thanks

Geert

113
General Board / How create instance of deployment specification
« on: October 10, 2008, 08:58:23 pm »
I'm trying to create an instance of a deployment specification, but it isn't working.
I tried creating an object on my diagram and then via "advanced/instance classifier" tried to select my deployment specification, but it does not show in the list.
As a test I created a generic artifact in the same directory and that one allowed me to select it as a classifier.
A bit strange since artifact is the superclass of deployment specification.
Is this a bug?

114
General Board / Is EA really scalable?
« on: May 08, 2008, 05:21:18 pm »
Hi,

Does anyone have experience with scaling EA to a big corporate scale?

I'm talking 2000+ users in 5 different countries. The current models contain something in the order of 10.000.000 (10 million!) objects.

Any feedback is welcome.

115
General Board / 7.1 beta status
« on: January 29, 2008, 10:55:19 pm »
Hi,

I've just noticed the release of version 7.1 (beta). Wow, there are some really nice new features in there. Especially the formatting will make the crowd wild in this organisation.
Anyone know the average time between beta status and general available status?
We are on the brink of rolling out EA and I might consider postponing if the general version is coming very soon.

116
General Board / Object attributes unreachable
« on: January 17, 2008, 12:15:31 am »
I have noticed some weird behaviour in EA regarding object diagram.
Follow the following steps
- Create Class "Class1"
- add attribute to Class1 "ClassAtt"
- Create object diagram
- Create object on the object diagram "object1"
- Add attribute to object1 "ObjectAtt"
- set the classifier of object1 to Class1
- Try to edit ObjectAtt

There seems to be no way to edit the attribute of the object. I only get the dialog for the attributes of the class. I also haven't found a way to break the link between the object and the class.
Does anyone have a solution for this?

117
General Board / Version control puzzle
« on: August 24, 2007, 04:30:43 am »
Hi,

Another one on the version control.
I'm using EA 7.0.815 with an oracle repository (although for this problem I tested with a .eap file as well)
I'm testing the integration with PCVS (versions 8 (Merant) and 10 (Serena) through the scc interface.
First we tested Serena with two users userA and userB
We did following:
- A packageA is checked in in the VC
- UserA nor UserB can modify packageA
- UserA checks out a packageA from VC
- UserA can now modify packageA
- UserB cannot modify packageA

So far so good, works exactly as expected. Now I did the same test with PVCS8

- A packageA is checked in in the VC
- UserA nor UserB can modify packageA
- UserA checks out a packageA from VC
- UserA can now modify packageA
- UserB can ALSO modify packageA :o

No I'm really puzzled. It seems like the settings for PVCS8 and PVCS10 are exaclty the same. In EA I don't see a difference... I really don't know anymore.  ???
Anyone that can shed some light on it?

118
General Board / "String literal too long" importing XMI
« on: August 03, 2007, 12:26:17 am »
When I import a unisys xmi file directly into my Oracle repository I get several errors: "ORA-01704: string literal too long".
The importing screen is indicating that is is "Adding notes"
Importing that same xmi file in a local eap or MySQL repository works fine.
I'm using EA corporate v 7.0.815 and Oracle 10.2.0.2

119
General Board / Build 816 zip file misconfigured
« on: August 30, 2007, 08:55:28 pm »
Just downloaded the 816 build zip file, and unzipped it over my install directory. Instead of overwriting all the files in my EA install directory it created a sub-directory called EA70_816 and put all the files there.
I needed to copy them over my install directory to get the latest version.
I'll send an email to sparx support as well.

120
General Board / BUG: Strip GUID's corrupts database
« on: August 16, 2007, 09:58:48 pm »
I found a major bug in EA (7.0.815)
When importing an xmi file that was created using version control and selecting the option "Strip GUID's", the database gets corrupted someway. It crashes EA (windows application error: The instruction at "0x09bacd3d" referenced memory at "0x0000000c". The memory could not be "read".)
After restarting EA the model is no longer accessible, when trying to load the model EA crashes with the same message.
This bug is not related to the repository type. (I reproduced the error on Oracle, Mysql and .eap file)
It does seem to be related to the version control settings. We have Serena Dimensions (PVCS 10) setup as version control system through the scc interface. It is only when the version control is configured that it has this problem. When using a new project, without the version control setup, it imports fine.
I'll submit a bug report for this issue.

Pages: 1 ... 6 7 [8] 9 10 ... 16