Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Geert Bellekens

Pages: 1 ... 5 6 [7] 8 9 ... 14
91
General Board / Select type dialog in build 846 is great!
« on: July 15, 2009, 07:08:34 pm »
The new select type dialog in the build 846 is great!
This new feature is reason enough for me to upgrade the whole team.

Geert

92
General Board / Advanced properties messing up Compare
« on: July 08, 2009, 04:24:05 pm »
Hi,

I'm in the process of merging a "shared" model that was replicated in different models back into one single model.
Obviously, over time, there are some differences between the various "copies" of this shared model, but most of it it still the same.
I'm trying to use the compare utility to find the differences between the package in my model and an xmi export of this same package from another model.
The problem is that most of the classes come up as changed. When I inspect the changes I found that the only field that is different is the "Advanced Properties", but I'm not sure what exaclty is kept there and how to interpret it.
If I manually compare the classes in the two models I cannot find anything different about them.
Here is an example the difference on the "Advanced Property" field of a class.

From model 1:
Code: [Select]
$XREFPROP=$XID={254FB558-630B-4185-88A9-79D03A267CC4}$XID
$NAM=CustomProperties$NAM
$TYP=element property$TYP
$VIS=Public$VIS
$DES=@PROP=@NAME=isActive@ENDNAME
@TYPE=Boolean@ENDTYPE
@VALU=@ENDVALU
@PRMT=@ENDPRMT
@ENDPROP
$DES
$CLT={0751D80E-16CD-459d-9F18-628E7E5FA3F3}$CLT
$SUP=<none>$SUP
$ENDXREF
$XREFPROP=$XID={371C62C7-54F9-42b0-9891-C921F7308F2A}$XID
$NAM=Stereotypes$NAM
$TYP=element property$TYP
$VIS=Public$VIS
$PAR=0$PAR
$DES=@STEREO
Name=type
GUID={07B9FF09-13A6-461f-AD53-3CB48FF4FA24}
@ENDSTEREO
$DES
$CLT={0751D80E-16CD-459d-9F18-628E7E5FA3F3}$CLT
$SUP=<none>$SUP
$ENDXREF

and the same from the baseline (model 2 xmi file):
Code: [Select]
$XREFPROP=$XID={254FB558-630B-4185-88A9-79D03A267CC4}$XID
$NAM=CustomProperties$NAM
$TYP=element property$TYP
$VIS=Public$VIS
$DES=@PROP=@NAME=isActive@ENDNAME
@TYPE=Boolean@ENDTYPE
@VALU=@ENDVALU
@PRMT=@ENDPRMT
@ENDPROP
$DES
$CLT={0751D80E-16CD-459d-9F18-628E7E5FA3F3}$CLT
$SUP=<none>$SUP
$ENDXREF

Does anyone know if there is a way to ignore the differences in the advanced properties, or how to manipulate them so that they are the same in both models?

PS: I'm using 7.5 v844

Thanks,

Geert

93
General Board / Name Only for Show Parameter Details
« on: May 08, 2009, 10:24:46 pm »
Hi,

Since we upgraded to version 7.5 all of our diagram have reverted to "Type only" for the option Show Parameter Details. In the previous version all diagrams had "Name Only" selected.
What would be the best way to set this back to "Name Only" for all diagrams? I've looked in the Tools/Options, but I can't seem to find it something helpfull there.
Thanks

Geert

94
General Board / How create instance of deployment specification
« on: October 10, 2008, 08:58:23 pm »
I'm trying to create an instance of a deployment specification, but it isn't working.
I tried creating an object on my diagram and then via "advanced/instance classifier" tried to select my deployment specification, but it does not show in the list.
As a test I created a generic artifact in the same directory and that one allowed me to select it as a classifier.
A bit strange since artifact is the superclass of deployment specification.
Is this a bug?

95
General Board / Is EA really scalable?
« on: May 08, 2008, 05:21:18 pm »
Hi,

Does anyone have experience with scaling EA to a big corporate scale?

I'm talking 2000+ users in 5 different countries. The current models contain something in the order of 10.000.000 (10 million!) objects.

Any feedback is welcome.

96
General Board / 7.1 beta status
« on: January 29, 2008, 10:55:19 pm »
Hi,

I've just noticed the release of version 7.1 (beta). Wow, there are some really nice new features in there. Especially the formatting will make the crowd wild in this organisation.
Anyone know the average time between beta status and general available status?
We are on the brink of rolling out EA and I might consider postponing if the general version is coming very soon.

97
General Board / Object attributes unreachable
« on: January 17, 2008, 12:15:31 am »
I have noticed some weird behaviour in EA regarding object diagram.
Follow the following steps
- Create Class "Class1"
- add attribute to Class1 "ClassAtt"
- Create object diagram
- Create object on the object diagram "object1"
- Add attribute to object1 "ObjectAtt"
- set the classifier of object1 to Class1
- Try to edit ObjectAtt

There seems to be no way to edit the attribute of the object. I only get the dialog for the attributes of the class. I also haven't found a way to break the link between the object and the class.
Does anyone have a solution for this?

98
General Board / Version control puzzle
« on: August 24, 2007, 04:30:43 am »
Hi,

Another one on the version control.
I'm using EA 7.0.815 with an oracle repository (although for this problem I tested with a .eap file as well)
I'm testing the integration with PCVS (versions 8 (Merant) and 10 (Serena) through the scc interface.
First we tested Serena with two users userA and userB
We did following:
- A packageA is checked in in the VC
- UserA nor UserB can modify packageA
- UserA checks out a packageA from VC
- UserA can now modify packageA
- UserB cannot modify packageA

So far so good, works exactly as expected. Now I did the same test with PVCS8

- A packageA is checked in in the VC
- UserA nor UserB can modify packageA
- UserA checks out a packageA from VC
- UserA can now modify packageA
- UserB can ALSO modify packageA :o

No I'm really puzzled. It seems like the settings for PVCS8 and PVCS10 are exaclty the same. In EA I don't see a difference... I really don't know anymore.  ???
Anyone that can shed some light on it?

99
General Board / "String literal too long" importing XMI
« on: August 03, 2007, 12:26:17 am »
When I import a unisys xmi file directly into my Oracle repository I get several errors: "ORA-01704: string literal too long".
The importing screen is indicating that is is "Adding notes"
Importing that same xmi file in a local eap or MySQL repository works fine.
I'm using EA corporate v 7.0.815 and Oracle 10.2.0.2

100
General Board / Build 816 zip file misconfigured
« on: August 30, 2007, 08:55:28 pm »
Just downloaded the 816 build zip file, and unzipped it over my install directory. Instead of overwriting all the files in my EA install directory it created a sub-directory called EA70_816 and put all the files there.
I needed to copy them over my install directory to get the latest version.
I'll send an email to sparx support as well.

101
General Board / BUG: Strip GUID's corrupts database
« on: August 16, 2007, 09:58:48 pm »
I found a major bug in EA (7.0.815)
When importing an xmi file that was created using version control and selecting the option "Strip GUID's", the database gets corrupted someway. It crashes EA (windows application error: The instruction at "0x09bacd3d" referenced memory at "0x0000000c". The memory could not be "read".)
After restarting EA the model is no longer accessible, when trying to load the model EA crashes with the same message.
This bug is not related to the repository type. (I reproduced the error on Oracle, Mysql and .eap file)
It does seem to be related to the version control settings. We have Serena Dimensions (PVCS 10) setup as version control system through the scc interface. It is only when the version control is configured that it has this problem. When using a new project, without the version control setup, it imports fine.
I'll submit a bug report for this issue.

102
General Board / Tagged values content lost on XMI import
« on: August 03, 2007, 04:49:47 am »
Hi,

Another one on the unisys XMI import.
I'm converting my Rational Rose model to EA. In that RR model I had a lot of information in the so-called properties. (like preconditions, purpose etc).
I exported this RR model using the unisys xmi export, and I have imported that into my EA model. That works fine. (as long as you're not working on an Oracle rep; see other post)
The XMI import will nicely create tagged values and copy the content into the "value" field of the tagged value. Unfortunately it will also cut-off the text at 255 chr's without warning! I've had a look into the db-schema and the value field of t_objectproperties is only varchar(255). There is another field (note) that has TEXT (MysQL) datatype, but that is not used.
Another bug report?

103
General Board / "Value too large" when importing XMI
« on: August 05, 2007, 09:49:09 pm »
Hi,

Another one on the XMI import/export.
When exporting an object to XMI (EA xmi export) that has a tagged value, I get an error importing that same XMI file.
This only seems to be happening when you have special characters in the tagged value (tabs, CR-LF,???) and when the total of 255 charachters is used in the tagged value.
I tested this with a plain '123456...' and that was fine.
Tested with the text:
Quote
Er wordt een nieuw mfa record aangemaakt met invulling van de volgende velden
MFA-TYPEA037
MFA-USERID'DISTRI'
MFA-DATVANA037.Debug_message
MFA-DATTOTA037.Fin_message
MFA-DATRECsysteemdatum
MFA-TYPERECORDA037.Type de record
MFA-ANOMALIEA037.C


and when trying to import the xmi I got a database error: "ORA-12899: value too large for column "D00ARCH01"."T_OBJECTPROPERTIES"."VALUE" (actual: 262, maximum: 255)"
I'm very worried about this since the version control add-ins use this xmi import/export principle; and i'm afraid it is going to be a problem there too. (I'm testing version control integration in the next weeks)

I'll be submitting a bug report for this issue.

104
General Board / Best practices on branching?
« on: August 16, 2007, 10:19:10 pm »
Hi,

I was wondering what would be the best practice in handling branching.
We have EA 7.0.815, a central (oracle) repository and a version control system (Serena Dimensions) integrated using the scc interface.
Imagine following situation:
We have released our application with version 1.0
We are now working on towards version 2.0
We get a major bug report that requires a patch on version 1.0 (so 1.1).
Now what is the best way to branch (a part of) the model to create this 1.1?
I tried getting the xml file (v 1.0) from the version control system, and importing that into a new root model (selecting "strip GUID's") to create an alternative copy, but that resulted in corrupting my whole project. (see post http://www.sparxsystems.com.au/cgi-bin/yabb/YaBB.pl?board=general;action=display;num=1187333928)

105
General Board / Compare utility evaluation
« on: August 09, 2007, 11:14:32 pm »
Hi,

I'm evaluating EA (7.0.815 on Oracle repository) and I'm currently looking at the compare utility. I found some weird things, and I would like your thoughts.
- I started trying to compare a package with a generated xmi file. So logically I used the context menu option "export package to xmi file..." on a test package to create the xmi file. I did not change any of the default settings, so it created an xmi 2.1 file. I then tried to compare the created xmi file with my (unchanged) package. To my surprise the compare utility gave the [sarcasm] very usefull [/sarcasm] message: "An error has occured during the compare process"
- After some fiddling about I found the option to control my package and thus exporting it to an xmi file. (xmi 1.1). I did the same thing, compare the created xmi file with my unchanged package; and to my surprise I still got a lot of changes, and even some deletes ?!?

Do any of you have any experience with the compare utility? Because, like it is now, reporting changes without changing anything, this seems totally useless to me.


Pages: 1 ... 5 6 [7] 8 9 ... 14