Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.

Messages - SteveHarris

Pages: [1]
I've been thinking about this some more - and while it would be really nice to have some association stereotype that visually associated element components and generated the appropriate key/keyref declarations, there is a very simple way that this could be supported.

If you look at what the generated code looks like, it should be pretty obvious how to provide basic support.

<xs:complexType name="foo">
  <xs:attribute name="foo_ID" type="string"/>

<xs:element name="foo_impl" type="foo">
  <xs:key name="foo_primary_key">
     <xs:selector xpath="foo"/>
     <xs:field xpath="@foo_ID"/>

The complexType and element would be modelled as normal, but the element stereotype would have an extra  dropdown data entry field with options (null);unique;key;keyref.  Selecting a non-null option would reveal extra data entry fields for name, path, refer and selector as appropriate.  While it would be nice to have these extra fields restricted to declared keys/attributes it is certainly not necessary.


Suggestions and Requests / Re: Additional eléments for XML schema toolbox
« on: February 24, 2006, 03:55:04 am »
Can I add my voice to Key-KeyRef support

This would bring you a long way to full code generation in XML databases.


General Board / Re: slow RTF generation
« on: March 23, 2006, 05:44:12 am »
Thanks, Thomas

repairing = integrity

Sorry for using the wrong terminology: I used to do a lot of development against the Jet database engine

Didn't help anyway


General Board / Re: slow RTF generation
« on: March 23, 2006, 01:33:16 am »
Ok, I left the report running overnight and I have a 3653 page report with repetitive garbage after page 277.

Tried repairing and compacting the file to no benefit.

If I have time today I'll start narrowing down the bit that causes problems


General Board / Re: slow RTF generation
« on: March 22, 2006, 08:18:36 am »
Ok, It's nothing to do with My PC, I reverted to a previous version on my desktop and updated to the current version on my laptop: generation completed on the desktop and slowed to a near halt on my laptop.


General Board / Re: slow RTF generation
« on: March 22, 2006, 07:01:54 am »
Thanks, Jamie

The project is local already.

I also have some more information:  the problem seems to be with the changes I have made to the diagram today: yesterday's checkin to subversion (on my thinkpad with less than half the RAM of my desktop) takes less than 3 minutes.  At <320 elements and <320 connections, it's not a particularly big project either.

As the changes made today could be excluded from the report I killed the RTF generation, rebooted my desktop machine and raced my thinkpad Z60m (1Gb, 1.99GHz) against my Dell Precision 380 (2.9Ghz, 2.5Gb) both on build 788.  The Dell has ground to a halt as I speak - both PCs are smack bang up-to-date on windows update so it doesn't look like a windows snafu.

I'm going to commit the diagram to subversion next and delete some things.


General Board / slow RTF generation
« on: March 22, 2006, 06:15:44 am »
How long should it take to generate RTF documentation?  I'm currently running at over 2 hours on my main project: it's making progress but slowly.  

I have upgraded to 788 recently.  It wasn't this slow with previous builds, but recently I have linked diagram references to use cases with a realise association: could this be responsible.

I'll post more when my PC becomes available - I have a deadline to meet and I don't want to loose my current investment in cpu cycles.


General Board / Re: Order of attributes in generated XML schema
« on: February 17, 2006, 02:00:22 am »
Build 787 now shows the ordering buttons by default.  It seems they used to appear and dissapear according to the setting of an 'sort features alphabetically' option in tools/options/objects.

Thanks for fixing this - my schemas are now generating elements in the correct order.


General Board / Order of attributes in generated XML schema
« on: February 15, 2006, 05:55:18 am »

I have a problem with the order of attributes when generating more complex XML schemas.

I am implementing an ISO standard.  In the standard I have a pair of classes A & B where B is a specialisation of A.  Class A has several attributes that will transform into elements on schema generation, one of which we will call E and with a datatype of string.

In my implementation of B (B') I want to restrict the datatype of E to an enumeration of strings.  I draw a generalisation association between B and B' and set its stereotype to be XSDrestriction.  In accordance with the rules on complex content restrictions, I then re-declare each of the elements of B in B' varying the type of E to achieve the desired result.  So far so good.

The difficulty is that the order of the elements generated from B differs from those in B' so my XML parser reports that there is an incomplete functional mapping between particles.  I can re-order the particles manually in the schema but this kind of misses the point...

Does anyone know how to work round this?

Many thanks


Bugs and Issues / BUG - HTML report files - invalid XML
« on: February 01, 2008, 01:12:25 am »
I had a quick search on HTML report and couldn't find a previous report

In the HTML export, files are saved to /js/data that contain table of contents entries.  Trouble is they are saved with an XML extension despite being largely untroubled by angle brackets.

AFAIK the XML spec says that is an XML processor encounters a file declaring itself to be XML, it should attempt to validate it.  Of course if this directory is uploaded to an XML database - say eXist - it will be rejected as invalid XML and the HTML report will not function.

When using eXist the workaround is to change the file name for upload and re-name it through WebDav interface.  But the product should not use the .xml extension for files that are clearly not html.

Pages: [1]