Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Gary W.

Pages: 1 [2] 3
16
General Board / UI: Quickly find 'instance of' classifier
« on: November 02, 2007, 08:21:52 am »
Hi,

How can I quickly navigate to, in the Project Browser, the 'object classifier' for a certain element of which it is an instance?

I can use the Finder to find it, but I would have guessed a right-click on the instance would offer up a means to quickly get to it.  

Thanks,
gary

17
General Board / Question on Statechart notation
« on: June 07, 2007, 01:34:59 pm »
Hi,

I have a question about the notation being used in EA's Statecharts.  The online help shows bubbles with a horizontal line:


But using the tool only shows bubbles without any lines. See the example below:


Now, the funny thing is that I've seen the other bubble in other tools (e.g. see
http://www.guides.sk/UML/together/#statechart-diagrams).


Is this 'action' *within* a State valid UML?  If so, how can EA produce this?

TIA
gary

18
General Board / Use Case Conventions (NOT formatting)
« on: February 26, 2007, 03:27:37 pm »
Hi,

There's lots of good discussions on formatting the text, but I have a more practical question.  I've accepted that there are no bold/italics/bullets/tab controls in the Use Case elements in EA.

So, how do people enumerate the:
a. actors involved (not just the primary one)
b. level of the UC (e.g. Alistair's sea-level, sky-level, etc)

Do people just put the whole text into the NOTES (on the first tab)?  This would be 'free form text' versus distinct data elements.

Or do people still put preconditions and postconditions into the Constraints (3rd tab), putting nothing into the Scenarios (5th tab)?

As an aside, what do people use Files (last tab) for?  Does anyone actually link to Word Documents with formatted Use Case specifications?

TIA
Gary



19
General Board / State Machine Diagram elements
« on: March 19, 2007, 02:11:24 pm »
Hi,

From the 'up arrow', I can drag and release, creating elements such as:
- entry
- exit
- terminate
- deep history
- etc.

But I don't see these on the toolbox under "State".  I actually like the 'up arrow' shortcuts, but it's odd that these elements aren't in the toolbox

???

Gary

20
General Board / Ignoring Diagram Text/Notes in RTF Docs
« on: January 12, 2005, 02:52:37 pm »
Hi,

I often add notes or text labels on my class diagrams, but when I generate RTF, they come out in the textual reports (i.e. <anonymous> or 'Text').

Is there an option to exclude these?  In the dialog box for 'Rich Texgt Format Report', I see many many choices under 'For each Object Include' and 'Exclude details for...', but not one that seems to correspond to either 'text label' or 'notes'.

Am I just blind?  Thanks in advance,
Gary

21
General Board / XMI 1.2 (missing DocType)
« on: June 15, 2005, 10:08:36 am »
Hi,

Why does Export Package to XMI, using V1.2, generate XML that cannot be validated?  I don't get the doctype line, and the namespace seems to be incorrect:
xmlns:UML="org.omg.xmi.namespace.UML"

If I check neither 1.0 nor 1.2, I get XML with:
<!DOCTYPE XMI SYSTEM "UML_EA.dtd">
with a valid namespace reference:
xmlns:UML="omg.org/UML1.3"

I'm trying to use the generated XMI as input to an XSLT transform for me to convert the Class Model.

I'm assuming that V1.2 is the latest and greatest, and am trying for that... however, I can fall back to V1.1 if need be.

Just curious why the the V1.2 Export Package to XMI seems to 'not work'...

TIA,
Gary Wong

22
General Board / Getting rid of 'anonymous' text
« on: March 08, 2005, 05:21:02 pm »
Hi,

While creating class diagrams, I'll often write little textual notes to point out certain features or issues with the model.  

So I now have some empty textual notes.. which I cannot find on any diagram.  I know they're there however because the RTF reports shows them as:

<anonymous>
public Text: [/i][/u]

I don't see them in the HTML reports, but I'd sure like to know how to find these 'null' text notes in the Project Browser so I can delete them.

Can anyone help?

Thanks,
Gary

23
General Board / Multi-Select in Project View
« on: January 19, 2005, 03:54:26 pm »
Hi,

Multi-select and multi-delete are mentioned in:
http://www.sparxsystems.com.au/cgi-bin/yabb/YaBB.pl?board=general;action=display;num=1102069218;start=8#8

I'm currently on Version 4.50.740 , and find that I would really really like to be able to multi-select a group of attributes or columns, and then do apply a global change to ALL of them. (e.g. dataType, notNull, etc.)

Does anyone know if this functionality is in the more recent versions?

I don't usually upgrade unless there's a good reason to...


TIA,
Gary

24
General Board / Seed defined datatypes for new Database Product
« on: January 14, 2005, 04:14:04 pm »
Hi,

Our deployment database is going to be Oracle version 10g, Spatial Option.   On the menu, I go to Configuration -> Database Datatypes, where I see various pre-built products and their pre-defined datatypes.

I'd like to 'Add Product' on this dialog box (i.e. "Oracle10g SDO", but initially copy the currently defined datatypes for the built-in Oracle product (e.g. DATE, NUMBER, VARCHAR2, etc.).

Is there any automated way to do this?  I'd hate to do this 'under the covers' in Access, but that's an option too.

TIA,
gary

25
General Board / Temporily 'Pinning' Toolbox item
« on: August 26, 2004, 03:16:36 pm »
Hi,

I'm creating some Use Case diagrams, and I typically create all the Use Cases and Actors first, lay it all out, and then connect them up.

Instead of 'navigate mouse to Toolbox and click once on Use', draw the link, 're-navigate back', draw new link, repeat.... is there a way to 'Pin' the toolbox item?  Double-click and shift-click (the obvious choices) don't work.

Actually, this question applies to all the diagramming tools... does anyone know a solution?

Thanks,
Gary

26
General Board / EA 4.0: Tabbed Folders on bottom
« on: June 01, 2004, 12:53:34 pm »
Hi,

Finally upgrade to 4.0 version.  UI looks good, but the 'tabbed folders' is confusing me.  The 'Start Page' tab is left-most, and the next EA file I open is shown in the next tab , so there is a total of two tabs open.

If I open a third, the 2nd tab (and EA file) is replaced with the new EA file.

Can I open multiple EA files and have them all show up in one  EA MDI, as tabs on the bottom?  There are left and right navigation buttons on the same tab inteface, implying that I can scroll across all the tabs.

Am I out to lunch here?  

Thanks,
Gary ???

27
General Board / Object Diagram: Showing attribute values
« on: June 25, 2003, 04:36:56 pm »
Hi,

Is there a way to set (and display) attribute values in an Object Diagram?

TIA,
Gary Wong

28
General Board / Getting EA 3.6 to look in my Project Folder
« on: March 24, 2004, 04:22:04 pm »
Hi,

Whenever I do a 'File -> Open',  and then click on the Browse button (to the right of the filename), EA always navigates to my $TEMP directory.

I'd rather it look in my dedicated folder for EA projects.    I've gone into 'Tools -> Options' and set the Project Directory to my preferred folder, but EA still insists on going somewhere else.

What am I doing wrong?

BTW, version is 3.60.653, and platform is Windows 2000 SP 4.

Thanks,
Gary

29
General Board / Multi-Select and Property Update
« on: June 23, 2003, 02:37:10 pm »
Hi,

Is there a way to select multiple Classes and make an 'across the board' change to a property?

My situation is this.. I want to take my class model and Generate DDL.  So, I have to double-click on each class and change the stereotype and the the target database setting.

It'd be quicker if I could multi-select and do it all at once.

It this possible?

TIA
Gary Wong

30
General Board / Usability Questions on Class Diagrammer (EA3.50)
« on: June 11, 2003, 11:34:30 pm »
Hi,

Been using the tool for a while now and love it.  However, I've never been able to resolve the following:
1.
Generate RTF documentation (with 'include diagram in file') creates an .rtf that cannot be read on another machine.  It's like it's a link to the EA tool, instead of a simple bitmap.

So, I do it the long way by manually 'save to file' and Insert Picture (from file) in Word.  Can I make EA save the diagram as a simple graphic instead of a smart link to EA?

2.
When opening up the generated .rtf file in Word, I see large spaces on the right and bottom (I make my class diagrams fit on one page).  I have to manually make Word cut the rightmost 2" and the bottommost 3".  Can I change the setting in EA that leaves all this blank empty space?

3.
Packages seem to be ordered in the sequence I created them (when I generate the whole 'Logical View' to .RTF).  Can I re-order them in EA so that 'Generate to RTF' results in a user-ordered sequence?

TIA,
Gary Wong

Pages: 1 [2] 3