Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Gary W.

Pages: 1 ... 5 6 [7] 8 9 10
91
General Board / Seed defined datatypes for new Database Product
« on: January 14, 2005, 04:14:04 pm »
Hi,

Our deployment database is going to be Oracle version 10g, Spatial Option.   On the menu, I go to Configuration -> Database Datatypes, where I see various pre-built products and their pre-defined datatypes.

I'd like to 'Add Product' on this dialog box (i.e. "Oracle10g SDO", but initially copy the currently defined datatypes for the built-in Oracle product (e.g. DATE, NUMBER, VARCHAR2, etc.).

Is there any automated way to do this?  I'd hate to do this 'under the covers' in Access, but that's an option too.

TIA,
gary

92
General Board / Re: Setting default class element language
« on: November 30, 2004, 10:34:05 am »
Hi

1. From Menu bar, select Tools -> Options.
2. Choose 'Generation' from the navigator
3. Change the 'Default Language for Code Generation' to C#.

Hope this helps,
Gary

93
General Board / Re: XMI Export to Oracle tools
« on: November 30, 2004, 10:42:36 am »
We ran into a similar situation, and unfortunately Designer cannot import XMI and will never accept XMI (only bug fixes are going in from this point forward).  

There was a post earlier this year on 'going from Designer to EA':
http://www.sparxsystems.com.au/cgi-bin/yabb/YaBB.pl?board=general;action=display;num=1079499965;start=10#10

Maybe you can talk to that fellow to talk about doing the 'reverse'.  

Incidentally, I *was* about to write a  parser from EA output to Designer API, but decided against it, as I have to convert from Object-Oriented Analysis Class Model to Relational ER model anyways.  I just did the ER from scratch and did periodic updates to the Designer model at milestones in the project plan.


Gary

P.S.  
I don't understand why you mention Developer as this won't get you anywhere.  Forms/Reports cannot use the model information anyways.

94
General Board / Re: appearance of connectors
« on: September 06, 2004, 02:33:34 pm »
Markus,

On my EA (version 4.1), I can
- open the class diagram
- right-click the connector
- select 'Appearance...'

This gives me a 'Connector Appearance' dialog box where I can change the colour and line width.

HTH,
Gary

95
General Board / Re: Temporily 'Pinning' Toolbox item
« on: September 03, 2004, 01:29:48 pm »
So 'Repeat Last Connector' is available via short-cut key F3... what about 'Repeat Last Element'?

On the menu bar (-> Diagram), I now see that F3 is documented as a short-cut key for 'Repeat Last Connector', but the analagous space next to 'Repeat Last Element' is blank.

I'm just asking if there is some undocumented key available here...
TIA,
Gary

96
General Board / Re: Temporily 'Pinning' Toolbox item
« on: September 03, 2004, 10:46:24 am »
F3 works great for my case...

Thanks for the answer !       ;D
Gary

97
General Board / Temporily 'Pinning' Toolbox item
« on: August 26, 2004, 03:16:36 pm »
Hi,

I'm creating some Use Case diagrams, and I typically create all the Use Cases and Actors first, lay it all out, and then connect them up.

Instead of 'navigate mouse to Toolbox and click once on Use', draw the link, 're-navigate back', draw new link, repeat.... is there a way to 'Pin' the toolbox item?  Double-click and shift-click (the obvious choices) don't work.

Actually, this question applies to all the diagramming tools... does anyone know a solution?

Thanks,
Gary

98
General Board / EA 4.0: Tabbed Folders on bottom
« on: June 01, 2004, 12:53:34 pm »
Hi,

Finally upgrade to 4.0 version.  UI looks good, but the 'tabbed folders' is confusing me.  The 'Start Page' tab is left-most, and the next EA file I open is shown in the next tab , so there is a total of two tabs open.

If I open a third, the 2nd tab (and EA file) is replaced with the new EA file.

Can I open multiple EA files and have them all show up in one  EA MDI, as tabs on the bottom?  There are left and right navigation buttons on the same tab inteface, implying that I can scroll across all the tabs.

Am I out to lunch here?  

Thanks,
Gary ???

99
General Board / Re: Searching Diagrams
« on: May 03, 2004, 02:22:21 pm »
Hi,

"Control-U" gives you the same function from the Project View.

Gary

100
General Board / Object Diagram: Showing attribute values
« on: June 25, 2003, 04:36:56 pm »
Hi,

Is there a way to set (and display) attribute values in an Object Diagram?

TIA,
Gary Wong

101
General Board / Re: Pasting Large Diagrams into Word
« on: April 07, 2004, 11:15:57 am »
Hi,

I've had lots of experience pasting EA images into Word, and I find that it often helps to crop the white-space from the sides.  In Word, you can do this by:
1.  Right-clicking the picture
2.  Choose 'Format Picture'
3.  Navigate to the ''Picture" tab

The first four fields alllow you to crop from the top, bottom, left or right.

Alternatively, a software tool like SnagIt lets you selectively copy a portion of what is on the screen.

HTH
Gary

102
General Board / Re: EA and Oracle Designer
« on: March 24, 2004, 04:24:48 pm »
Hi,

If you're looking for Beta testers, than I can offer my help as well.  We have a 6i Repository, and also have access to a few 9i Repositories where I can try it out.

Cheers,
Gary
gwong@pacificcoast.net

103
General Board / Getting EA 3.6 to look in my Project Folder
« on: March 24, 2004, 04:22:04 pm »
Hi,

Whenever I do a 'File -> Open',  and then click on the Browse button (to the right of the filename), EA always navigates to my $TEMP directory.

I'd rather it look in my dedicated folder for EA projects.    I've gone into 'Tools -> Options' and set the Project Directory to my preferred folder, but EA still insists on going somewhere else.

What am I doing wrong?

BTW, version is 3.60.653, and platform is Windows 2000 SP 4.

Thanks,
Gary

104
General Board / Multi-Select and Property Update
« on: June 23, 2003, 02:37:10 pm »
Hi,

Is there a way to select multiple Classes and make an 'across the board' change to a property?

My situation is this.. I want to take my class model and Generate DDL.  So, I have to double-click on each class and change the stereotype and the the target database setting.

It'd be quicker if I could multi-select and do it all at once.

It this possible?

TIA
Gary Wong

105
General Board / Usability Questions on Class Diagrammer (EA3.50)
« on: June 11, 2003, 11:34:30 pm »
Hi,

Been using the tool for a while now and love it.  However, I've never been able to resolve the following:
1.
Generate RTF documentation (with 'include diagram in file') creates an .rtf that cannot be read on another machine.  It's like it's a link to the EA tool, instead of a simple bitmap.

So, I do it the long way by manually 'save to file' and Insert Picture (from file) in Word.  Can I make EA save the diagram as a simple graphic instead of a smart link to EA?

2.
When opening up the generated .rtf file in Word, I see large spaces on the right and bottom (I make my class diagrams fit on one page).  I have to manually make Word cut the rightmost 2" and the bottommost 3".  Can I change the setting in EA that leaves all this blank empty space?

3.
Packages seem to be ordered in the sequence I created them (when I generate the whole 'Logical View' to .RTF).  Can I re-order them in EA so that 'Generate to RTF' results in a user-ordered sequence?

TIA,
Gary Wong

Pages: 1 ... 5 6 [7] 8 9 10