Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Thelonius

Pages: 1 2 [3]
31
General Board / Error message
« on: October 13, 2008, 09:43:44 am »
Getting this error message when creating a MySQL database instance using MySQL_MyISAM_BaseModel.sql and MySQL ODBC 5.1 driver on Windows Vista SP1.

Is this anything to be concerned about?

ERROR: *** t_umlpattern - record no: 12. The XML for UML Pattern 'Abstract Factory' is too long and Abstract Factoryhas been set to an empty string.

32
General Board / Printing - General Problems
« on: September 04, 2008, 02:43:12 pm »

Today I've spent way too much time trying to get the very important Relationship Matrix to print on an A3 sheet of paper.

However, EA insists that this be printed in an A4 format, regardless of what I attempt to do. And I've tried it all, believe me. Best I can do is an A4 version printed on multiple  A3 sheets.

I'm using EA as an Enterprise Architecture consultant. And printing is very important in this use context. Don't care so much about reverse-engineering or code generation.  I'm using EA as a very powerful 'sketch' tool. I'm having some good success with it, too. But in this use pattern, we tend to use A3 and larger print sizes. I'm sure others do as well.

Just seems that the way EA interacts with printers generally is very poorly  implemented and thought out. As in: "We got this other really hard stuff to work - but we haven't really gotten around to worrying about getting diagrams and reports to print out looking half-way decent."

Anyone know if this is something we can expect Sparx to improve any time soon? It's very disappointing. I would not be able to encourage my professional colleagues to use EA with the poor print support it currently implements.

If you really want an eye-opener - try using the "Scale to x pages by x pages" option in the application. It distorts the print image in a very .... surprising .... manner.

Am I wrong? Too picky? Do others share my perception?


33
General Board / Telelogic Modeller?
« on: July 30, 2008, 01:09:22 pm »
Hi

This question may be stretching the purpose of this thread / forum but I'm going to see what happens. Please don't flame me.

The free version of Telelogic Modeller - should I even bother downloading it just to see if it's of any value at all?

Have any of you had a look?

From time to time I speak to customers who are considering a modelling tool - some have mentioned this one.

My view is that 'free' probably means 'don't bother'.

Regards

34
General Board / Project Browser 'Expand All' Function?
« on: July 12, 2008, 01:44:12 pm »
Is there a simple command that will expand all levels of a model in the Project Browser?

Searched the fora to see if anyone else had asked this question before, but couldn't find a similar prior posting.

Thanks
Jon

35
General Board / multi-segment connecting lines
« on: April 12, 2005, 09:20:29 pm »
I've discovered that normal straight lines can automatically become multi-segment lines on a diagram.

Subsequent moves of objects then require fiddling to get the line segments straight.

How can I force connecting lines back to non-segmented, straight lines?

I checked FAQs, help file and EA configuration options but didn't see anything obvious...

36
Bugs and Issues / Infinite Loop 2014: The Movie
« on: October 23, 2014, 10:22:25 am »
https://vimeo.com/109758051

Usually, "Cancel" means "I don't want to do anything" as in "Cancel"?

Not "Go ahead. Force me to enter something when I don't want to."

Hello.

37
Bugs and Issues / Wierd ArchiMate Connector!
« on: November 19, 2010, 06:00:32 pm »
Using the ArchiMate profile - using the "Used By" connector to connect an Infrastructure Service to a Product. All quite legal and everything. When I change the line style to "lateral horizontal" - the connector that pops up is a combination of a dashed line and a solid line. Not quite kosher, ArchiMate-wise. Is there an explanation for this other than "it's a bug"? :-?

38
Bugs and Issues / Make Model Default - Busted?
« on: August 17, 2010, 02:11:40 pm »
This fiddly business of 'Make Model Default' does not work in my v8 build 860 on Win 7. Is anyone aware if it has stopped working for some reason?

EA keeps opening the same diagram and nothing I do seems to get it to stop opening the diagram it wants, and open a different diagram that I want. I have followed the instructions above.

Just thinking about this - would there not be a way better way to define which diagram will open automatically by default when I open a .eap model?

As in 'right click' + select 'make model default' from context menu -- or even 'open this diagram automatically when opening this model'

Perhaps?

39
Bugs and Issues / Really Easy Bug To Fix
« on: December 19, 2009, 11:22:33 am »
Just getting started using the scripting capability of EA.
In the Scripter window, there is no little popup windoid thingy that tells me - when I hover my cursor over it - what it's going to do for me if I click on it. I'm guessing it means "refresh"? It doesn't seem to mean "step through code one line at a time" ... ?

All the little dooverlackys left and right of this one DO have the wee pop-up helpful hint gizmos, so I'm assuming this is something of an oversight?

I know it's not the most important thing in the world ... just trying to help.
 :) ;) :D ;D

40
Bugs and Issues / Can't switch from EA to other apps on Vista
« on: December 18, 2009, 01:36:35 pm »
Running Firefox and Vista. I have EA and other apps running. I'm working in EA. Then I click another application's icon on the taskbar. But EA doesn't release focus to allow the other app to come to the foreground. I have to click on the "Show Desktop" icon on the taskbar to get EA to release focus.

Does anyone else have this problem?

If I have EA and another app open in "Show Windows Side by Side" mode - this works okay - I can click between EA and other apps no problem. But when the EA screen is maximized - no dice.

 :-/ :-? :(

41
Bugs and Issues / Matrix HTML not WYSIWYG?
« on: December 10, 2009, 04:19:49 pm »
Has anybody else noticed that when you HTML generate a diagram that has a Matrix where you have located elements (say Requirements) in the cells - the elements are not correctly aligned in the HTML diagram?

42
Bugs and Issues / "Synchronised" Tagged Values ?
« on: October 09, 2009, 09:24:29 am »
Hi guys - noted the following misspelling - should be "Synchronise" not "Synchronised" Tagged Values ... true - not a big bug - but I'm just trying to do my bit here ... :-)




43
Bugs and Issues / Bug with connector label text wrapping
« on: January 06, 2009, 02:01:37 pm »
Text on connector labels reformats itself when the EAP file has been saved and re-opened. Typically if I set a text label to be a single line, when the model is re-opened, the text has wrapped the last one or two words.

Has anyone else observed this -- or am I the only one?

I have reported this bug using the registered users bug reporting facility on the EA website. But other than an automated email there is no 'real' acknowledgement when using that facility...

Visual representation of the problem is here:

http://www.members.iinet.net.au/~jmcleod/EA-Connector-Label-Bug/index.html

44
Automation Interface, Add-Ins and Tools / Archimate Add-In Bad Drawing
« on: August 16, 2010, 11:57:35 am »
This probably isn't the most elegant way to render text graphically within the Archimate "Product" icon.



I'm sure someone will tell me to fill out a form and submit a bug report and fling that into the echo-less black hole of bug reports ...
 :-X



45
Automation Interface, Add-Ins and Tools / Anyone using Archimate add-in?
« on: August 19, 2009, 01:52:38 pm »
Sparx provide it. I've had a look at it, and at the Archimate specification. It has not been updated, and looks a bit daggy. I'm thinking that anything I could do using Archimate, I could do using basic UML.

Having a hard time seeing the value, really. In theory, the value assertion seemed interesting, but in practice - now that I've had a closer look - I'm not getting an epiphany from it.

What am I missing?

Pages: 1 2 [3]