Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - andykennelly

Pages: [1] 2 3 4
1
General Board / Re: Can't re-connect keystore manager to keystore
« on: January 30, 2014, 12:55:56 am »
Thanks, Stefan. My users can now retrieve floating licenses. Something strange is happening, though.
As soon as the user selects a floating license they get a message 'Not enough storage space on disk'. This doesn't effect them - they can carry on and use Sparx (and Help\Register and Manage License key(s)' shows that they do, indeed, have a floating license).
However, as administrator I see the Keystore Manager app simply close down and, when I re-open it, the floating license isn't shown as allocated (although the user is still using one within their instance of Sparx).
This may be related to storage space on our network, of course - is it anything you're aware of, though,  as a Sparx/keystore issue?

2
General Board / Can't re-connect keystore manager to keystore
« on: January 30, 2014, 12:00:37 am »
My Keystore Manager has for a long time been linked to a drive thus enabling me to monitor our use of floating licenses. Recently, the sskeys.data file on that drive has been emptied (and possibly the file corrupted) - I've no idea how this happened, but it certainly wasn't through use of Keystore Manager.
I'm trying to re-connect to that drive using 'File/Link to' in Keystore Manager so that I can re-populate the sskeys.dat. However, even though I can browse to, and select, sskeys.dat, when I OK in the 'Shared keystore selection' box I get "Could not link to keystore - error:unspecified error" (I'm assuming this is because the file is corrupt).

(I think I've seen a post on this before, but can't find anything when I search.The trouble shooting guide on the Sparx site doesn't give any direction.

Any ideas?

3
General Board / How do I delete a project shortcut?
« on: December 04, 2014, 08:56:36 pm »
I know how to create a Project Shortcut such that a specified diagram is opened when a project is launched.
However, I can't work out how to delete a shortcut.
I can't find anything in Sparx Help for 'Project shortcuts', nor anything on this forum.

Any ideas??

4
General Board / CSV import/export - strange behaviour
« on: October 21, 2014, 05:28:41 am »
I have a component with a single provided interface called IF01.
I run an extract to a CSV file to which I subsequently want to add new rows and then import back, so I carry out the following:-
I copy/paste a new row from the IF01 row.
I change the name of IF01 in the new row to IF02.
I delete the GUID on the (new) IF02 row.
I then change the Type from ProvidedInterface to Interface on both rows - (there's no good reason why I do this - I do it purely to re-create a scenario I find puzzling).
I run an import from the CSV.

Now, in the project there is a new interface (not provided interface), which is what I'd expect.
However, the original IF01 row remains a provided interface - I'm not sure  if I expect that or not. However, the really confusing thing (and the purpose of this post) is that the name of that original provided interface been updated from IF01 to IF02!!! Not what I was expecting!!
In other words, there are 2 interfaces (one provided, one "regular") in the project both called IF02.

I should, of course, have not changed the type of the original row - so the problem is one of my own making. But I'm surprised how Sparx processed the file. And, anyway, might I not legitimately be trying to update the element type via CSV import???

Anybody been here before? Is this a feature of CSV export/import when used in this way?

Sparx Help doesn't seem to cover this specific (unusual) scenario.

5
General Board / "Please re-install EA" err msg on Sparx launch
« on: July 08, 2014, 08:04:35 pm »
"One of my colleagues has installed Sparx in the correct way (or, as far as he is aware, anyway) but when he launches it he gets this message:-

"Error opening or accessing key file! Cannot continue.  Please re-install Enterprise Architect!".
At first I thought he needed to define the path to the floating licence repository - but he can't even open Sparx at all. The error message appears as soon as he clicks the sparx launch icon.

I tried searching for "re-install" across the forum (possibly incorrectly) but couldn't find anything.

It might well, of course, be something related to his user profile etc., rather than something related to the sparx app.

Has anybody experienced this?

6
General Board / Showing stereotypes for UI control elements
« on: March 04, 2014, 02:38:10 am »
I've created a button UI control and stereotyped it (as <<tab>>). The stereotype value can be seen in the project browser, but not when I drag/drop the element onto a (user interface) diagram. Stereotypes of other element types can be seen on the same diagram diagram (i.e. I have checked 'Show element stereotypes' on the diagram's Elements tab as per Help guidance), but not for UI controls.

Any ideas?

7
General Board / Generate DDL - 'table: Database not defined' error
« on: February 19, 2014, 09:13:24 am »
I've used Model Transformation to create a platform specific model from a platform independent model and I know want to generate DDL to run in a SQL environment to create tables etc. To do this I'm right-clicking on the package with my platform specific model elements (diagram and tables) and selecting/generate DDL. I fill out the presented 'Generate Package DDL' box correctly (or so I believe), click Generate and see a 'table:Database not defined' message.
I can't find any guidance on Sparx Help nor the Forum. Trawling the web I see I might need to specify a default database in Tools\Options\Source Code Engineering\Code editors..... which I do (SQL 2008), but I still get the same message when attempting to generate DDL.

Any clues, Sparxites?

8
General Board / Re: Ordering attributes by stereotype under IF ele
« on: January 07, 2014, 12:39:54 am »
Thanks, Geert. That's helpful. I assume from what you say that there's no way to impose stereotype ordering within the project browser as well??

9
General Board / Ordering attributes by stereotype under IF element
« on: January 06, 2014, 08:51:48 pm »
I'm creating attributes under an interface element. The attributes will be one of 2 stereotypes, <<input>> or <<output>>. For purposes of clarity I want all the <<input>> attributes to appear together immediately under the interface, and for all the <<output>> attributes to appear under the <<input>> attributes.

However, Sparx applies alphabetical ordering based on the attribute name.

Can I overide this with ordering based on alphabetical ordering of stereotypes (which will put all my input's first)??

(I've searched on various combination of ordering/attributes' in sparx help and on the forum, but found nothing).

Any ideas?????

10
General Board / Re: How to re-install removed 'Manage user' permis
« on: October 12, 2013, 06:25:22 pm »
Thanks, Q. I'd searched for references to enable and disable security but hadn't noticed this one if it had turned up from my searches. Cheers.

11
General Board / How to re-install removed 'Manage user' permission
« on: October 12, 2013, 06:24:53 am »
HELP!!! Whilst exploring various aspects of the security function, I've managed to inadvertently get myself into the following situation.

Whilst logged in as an admin user I removed the 'Security - manage users' permission from both the User Permissions and the Group Permissions (relating to the group to which admin user belongs). Don't ask why I did this - as I say, I was exploring!

I'm now in the position where I don't, as admin user, have the 'Manage users' option in the Project/Security drop-down. And I can't re-install that permission becuause I've removed my own ability to do so!!

Can I get mysefl out of this? This is just a "play" project, so there's no real harm done. But what if I was daft enough to do this on my company's Live Model?

12
General Board / Comm path link not shown in traceability window
« on: September 10, 2013, 08:25:14 pm »
Sparx won't let me create certain links between component elements owing to non-compliance with UML, e.g. a manifest link. It does, though, let me create a communication path link (part of the Deployment diagram toolbox) between 2 components. I'm not sure if this is UML compliant or not, but it lets me do it.
However, the traceability window doesn't show the communication path link between the 2 components. All other component-to-component links are shown in the traceability window. This means that, if I'm using the traceability window for impact analysis, I'm going to miss some stuff. Am I doing something wrong?

13
General Board / Listing artifacts on a node element
« on: September 04, 2013, 08:02:15 pm »
UML 2.0 allows 3 ways to model the deployment of an artifact onto a node (or so I understand it!):-
1. Place the artifact element onto the node element (OK if there are just a few artifacts).
2. Linking the artifact element to the node element using the <<deploy>> relationship (again, (OK if there are just a few artifacts).
3. Putting the artifact name as an item in a list on the node element (ideal where there are many artifacts deployed on the node).

I can see how to model the first 2 ways in Sparx, but I can't see how to create a list on a node element. Does Sparx support this?

14
General Board / HTML gen for a "speciifc path" through the model
« on: September 02, 2013, 10:20:21 pm »
My model has the following folder structure and content:-

- 'Function’ folder
   ---‘Screen Journeys’ folder
        ---‘Screen Journey 1’ folder
             This folder contains a single screen element which, through
             the single diagram, holds a relationship between that screen  
             to Back End1 (which resides in ‘Back Ends’ folder below). The
             Back End1 element on this diagram has a composite diagram
             link.
   ---‘Back End’ folder
        ---‘Back End1’ folder
             This folder contains a single element, Back End1, which is
             dropped onto a diagram.

This structure allows me to drill down (using the composite diagram link) from the screen to its back end.
If I want to create a HTML report that allows this drill down I need to generate everything in the ‘Function’ folder.

So far, so good.

My challenge comes when I have the real-world scenario of multiple screen journeys each of which may call one or more of multiple Back End elements. If I want to create a HTML report only for Screen Journey 98 then I can put the cursor on the ‘Screen Journey 98’ folder and generate HTML from there. However, the result of that, of course, is that I won’t have any Back End elements generated and I can’t drill down.
The only way I can see to do it is to generate HTML for the whole model from the ‘Function’ folder (some, or most, of which I might not want to generate if I’m publishing to an audience to whom I only want to show the Screen Journey 98 context).
Is there any way of generating HTML only for the “path” specific to Screen Journey 98????

15
General Board / Composite diagram link on artifact elements
« on: August 02, 2013, 09:01:56 pm »
Is there a way of creating a composite diagram link on an artifact element (in the same way you can by right-cliccking on a component and selecting 'New diagram / Select composite diagram')? The only way I can find to jump from an element on diag A to diag B is by palcing a hyperlink on diag A ..... which isn't as neat as composite diagram linking.

Pages: [1] 2 3 4