Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Graham_Moir

Pages: 1 ... 5 6 [7]
91
Bugs and Issues / Instability of rtf document generation in 9
« on: May 24, 2011, 01:10:20 am »
I'm finding the RTF generator in 9 much less stable than in 8.  It used to crash fairly regularly in 8,  but nowhere near as much as it does in 9.  Using a model in 9 that was originally put together with EA 8, generating the same document multiple times without restarting EA predictably seems to follow one of these 2 sequences.

1.  First run, generally OK
2.  Second or third run comes up with "EA encountered an improper argument"  followed by crash to desktop

or

1.  First run only picks up Master document template and none of the model documents resulting in output with a cover page only.  
2.  Once this happens the generator never finds the full virtual document definition unless you generate a different document and come back to the original one.

On top of that there's
a. The issue skiwi has raised with items such as diagram legends and hyperlinks being picked up and erroneously, irritatingly, added to the output document.  
b.  Numbering problems when iterating through child packages.  I notice from the release notes that this functionality has been touched to "fix" it but in my case it used to work in EA 8, but now I get level 3 which should be say 3.1.1 jumping back to 3.x  and level 4 jumping forward to level 5 as  3.1.0.0.1   This is without changing any templates in 9.

Anyone else experiencing similar problems ?  :(

92
Bugs and Issues / Free format RTF tables
« on: September 20, 2010, 11:07:45 pm »
Hello.  I consider myself a reasonably experienced user with the RTF editor, however I've hit a very irritating problem, but I'm not 100% sure it's a bug or whether I've missed something.  

What I'm trying to do is include a free format table in a linked document,  i.e. by free format I mean a table that does not pull information from the model.  It has a 4 rows and 6 columns,  and describes the project governance in terms of meetings that are expected to happen and be minuted etc..

The thing is, visually on the screen I can changed the width of the columns and get the table looking very nice.  But if I save the document, exit and then go back into it,  all the settings have been lost.  The table is still there,  but with what appear to be random column widths and an overall size that extends far beyond the right margin of the document such that you can't see a couple of the columns at all.  

I have been unable to fix this, except in MS Word after report generation (the rtf output generated matches the rogue display in the rtf editor).

Has anyone else seen this issue?    If so, does anyone has a fix/workaround.  Or should this be submitted as a bug ?

thanks

93
Bugs and Issues / Elements missing from Project Browser
« on: May 12, 2010, 08:28:58 pm »
This is a repeat of a message in "EA v8 - doc generation" as I think it merits its own thread.

I have found something that is pretty sinister.   I have document elements on diagrams that work correctly in the sense that the are displayed on the diagram, you can click on them to modify properties and linked docs can be edited,  however ...

They do not exist any more in the project browser !!!  

"Find in browser" just doesn't find them.   Attempting a project integrity check doesn't find any issues.  All of this is v8.856 and very worrying.  

In short they seem to have disappeared from the package that owned them - in each case in fact each document had its own package and was the only element in the package.   These packages still exist but are now empty.

How do I get an element that exists on a diagram (or multiple diagrams) and can be found in Model Search (but not in Find in Project Browser) back into the project browser - back into the package where they should be ?


94
Bugs and Issues / Project Constants Export   v7.5
« on: March 04, 2010, 12:57:20 am »
The help for exporting the Project Constants (found on the RTF document generation dialogue) says

"Export a selected set of fields to an external XML file."

However, when I try this function selecting specific constants makes
no difference,  ALL the constants seem to be exported all the time.
Also,  the XML output is not nicely formatted as it is for other exports, making editing output file more difficult than it should be.

Not sure if this is different/fixed in 8.

G.

95
Bugs and Issues / Raquest and EA 7.5
« on: February 17, 2009, 11:28:20 pm »
Any news on compatibility of Raquest with the soon to be released version of EA ?
thanks

96
Uml Process / Forward Engineer a Class Model - Beginner question
« on: May 24, 2012, 11:00:49 pm »
Just need a bit of direction please.  

Let's assume you have a well structured platform independent class model, which by its nature contains data and behavioural definitions and relationships.   This can be forward engineered for the intended target database to create a platform specific data model, say for Ms-SQLServer using the EA DDL transformation.  However this process loses the behavioural aspect of the class model as well as not supporting inheritance complexities.

So, what, for you, has been the most successful way to forward engineer the behaviours from the class model for the persistent data to get the other side of the story ?  Is there another transformation you would recommend, or does it have to be done manually (e.g. where stored procedures are providing the behaviour) including putting in relationships for traceability in order to get towards the complete physical model picture ?

Thanks

Pages: 1 ... 5 6 [7]