Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Jens Nötzold

Pages: [1]
1
General Board / Re: Basic Approval Workflow
« on: August 25, 2017, 10:17:34 pm »
Have a look at

http://www.procead.de

Let me know, if it works 4u
Let me know, what needs to be added to make it work for you.

Cheers,
Jens

2
Update:

Sparx support says:
"This has been confirmed by hte devlopers and will be fixed in a future
build of EA.

As a workaround you could create a Custom SQL Fragment template for this
purpose."

3
Hi,

I get an error

DAO.Database [3464] Data type mismatch in criteria expression

when setting up an element filter on RTF template document options to render
- only elements having tests of testclass one of 1,2,3,4,5
- and only element test of  testclass one of 1,2,3,4,5
(otherway : want to exclude elements without tests or testclass = 6)

Setting up a filter criteria on t_objecttests.testclass is not working,
- neither from Document Options->Element Filters
- nor from Document Options->Other Filters
- nor from Find in Project->Query Builder

None of the operators EqualTo, Not Equals, One Of can be used, no chance for the user to input the correct type to avoid the problem!

The error persists in EA 12.0.1212, 12.1.1229, 13.0.1306
Its a very frustrating one as it prevents us from running test reports!

Any help on this is welcome to get around this.

Cheers,
Jens Nötzold

4
Thanxs Geert. Report posted.

5
Hi,

today I upgraded from EA 12.1.1215 to latest 12.1.1229

Selecting a template from within the document template editor results in an empty page, the editor headline and tab bears a garbled/truncated template name.

Starting template editing from the resources view or the document generation dialog still works.

Cheers
Jens Nötzold

6
Suggestions and Requests / Re: Introduce relative source path
« on: February 12, 2009, 08:39:10 pm »
Quote
I want to be able to check out the code, the model, update the code or the model, synchronize and check both back in without fiddling with local paths or replacing directory paths in exported XMI or resort to voodo.

Moreover, the "local paths feature" (well its more a workaround than a feature) doesn't help for model elements having links to local files. So I would suggest that every link to the local filesystem may be stored relative to the current model.
(Currently EA is not applicable in a distributed development environment. A model with links to the outside must be diverged per user an per machine).

Has somebody already raised a feature request?

7
General Board / Re: diagram appearance on different screens
« on: September 13, 2007, 12:06:12 am »
I posted the issue to the Sparx support and they themselve forwarded this as bug report to the developer team.

Thanks so far,
Jens

8
General Board / diagram appearance on different screens
« on: September 05, 2007, 12:27:09 am »
All,

my team is working on different computer having screen resolutions that vary from 85 to 150 ppi.
If a diagram in the model is created on a 85 ppi screen, the diagramm elements will overlap on 150 ppi.

Obviously EA uses fonts with real sizes (x pts) for text elements, but stores all other primitives in pixel ordinates.

Is there a way to make diagrams look the same on different computers?

Regards,
Jens

9
Bugs and Issues / Re: Wrong style used for notes comments
« on: March 01, 2012, 10:07:53 pm »
I have problems with styles in comments from EA 8 til 9.2 (922).
Today I analyzed the frustrating problem as it leads to unusable RTF-output. This is what I found out:

Whenever a note contains HTML-characters like ">" or "&gt" the RTF-output for the following paragraphs is corrupt.
 
The same is with lists in notes. They are internally converted to HTML-lists an cause corruption, too.

Seems, that RTF generator is not able to convert html.
Would be good to add this to your bug report, as it'll help developers to fix it.

cheers,

10
Thank you for your quick response.

Following your hints I found that <Options> are not written when saving toolbox as UML profile. If inserted manually everything works as expected.

Half way done. Seems, that the redefinition clause is ignored in toolbox profile diagram notes.

cheers

11
Help!

overriding the default UML::Activity toolbox with an MDG Techn. does not work as stated in the documentation. (RedefinedToolbox=UML::Activity ....)

The toolbox shows up on a custom diagram type, if a diagram profile is incorporated.

What am I missing!??

Pages: [1]