Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - skiwi

Pages: 1 ... 111 112 [113] 114 115 ... 118
1681
Bugs and Issues / Data model - export column attributes
« on: December 23, 2009, 12:14:35 pm »
A question for which I am seeking assistance.

How would I go about extracting and exporting to a spreadsheet (or CSV) a list of all tables, their columns, and attribute details (eg name, type, length, PK, FK, not null, unique, ...) from a package (and all sub packages)?



tia

simon


1682
Bugs and Issues / Re: Bugzilla and EA
« on: December 23, 2009, 09:53:04 am »
dem's dangerous thoughts thinks I as I thinks to meself, demmed dangerous, earthlings might appreciate better service and visibility of issues, and be able to subscribe to updates  :exclamation
dey might report fewer bugs that have already been reported, but dey might report more new bugs seeings 'ow dey perceive bug fixing to be more effective.  [smiley=vrolijk_1.gif]

1683
Bugs and Issues / Data model - show length attribute
« on: December 23, 2009, 12:18:22 pm »
In the attributes dialogue box columns "PK, Name, Type, etc" are shown in the columns table.

How can I also display the length in that table.
I tried RMB but there is no context menu for this table in tha dialogue box.



tia

Simon

1684
Bugs and Issues / How to show diagram that is under an element
« on: December 10, 2009, 09:48:36 am »
I have a package, with elements, and to get the order right, a diagram under an element. See this diagram - section 1.2.3 services.

The diagram does not show in the RTF document.
Here are the document template settings I have. Note that the diagram name shows, but not the image,
any suggestions?

1685
Bugs and Issues / Re: Non elements appearing in generated documents
« on: November 30, 2009, 06:39:24 am »
I have now sent in a bug report with test case for this problem.

1686
Bugs and Issues / Non elements appearing in generated documents
« on: November 17, 2009, 08:39:18 am »
In 849 and 850 we are seeing "non elements" (such as boundaries) appearing in generated RTF documents in some circumstances as child elements.

Has anyone else observed this behaviour?

It appears different from previous versions (ie documents that used to look OK are now different), and looks buggy.



1687
Bugs and Issues / Diagram with elements from locked packages
« on: November 24, 2009, 01:09:42 pm »
I'm creating and updating diagrams which contain elements from other packages.
Using SQL Server we have the User Lock on all objects in the model.

Most formatting works on these elements when they not locked by me, but there are two things that I can't do when the elements are I don't have the elements locked.
These things are display/formatting only, so they should not, I think, require the original element to be unlocked:
  • change Z Order of element
  • Use Rectangle Notation

Thoughts anyone?


1688
Bugs and Issues / Re: Data modelling: removing primary key
« on: November 24, 2009, 01:02:22 pm »
Thanks.
I'll try to create a test case to report.

1689
Bugs and Issues / Data modelling: removing primary key
« on: November 23, 2009, 02:46:27 pm »
I added a primary key to a table that already had one primary key.

I then realised I didn't want to do that, and tried to remove it
(both by unselecting the PK check box, and by deleting the column).

In both cases I got the following error message.


Sorry this attribute is part of a foreigh key relationship.

The table had an association (connector) with another table, and EA has deduced the relationship.

Without deleting the connector how do I remove (this part of) the primary key.

I'm sure there is an easy answer, but it does not appear obvious.

Tia

1690
Bugs and Issues / Re: Hide connector in other diagrams (don't use no
« on: November 20, 2009, 01:26:34 pm »
thanks for putting me right on that

1691
Bugs and Issues / Re: Hide connector in other diagrams (don't use no
« on: November 10, 2009, 05:53:41 am »
Quote
From the main menu, Diagram > Visible Relations (Ctrl+Shift+I)

Thanks,
I note that this dialogue box does not have a button to make visible (unsuppress?!) all the relations.

Also curious why one menu talks about relations, the other connectors.

Perhaps the same dialogue could be used for both ...

1692
Bugs and Issues / Re: Hide connector in other diagrams (don't use no
« on: November 09, 2009, 11:13:22 am »
Quote
All good points]
Would it be possible then please, to clarify the effect of the "Suppress all button".

I note that the dialogue has no help button.

Note that I wasn't suggesting that the context menu item be changed (although I take and agree with Paulo's point).
My quibble is with the first line (ie instructions) in the pane, viz

"Clear check box to hide connector in diagram:"

There just is no need to make it obtuse.

PS: Just thinking about showing (unhiding) connectors in a diagram, is there some way for an entire diagram to show a list of all connectors that have been hidden?

1693
Bugs and Issues / Hide connector in other diagrams (don't use no dou
« on: November 09, 2009, 07:47:02 am »
I don't know about you, but first thing on a Monday morning (yes we are 12 hours ahead of many of you) this kind of think hurts my brain



"Clear check box to hide connector in diagram"

Perhaps it would be better phrased

[highlight]"Set check box to show connector in other diagram"[/highlight]


[size=9]You know - 'accentuate the positive' - 'don't use no double negatives'[/size]

PS trivial I know, but votes welcome

PPS at the bottom is a button showing "Suppress All". Its not quite clear to me if this is simply a way of untoggling all the check boxes (it doesn't check them) or it has a deeper meaning of 'don't show this connector on any current or future diagram'

1694
Bugs and Issues / Re: "Undo" icon is the same of "Save"
« on: November 17, 2009, 08:14:27 am »
This issue has resurfaced for us in 850, except that while restoring to the default layout fixes it the undo icon quickly reverts to the save icon again.

1695
Bugs and Issues / Re: Package Linked document -> RTF report
« on: November 16, 2009, 12:54:26 pm »
Thanks  [smiley=dankk2.gif]

Pages: 1 ... 111 112 [113] 114 115 ... 118