Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - Ericga

Pages: 1 2 [3]
31
Bugs and Issues / Re: Losing diagrams' content on import
« on: July 15, 2010, 10:22:30 pm »
Geert,

If by model transfer you mean importing the XMI in the new eap file I get the same error:


---------------------------
EA
---------------------------
DAO.Field [3163]

The field is too small to accept the amount of data you attempted to add.  Try inserting or pasting less data.
---------------------------
OK  
---------------------------

32
Bugs and Issues / Re: Losing diagrams' content on import
« on: July 15, 2010, 09:47:20 pm »

> OK, are you confirming the scenario in my last post?  Round-trip into the same repository?  

yes

>How are you reseting the diagram for each test?

Just dragging a couple of related classes to it and saving

>What settings are you using on the export and import?

I just experimented again and got different results. I am exporting with these settings:

XMI 1.1
Enable full EA Roundtrip
Format XMI output
Use DTD
Write Log

And I import in a single transaction with Write Log. I do NOT check the Strip GUID option.

I am obviously doing something differently this time because the diagrams are just refresh instead of wiped out. However I get a ton of error messages like this while importing:

DAO.Field [3163]

The field is too small to accept the amount of data you attempted to add.  Try inserting or pasting less data.

ps: I have seen such errors in the past and instead of writing the errors to the log EA pops an error dialog for each one. An large imports the only solution is to kill the EA process unless you want to click OK a few thousand times.

So I am getting much better results now and the initial problem seem resolved (although I have no idea why) but I am now getting these error messages on import. I would like to ignore them but clicking OK repeatedly  for 5 minutes is irritating and I have no idea what field data I am losing yet)

Thanks for all the help

Eric


33
Bugs and Issues / Re: Losing diagrams' content on import
« on: July 15, 2010, 11:29:26 am »

> What is your configuration and environment?

Latest build of the professional version on Windows 7

34
Bugs and Issues / Re: Losing diagrams' content on import
« on: July 15, 2010, 01:38:55 am »
The diagrams' content is lost on import. Even in this simplest scenario the content is lost: export A to diesk, reimport A from disk as if I was just refreshing my package.

35
Bugs and Issues / Losing diagrams' content on import
« on: July 14, 2010, 11:44:02 pm »

If I export a package with the "full EA roundtrip" option, I still lose all the content of all diagrams that used some of the package's classes. The diagrams still exists but they are now empty.

I thought the purpose of the roundtrip option was to resynch entities based on their GUID included in the XMI so references was not lost?

tested with latest build (859)

thanks for any help understanding this

Eric

36
Bugs and Issues / Re: DAO Recordset [3022]
« on: December 09, 2008, 01:02:55 am »
I have the same issue with build 834 (DAO Recordset [3022])
Error: Unknown Client or Supplier)

I will try again to reproduce the issue with a smaller XMI file. This might take a couple of days.

37
Bugs and Issues / Re: DAO Recordset [3022]
« on: December 08, 2008, 09:29:20 am »


Sorry, but I don't see the workaround in that post. The error is similar but he had a project integrity issue; I don't. I get this error while importing a XMI file.

Eric

38
Bugs and Issues / Re: DAO Recordset [3022]
« on: December 07, 2008, 10:08:47 am »
I did try to upgrade to the latest build before posting to the forum but my user/password did not work anymore. I emailed sales@sparxsystems.com but did not receive any reply yet (email Friday around noon so I suppose I will get a reply Monday).

Thanks

eric

ps: I did search DAO on the forum before posting but didn't find anything

39
Bugs and Issues / Re: DAO Recordset [3022]
« on: December 07, 2008, 12:29:24 am »
N0 830

40
Bugs and Issues / DAO Recordset [3022]
« on: December 06, 2008, 04:28:01 am »
I am getting many errors like this while trying to import some XMI. The problem is that it seems impossible to pinpoint the origin. The log is useless as there is no information on  what tag or element is being processed (and the XMI is close to 40Mb).

I have found other obscure messages in the logs (like "Unknown Client or Supplier") but have the same issue of the log not being descriptive enough. Is there a way to may it more verbose to understand what is really going on?


DAO Recordset [3022]
The changes you requested to the table were not successful because
they would create duplicate values in the index primary key, or
relationship. Change the data in the field or fields that contain
duplicate data, remove the index, or redefine the index to permit
duplicate entries and try again.


Thanks

Eric

Pages: 1 2 [3]