Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - SaschaR

Pages: [1]
1
General Board / Template Package -> Author
« on: November 14, 2008, 01:19:39 am »
Hi,
we are using a templte Package for defining the default appearance of an Activity. Is there a way to auto set the author, when an Activity is used in another Diagram.
In the moment, all Activities have the same author (the one who declared the Activity in the Template Package), but thats not really nice.
Any suggestions?

2
General Board / Default open last Diagrams
« on: January 23, 2008, 12:29:22 am »
Hi,
is there an option to save the perspective I used when I closed the EA. For example, I closed the EA and Diagram1 and Diagram2 were opened. What I want is that, when I restart EA, exactly these two Diagrams are opened as default.
Greetings
SaschaR

3
General Board / XML export
« on: June 20, 2007, 10:17:23 pm »
Hi,
I am trying to export my requirements to a specific xml file. It should look like this :
<requirementsPackage>
   <requirement>
      <requirementTitle>#addElementName#</requirementTitle>
      <requirementText>#addNotesHere#</requirementText>
   </requirement>
</requirementPackage>

First, I thought I could edit an HTML Template, but this dont really work.
Is there any other workaround to do something like this?

4
General Board / Relationship between Requirements
« on: April 24, 2007, 04:01:29 am »
Hi,
I just have entered the requirements for a product in EA. There are some Requirements that are aggregated (Aggregation Link) from other requirements. And there are requirements that have an association link.
When I open the relationship View, none of this relations exists. And when I import the requirements in RaQuest, they are also gone?
Do I have to declare every relation between requirements in the relationship view?

5
General Board / Reference Element in linked document
« on: March 21, 2007, 02:43:47 am »
Hi,
I have a problem with the linked documents.
We want to use them for various supposes, but I cant see the possibility to reference the element, to which the document is linked to (e.g. the Element name as headline), like I can do with the rtf generator.
Am i right, that the linked document is only a plain text editor?

6
General Board / Order of tagged values in profile
« on: March 09, 2007, 12:41:08 am »
Hi,
when I add tagged values to a stereotype, they are always ordered alphabtically. I already switched off "Tools->Option->Object->Sort Feature Alphabetically" but this doesnt help, they are still in a alphabetical order.
Can someone help me?

7
General Board / Change stereotype icon
« on: March 07, 2007, 05:48:58 am »
Hi,
can someone tell me if its possible to change the icon of a stereotype, which is displayed in the UML-Toolbox after importing the profile?

8
General Board / Stereotypes and predefined Attributes and OCL
« on: March 07, 2007, 02:56:12 am »
Hi,
I just created a profile, that contains a stereotype and extends the metaclass "activity". I created a shape script, that change the appearance.
Now I want to add attributes to the stereotype (like an string id) , that should be predefined in every stereotype, that I use from the toolbar in any diagram. But when I define an attribute at the stereotype in the profile view, it isnt transformed to the diagram, where I use the stereotype. I know I can make tagged values, but thats not really what I want, because I want to be sure, that everyone who use this stereotype also use the attribute. What can I do about it?

Another issue is : Does OCL works with EA? I tried to force, that a stereotype has alwasy a link to e.g. a use-case diagram and tried this with the ocl expression inv: self.UMLDiagram->size()>1 but it didnt work?

9
Bugs and Issues / ORA-12899 Error when creating a package / diagram
« on: November 26, 2009, 12:57:57 am »
Hi,
I am using the EA Version 7.5.844 and getting the error
Code: [Select]
OraOLEDB[...]
ORA-12899: Value exceeded ... EA_GUID (actual: 41, max: 40)
whenever I create a new package / diagram / object.
I am using an oracle 11 database for storing the model.
Anyone ever had a message like this?
Any suggestions?

10
Bugs and Issues / Update of a Note Element is not reckognized
« on: October 13, 2008, 06:31:44 pm »
Hi,
I have a little problem concerning the Note Element:
When I enter a text in a Note with Copy & Paste this is not reckognized and so I cant save the changes. Is this a known bug / issue?

11
Automation Interface, Add-Ins and Tools / Java API to generate RTF
« on: March 22, 2007, 06:11:07 am »
Hi,
I just tried the Java API for EA, but I have a little problem :
Does anyone has experience with calling the rtf generate function of EA from the Java API?
The only functions I discovered where things to do with the repository, but we are looking for a way to generate rtf (with a created rtf template) from java (for batch producing of documentation without open EA and make it manually).
I think this wont work with the Java API, any other opninion?

Pages: [1]