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Perspectives

Enterprise Architect provides a wide range of built-in
modeling languages and technologies, and sometimes it can
be difficult to identify the right tool or combination of tools
to meet your exact modeling requirement or scenario. The
Perspectives facility helps you to quickly and effectively
filter the overall modeling capability to a Perspective Set of
technologies that are relevant to a domain, such as
Requirements modeling, and further refine the tools for
more specific tasks within that domain, such as Business
Rule modeling, in a Perspective.
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Perspectives:

Are selections of Technologies - some specific to one of·
the many modeling languages - and their model and
diagram Patterns

Are tailored to domain-specific modeling scenarios; when·
you work in a specific domain, you can apply a
Perspective to expose appropriate facilities and hide all
others

Remove the significant distraction of having to identify·
and assess multiple technologies before proceeding with
your work

(c) Sparx Systems 2018 Page  5 of 34



User Guide - Perspectives 21 December, 2018

Help you to select and apply an environment of particular·
modeling languages or Technologies, enabling you to
work effectively and efficiently on the task at hand

Help you to switch easily and quickly between tools when·
your modeling focus changes; you simply select another
Perspective from the list of Perspective Sets (which
identify the domain they support) and Enterprise Architect
then hides the features of the previous Technologies and
applies the new environment

Initially you can select from the thirteen built-in Perspective
Sets and the more than 60 Perspectives they provide. As
your experience in modeling with Enterprise Architect
develops and your work becomes more specific, you can
create your own custom Perspectives. This helps you work
within a Technology that you might have recently imported
and activated, or apply a combination of Technologies that
are not associated in the built-in sets.

Overview

You select and switch to the required Perspective through
the 'Perspective' option at the top right of the screen, or
through the 'Start > View > Perspective' ribbon option, or
through the Perspective Portal in the Portals window.

Selecting a built-in Perspective automatically brings up the
Model Wizard, which provides a rich set of new model
patterns and guidance notes, filtered to narrow down the
available patterns, technologies, diagram types and other
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modeling constructs to the precise set required, with similar
actions on the Toolbox and dialogs. This helps you to
quickly build accurate, focused models with minimal 'noise'
and maximum fidelity.

Applying a Perspective mainly takes effect through the
Model Wizard, 'New Diagram' dialog, Diagram Toolbox
and 'Stereotypes' dialog, for creating model structures. The
Model Wizard and the 'New Diagram' dialog also allow for
swapping Perspectives instantly, making it easy to find and
change to the exact modeling tools required.

As a huge boost to models encompassing several disciplines
and modeling domains, selecting a Perspective provides its
Technology as an available development tool, whilst all
existing model structures that make use of the hidden
Technologies still render and work as normal. If you have a
model that contains, say, a BPMN View and a SysML
View, you might apply a Perspective to support the creation
of BPMN structures and see only BPMN templates and
Toolbox items in your BPMN development. But if you open
a SysML diagram during this work, you will still see the
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SysML Toolbox pages, Properties pages and options that
enable you to properly examine that diagram.

To further enhance your modeling experience, you can also
use the Perspective Sets window to filter the Perspectives,
hiding complete Perspective sets or individual Perspectives.
This enables you to reduce the list of Perspectives offered
for selection to just those you are likely to use.

For specific instructions on using Perspectives, see the
Using Perspectives Help topic.

System Perspectives

Enterprise Architect provides a rich set of more than 60
Perspectives built directly into the application. These have
been crafted to align with the multitude of roles that
modelers perform; these are grouped into Sets that make
finding the right Perspective quick and easy, and include:

Business sets for Strategy, BPMN, Business Analysis and·

more, helping the business user focus on their current task

SysML, MBSE, Software, Simulation and others, for the·

Systems Engineer and Software Engineer

Archimate, TOGAF, Zachman Framework and·

GRA-UML, version-specific sets that provide the most
common tools for the needs of Enterprise Architects

SPEM, Process Guidance and MDG Technology Builder·

for Project Managers

Each set contains a number of relevant and useful
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Perspectives. This diagram shows an example of three
Perspective Sets, each of which contains a number of
Perspectives.

For a more comprehensive description of the built-in
Perspectives, see the Types of Perspective Help topic.

Custom Perspectives

In addition to the built-in Perspectives, you can create any
number of your own Perspectives on the 'My Perspectives'
tab. While the built-in, or system, Perspectives typically
contain a single language or technology - for example the
BPMN (Business Process Model and Notation) Perspective
allows you to focus on just BPMN - custom Perspectives
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allow you to open a number of technologies at the same
time. For example, if you regularly create prototypes you
might want to create a 'Prototyping' Perspective that groups
the technologies and modeling languages you use in that
work.

Custom Perspectives do not automatically open the Model
Wizard; as they combine facilities, the system cannot
determine which sets of Patterns to automatically present.

These custom Perspectives can be created, modified and
deleted as the roles you perform change over time. For
information on creating custom Perspectives, see the
Customizing Perspectives Help topic.
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Using Perspectives

You can access both built-in and custom Perspectives from
a number of different points. This makes it easy to start your
work in the appropriate environment with the required
Perspective from any point, and to quickly and smoothly
switch to a different Perspective if the need arises.

Conversely, if you prefer to have a wider range of tools and
languages immediately available to you, you can select the
appropriate 'All <perspective group name>' option in the
Model Wizard or  list to filter for all Perspectives
for a domain.

Access

Currently, selecting a built-in Perspective will take you to
the Model Wizard. Some access paths first take you to the
Perspectives Portal, and when you select a Perspective from
there the Model Wizard opens and you choose the
appropriate Patterns to use (if required).

Other paths take you directly to the Model Wizard, where
you first select the Perspective and then the Patterns to use
(if required).

Selecting a custom Perspective does not open the Model
Wizard, because custom Perspectives generally expose
combinations of Technologies and facilities, and the system
cannot determine which Technology to open the Wizard at.
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Ribbons Start > View > Perspective > Select a
Perspective (takes you to the Perspective
Portal) > <perspective group> >
<perspective>
Start > View > Perspective > Open
Model Wizard > Model Patterns >
Perspective
Show > Portals > Perspective >
<perspective group> > <perspective>
Design > Package > Insert > Insert Using
Model Wizard > Model Patterns >
Perspective

Context
Menu

Click on Package > Add a Model using
Wizard > Model Patterns > Perspective

Other Start Page | Open a Portal | Perspective
Portal > <perspective group> >
<perspective>
(Top right corner of screen) >  >
<perspective group> > <perspective>
('My Perspective' options just apply the
custom Perspective)

Navigator Toolbar :  :  >
<perspective group> > <perspective>
In the 'New Diagram' dialog, click on the
Select From button and select the
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required Perspective

Use a Perspective

Having selected a Perspective, and depending on what
Perspective that is, you would expect to see impacts on the
Model Wizard, 'New Diagram' dialog, Diagram Toolbox
and 'Stereotypes' dialog, each offering fewer options more
specific to the Technology or operations you are working in.
For Perspectives related to Code Engineering, the code
editors and code generators might also have a narrower
focus.

As you develop models and/or engineer code, you will see
the structures you require and not have to pick them out
from many other structures of no relevance to the work you
are doing.

Filter Perspectives Available

You are unlikely to use all the Perspectives available in
Enterprise Architect, so if you prefer you can exclude
Perspectives - or even whole Perspective Sets - that you do
not need from display in the Model Wizard and 
selection lists. You do this using the 'Perspective Sets'
dialog:
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    Start > View > Perspective > Customize List of Available
Perspectives

The 'Perspective Sets' dialog displays, showing the 'Global
Perspectives' tab. If you want to exclude a complete
Perspective Set, deselect the checkbox against that category
in the 'Perspective Sets' panel.

Otherwise, if you want to just exclude individual
Perspectives, click on the parent Perspective Set name and
deselect the checkbox against the Perspective name in the
'Perspectives' panel. In this illustration, the CMMN and
Erikson-Penker Model Perspectives have been excluded
from display.

Note that if you exclude a Perspective Set, the checkboxes
against the individual member Perspectives remain selected.
However, the Perspectives do not show in the selection lists
in, say, the Model Wizard.

If you decide to show any excluded Perspectives again,
return to the dialog and select the appropriate checkboxes.
Alternatively, show all Perspectives as explained in Revert
to All Perspectives.
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Revert to All Perspectives

If you have filtered your list of Perspectives, or been
working within a specialized Perspective such as
Requirements or a customized Perspective, and you want to
return to a non-specific environment, either:

Select the 'Start > View > Perspective > Clear Current·

Perspective' ribbon option, or

Click on the Reset button on the 'Perspective Sets' dialog,·

or

Select  > Manage > Show All Perspectives·

Notes

A Perspective hides all Technologies that are not·

specifically associated with it; if you use custom
Technologies in your work, add them to a custom
Perspective with any built-in Technologies you want to
use, so that all your specialized tools are available
together

An individual Technology might not present all facilities·

you need (for example, ICONIX does not have a diagram
profile, so a Perspective that just exposes ICONIX does
not allow you to create diagrams); select or create a
custom Perspective that includes a Technology that adds
the missing facilities (in this case, the UML Technology)
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In order to function when included in and presented by the·

Perspective, a Technology must remain enabled in the
'Manage Technologies' dialog
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Customizing Perspectives

Whilst Enterprise Architect provides a huge range of
Perspectives to select from, you might need to create others
more specifically tailored to your area of work, or to expose
Technologies that you have recently imported.

The methods for tailoring Perspectives to match your work
environment are described here.

Before starting, review the Technologies available to you in
Enterprise Architect and identify and enable those you want
to apply in a Perspective, either individually or in
combination. This is particularly important for any custom
Technologies you have, as selecting a Perspective makes
available only those Technologies it specifically contains
and hides all others - including your custom Technologies.

Access

These access options display the 'Perspective Sets' dialog,
through which you can create customized Perspectives.
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Ribbon Start > View > Perspective > Customize
List of Available Perspectives > My
Perspectives
Design > Diagram > Insert > 'Hamburger'
icon > Manage > Customize > My
Perspectives

Other (Top right corner of screen) >  >
Manage > Customize > My Perspectives

Create Custom Perspective
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Ste
p

Action

1 Click on the New button. The 'Select MDG
Technologies' dialog displays.

2 In the 'Set Name' field, type a name for the custom
Perspective. Then select the 'Add' checkbox against
each MDG Technology to make visible.
You can click on the All button and then deselect the
checkbox against each Technology to hide, or click
on the None button to clear all selected checkboxes
and then re-select those against Technologies you
want to keep visible.
If you want to group your selections by Technology,
click on the 'Group Categories by Technology'
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checkbox.

3 When you have added the necessary Technologies to
the Perspective, click on the OK button. The
Perspective name displays in the 'Create Perspective'
panel, and the Technologies in the Perspective are
listed in the 'MDG Technologies' panel in
alphabetical order.
Notice that all buttons at the bottom of the window
are now enabled.

4 If you prefer to:
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List the Technologies in the Perspective in a·

different sequence, click on each Technology
name in turn and use the Up Hand button or Down
Hand button to move the Technology name to the
correct position in the sequence
Remove a Technology from the Perspective, click·

on the Technology name and click on the X button
to redisplay the 'Select MDG Technologies' dialog,
listing just the Technologies that are in the
Perspective; clear the 'Add' checkbox against the
Technology to be removed, and click on the OK
button
Add another Technology to the Perspective, click·

on the + button to redisplay the 'Select MDG
Technologies' dialog, listing the Technologies that
are not already in the set; select the 'Add'
checkbox against the required Technology, and
click on the OK button

5 Click on the Save button and, if you have finished
setting up or changing a Perspective, click on the
Close button.

Delete a Custom Perspective

If you no longer want to use a custom Perspective, you can
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delete it from the list of those available.

On the 'My Perspectives' tab of the 'Perspective Sets' dialog,
click on the custom Perspective name and then on the Delete
button.

In response to the confirmation prompt, click on the Yes
button.
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Types of Perspective

There is a wide selection of built-in Perspectives provided
within Enterprise Architect, each containing a suite of
Patterns. This topic is a reference, describing each
Perspective Set and Perspective. You can also create your
own custom Perspectives, which are included as the last
item in the list of Perspective Sets.

To select and apply any of these Perspectives, see the Using
Perspectives Help topic.

Perspectives

Category Perspectives

UML The UML category provides the
Perspectives for normal UML modeling,
including:

All UML Modeling - all modeling tools·

and objects provided by the other
Perspectives in this group
Structural - the modeling tools and·

objects for structural UML models,
such as:
    - Package diagrams
    - Class diagrams
    - Object diagrams
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    - Composite Structure diagrams
    - Component diagrams
    - Deployment diagrams
Behavioral - the modeling tools and·

objects for behavioral UML models,
such as:
    - Use Case diagrams
    - Sequence diagrams
    - Timing diagrams
    - Interaction Overview diagrams
    - StateMachine diagrams
    - Communication diagrams
    - Activity diagrams

Strategy The Strategy category provides
Perspectives for:

Mind Maps - the basic Mind Map·

diagram
Strategy modeling, such as:·

    - Organizational Charts
    - Value Chains
    - Strategy Maps
    - Balanced Scorecards
    - One-level and Two-level
Flowcharts
    - Decision Analyses with Trees and
with Decision Tables
    - SWOT Analyses
Risk Analysis - the Risk Taxonomy·
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Threat Community diagram

Analysis The Analysis category provides
Perspectives for:

White Boarding - diagram structures in·

Whiteboard and/or Hand-drawn mode
Simple Analysis, based on a Two·

Activity Process
Case Management Model & Notation·

(CMMN) analysis, with a:
    - Claims Management example
    - Basic 5-Task Plan
    - Three Choice Tasks Pattern
    - Two Phase Case Plan
Erikson Penker modeling, the basic·

business process
Web Modeling, based on a simple Java·

Server Page (JSP) model

Requirements The Requirements category provides
Perspectives for:

Creating a range of Requirement·

Hierarchy diagrams, and a
Requirement Specification View
Working with Decision Modeling·

Notation (DMN) to:
    - Create a simple Decision diagram
with a Decision Table

(c) Sparx Systems 2018 Page 25 of 34



User Guide - Perspectives 21 December, 2018

    - Set up a DMN Business
Knowledge Model
    - Model a DMN Decision
Setting up a Business Rule model·

Setting up one-level and two-level Data·

Flow models

UX Design The UX Design category provides a
number of Perspectives for modeling user
interfaces on various devices, including:

Wireframing for various phone and·

tablet devices
IFML Interaction flows on desktop·

applications, information entry,
interaction on wireframe devices, and
information searches
A basic Enterprise Architect user·

interface model for a window with lists
and combo boxes
An alternative simple user interface·

Win 32 User Interface modeling·

Business
Modeling

The Business Modeling category
provides these Perspectives:

BPMN - Patterns for:·

    - BPMN 2.0 modeling
    - BPEL 2.0 Starter model
BPSim - Patterns for BPMN 2.0 and·
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BPEL 2.0 modeling, plus:
    - Patterns for Business Process
Simulation (BPSim) constructs and
    - Patterns for a number of BPSim
Case Studies
Business Model Patterns for Business·

Use Case models and Use Case
Realization
Business Interaction model Patterns·

BABOK - a wide range of Patterns·

supporting models for:
    - Strategies
    - Collaboration activities
    - Analyses
    - Business Processes
    - Project Management activities
    - Standard business documents
BIZBOK - Patterns for modeling·

BIZBOK activities

Software
Engineering

The Software Engineering category
provides Perspectives for software
development, including:

Code Engineering, modeling programs·

in a number of programming languages
Service Oriented SOMF 2.1, for·

several Conceptual Association types
SoaML, for modeling aspects of basic·
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service provision
XSLT Feature demonstrations, such as·

XSLT transforms and debugging
ICONIX modeling·

GOF Patterns for Creational, Structural·

and Behavioral models

Systems
Engineering

The Systems Engineering category
provides Perspectives to support systems
Engineering projects under:

SysML1.5, with a wide range of·

Patterns for generating:
    - Project structures
    - Requirements diagrams
    - Use Case diagrams
    - Activity diagrams
    - Block Definition diagrams
    - Internal Block diagrams
    - Parametric diagrams
    - State Machine diagrams
    - Libraries
    - Model elements
    - Modelica Case Studies
UAF, with Patterns for:·

    - Strategic Views (St-xx)
    - Operational Views (Op-xx)
    - Services View (Sv-xx)
    - Personnel Views (Pr-xx)
    - Resources Views (Rs-xx)
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    - Security Views (Sc-xx)
    - Projects Views (Pj-xx)
    - Standards Views (Sd-xx)
    - Actual Resources Views (Ar-xx)
    - Dictionary View (Dc)
    - Requirements View (Rq)
    - Summary and Overview (SmOv)
    - Information View (If)
    - Parameters Views (Pm-xx)
    - The SysML 1.5 sets (as listed,
except for Modelica Case Studies)
UPDM with Patterns for:·

    - UPDM Frameworks (DoDAF and
MODAF)
    - DoDAF All Viewpoints (AV-n)
    - DoDAF Capability Viewpoints
(CV-n)
    - DoDAF Data and Information
Viewpoints (DIV-n)
    - DoDAF Operational Viewpoints
(OV-n)
    - DoDAF Project Viewpoints (PV-n)
    - DoDAF Services Viewpoints
(SvcV-n)
    - DoDAF Standard Viewpoints
(StdV-n)
    - DoDAF Systems Viewpoints
(SV-n)
    - MODAF All Views (AV-n)
Viewpoints
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    - MODAF Acquisition (AcV-n)
Viewpoints
    - MODAF Operational (OV-n)
Viewpoints
    - MODAF Service Oriented Views
(SOV-n) Viewpoints
    - MODAF Strategic Views (StV-n)
Viewpoints
    - MODAF System Viewpoints
(SV-n)
    - MODAF Technical Standards
Views (TV-n) Viewpoints
Executable State Machines, with·

various Patterns including a set to
demonstrate case studies

Database
Engineering

The 'Database Engineering' category
provides sets of Perspectives for
modeling a range of DBMS repositories,
including:

Starter Model and Model Structure·

Patterns for each of the main DBMSs
supported by Enterprise Architect
Patterns for simple Entity Relationship·

models
Patterns for simple ArcGIS projects·

and workspaces
A simple Enterprise Architect Data·

Modeling diagram Pattern
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Enterprise
Architecture

The Enterprise Architecture category
provides a number of Perspectives for
Enterprise Architecture frameworks,
including:

ArchiMate, supplying Patterns for:·

    - Basic viewpoints such as
Organization, Application Usage and
Service Realization
    - Motivation Viewpoints such as for
Stakeholders, Principles and
Requirements Realization
    - Strategy Viewpoints
    - Implementation and Migration
Viewpoints
TOGAF, with Patterns for:·

    - A Starter Model
    - The Architecture Development
Method
    - The Enterprise Continuum
    - The Technical Reference Model
    - Catalogs
Zachmann Framework·

GRA-UML annotations library and·

starter model

Information
Exchange

The Information Exchange category
supports a number of built-in
technologies, providing Perspectives and
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basic model Patterns for:
Ontology Definition (ODM)·

Geographic GML·

Archetype Modeling Language·

NIEM 3.0, 3.1, 3.2 and 4.0 Reference·

Models and NIEM 3 and 4 starter
models
SIMF·

Universal Business Language·

UPCC 3.0·

UMM 2.0 Profile·

Construction The Construction category provides these
Perspectives:

Project Roadmaps, for a range of·

management work areas
Kanban workflows·

Document Publishing for types of·

Project document
Dashboards and Charts for various·

scenarios
Reviews and Discussions to define the·

structure and function of these team
collaboration activities
Test Management to define how tests·

are planned and managed
Change Management to define a model·
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for managing issues and changes
Resource Management to define how·

resources are identified and managed
Legends to define how diagram·

legends are set up and used

Management The Management category provides
Perspectives to support:

SPEM·

Process Guidance - working up process·

templates
The Enterprise Architect Script Library·

The MDG Technology Builder·

My
Perspectives

The 'My Perspectives' category holds the
Perspectives that you have created for
yourself, using the 'Start > View >
Perspective > Customize List of
Available Perspectives' option. For
further details, see the Customizing
Perspectives Help topic.
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