
Installing Enterprise Architect inside WINE, Version 1.0.2 Page  1 of 24

Installing Enterprise Architect inside WINE

Enterprise Architect 9.0 Build 905

Wine Version: 1.2.23

Version 1.0.2



Installing Enterprise Architect inside WINE, Version 1.0.2 Page  2 of 24

Table of Contents
1    Introduction 3
2    Installing Enterprise Architect with Standard Wine 4
3    Installing Enterprise Architect with Support for ODBC Connections 5
4    Installing Enterprise Architect with Support for Scripting and ODBC
Connections 7
5    Installing Enterprise Architect with Crossover 9
6    Upgrading Enterprise Architect in Crossover 10
7    Installing Enterprise Architect Add-ins 11

7.1    .NET Add-ins 12
8    Installing MDG Eclipse Link. 13

8.1    Connecting to a project 14
9    Setting up subversion with Enterprise Architect 16
10    Debugging and Sampling 18
11    Appendix 21

11.1    Appendix A: Links 21
11.2    Appendix B: ODBC Versions 21
11.3    Appendix C: Known Issues and Workarounds 21
11.4    Appendix D: Installing Wine dependencies for Linux 64 bit editions 24



Installing Enterprise Architect inside WINE, Version 1.0.2 Page  3 of 24

Introduction1
This document describes how to install Enterprise Architect within Wine.  We assume some
knowledge of downloading installers and running scripts.

Requirements

The install process documented in this paper makes frequent use of the winetricks script. The
winetricks script is maintained by the Wine community and is able to download, install and
configure Wine packages on the users behalf.

The winetricks script is available from http://kegel.com/wine/winetricks

Additionally it is assumed that Wine and the associated Wine utility cabextract are already
installed on the host computer.

If you are using a 64 bit linux distribution, please read Appendix D: Installing Wine dependencies
for Linux 64 bit editions before continuing.

http://kegel.com/wine/winetricks
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Installing Enterprise Architect with Standard Wine2
This section explains how to set up Enterprise Architect under the Wine environment without
support for scripting or Open Database Connectivity (ODBC) repositories.

Step 1: Download Necessary Components

To install Enterprise Architect the following components are required:

Enterprise Architect (available from http://www.sparxsystems.com)·

The winetricks script (available from http://kegel.com/wine/winetricks)·

Step 2: Install Windows Components

At the command line, run the following

 $ winetricks allfonts # install windows fonts
 $ winetricks msxml4      # install MSXML4 support.

Step 3: Install Enterprise Architect

At the command line, run the following

 $ wine easetupfull.exe

Step 4: Adding Unicode support (optional)
At the command line, run the following

 $ winetricks jet40

Download the Jet 4.0 model from Jet 4.0 Model, and copy the contents of the file to the install directory
of EA.  Run EA and enabled the JET4 option from menu "Tools -> Options -> General Tab".

http://www.sparxsystems.com/
http://kegel.com/wine/winetricks
http://www.sparxsystems.com/bin/EABase_JET4.zip
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Installing Enterprise Architect with Support for ODBC3
Connections

This section explains how to set up Enterprise Architect under the Wine environment with
additional Open Database Connectivity (ODBC) repository support.

Step 1: Download Necessary Components

To install Enterprise Architect with ODBC support, the following components are required:

Enterprise Architect (available from http://www.sparxsystems.com)·

An ODBC driver (see Appendix A: ODBC Versions  for a list of compatible ODBC drivers)·

The winetricks script (available from http://kegel.com/wine/winetricks)·

Step 2: Install Windows Components

At the command line, run the following

 $ winetricks allfonts # install windows fonts
 $ winetricks msxml4 # install MSXML4 support.
 $ winetricks mdac28             # install data access components

Step 3: Override OLEAUT32

At the command line, run the following

 $ winecfg

Set the library overrides for oleaut32 to (native, builtin)

Step 4: Install an ODBC Driver

At the command line, run the following

 $ wine msiexec /i mysql-connector-odbc-3.51.25-win32.msi

NOTE:  'msiexec /i' is only needed for MSI installers.

http://www.sparxsystems.com/
http://kegel.com/wine/winetricks
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Step 5: Install Enterprise Architect

At the command line, run the following

 $ wine easetupfull.exe
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Installing Enterprise Architect with Support for Scripting4
and ODBC Connections

This section explains how to set up Enterprise Architect under the Wine environment with
support for Scripting and Open Database Connectivity (ODBC) repository.

Step 1: Download Necessary Components

To install Enterprise Architect with ODBC support, the following components are required:

Enterprise Architect (available from http://www.sparxsystems.com)·

An ODBC driver (see Appendix B: ODBC Versions for a list of compatible ODBC drivers)·

The winetricks script (available from http://kegel.com/wine/winetricks)·

Step 2: Install Windows Components

At the command line, run the following

 $ winetricks allfonts # install windows fonts
 $ winetricks msxml4 # install MSXML4 support.
 $ winetricks mdac28             # install data access components
 $ winetricks wsh56 # install MS Scripting Host

Step 3: Override OLEAUT32

At the command line, run the following

 $ winecfg

Set the library overrides for oleaut32 to (native, builtin)

Step 4: Install an ODBC Driver

At the command line, run the following

 $ wine msiexec /i mysql-connector-odbc-3.51.25-win32.msi

NOTE:  'msiexec /i' is only needed for MSI installers.

http://www.sparxsystems.com/
http://kegel.com/wine/winetricks
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Step 5: Install Enterprise Architect

At the command line, run the following

 $ wine easetupfull.exe
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Installing Enterprise Architect with Crossover5
This section explains how to set up Enterprise Architect within the Crossover environment when
using the Linux or Mac OS.

Step 1: Download Necessary Components

To install Enterprise Architect the following components are required:

Enterprise Architect (available from http://www.sparxsystems.com)·

Crossover Linux or Mac 10.0.3 or Greater (available from Crossover Community Page for·
Enterprise Architect.)

Step 2: Using CodeWeavers automated install
Navigate to Crossover Community Page for Enterprise Architect.·
Click on the "Install Enterprise Architect 9.0 Now" button.·
Click the Load button.·
Click the Install button·
Everything Enterprise Architect needs is installed automatically.

If the installer doesn't start automatically, run the following.

 $ CROSSOVER_PATH/bin/cxinstaller PATH_TO_FILE/9035.c4p

NOTE: The trial will be downloaded and installed by default. Once the trial starts to download
you can skip/cancel this stage if want to install the registered version.

Step 3: Installing Registered Version of Enterprise Architect.
Under the Crossover Menu, select "Install Windows Software".·
Find the "Unsupported Application section" and select "Other Application"·
Click Proceed·
Click "Choose Installer File..."·
Select file easetupfull.exe.·
Click Install.·

http://www.sparxsystems.com/
http://www.codeweavers.com/via/earchitect9
http://www.codeweavers.com/via/earchitect9
http://www.codeweavers.com/via/earchitect9
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Upgrading Enterprise Architect in Crossover6
This section explains how to upgrade Enterprise Architect within the Crossover environment
when using the Linux or Mac OS.

Step 1: Remove Existing version of Enterprise Architect
Under the Crossover menu, select "Manage Bottles"·
Find the Bottle Enterprise Architect is installed into.·
Select the "Applications" tab.·
Select "Enterprise Architect" in the "Installed Application" list.·
Click "Repair or Remove..."·
Follow prompts to remove.·

Step 2: Installing Registered Version of Enterprise Architect.
Click "Install Software..." button.·
Find the "Unsupported Application section" and select "Other Application"·
Click Proceed·
Click "Choose Installer File..."·
Select file easetupfull.exe.·
Click Install.·
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Installing Enterprise Architect Add-ins7
This section explains how to install Enterprise Architect add-ins under the Wine environment.

Step 1: Download Required Add-ins

Add-ins are usually distributed as executable installers. A list of some of the addins available for
Enterprise Architect can be found at http://www.sparxsystems.com/products/index.html.

Step 2: Install the Add-in

At the command line, run the following

 $ wine EAZachman.exe # substitute with actual
 # addin installer filename

Illustration 1: The Zachman add-in installer running in Wine

http://www.sparxsystems.com/products/index.html
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.NET Add-ins7.1
Please note that third party add-ins built in .NET have NOT been tested. To install an add-in built
in .NET you must have at least Wine version 0.9.59 and have .NET installed.

To install .NET, run the following from the command line

 $ winetricks dotnet20
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Installing MDG Eclipse Link.8
When running under Wine, the MDG Eclipse Link allows the user to link to an instance of Eclipse
running natively on the Linux host. The instructions for this step assume that Eclipse has been set
up within the native Linux environment.

Step 1: Download MDG Eclipse Link Installer

The MDG Eclipse Link installer executable is available from the Sparx Systems website at
http://www.sparxsystems.com/products/index.html

Step 2: Install MDG Eclipse Link

At the command line, run the following

 $ wine EAEclipse.exe

Step 3: Copy Eclipse Plugin Jar Files

To run the Eclipse link in the native Linux version of eclipse, the plugin jar files installed in Step 2
must be copied to the plugins directory in the location where Eclipse is installed. To copy the
necessary jar files, run the following from the command line:

 $ cp ~/.wine/drive_c/Program\ Files/Sparx\ Systems/MDG\ Link/\
 > Eclipse/*.jar PATH_TO_ECLIPSE_DIR/plugins

http://www.sparxsystems.com/
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Connecting to a project8.1
Step 1: :Load Eclipse
Load Eclipse in the Linux environment and load your project you wish to link to EA.

NOTE: Java has a large amount of outstanding issues when used within the WINE environment, so
ensure you use the native Eclipse version.

Step 2: Load Ea
Load EA and Open a Model

Step 3: Setup option so Eclipse will correctly generate the file
Since Windows and Linux paths are difference, we need to setup how the path is converted.

NOTE: Replace "Y:" with the path you use in WINE.
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Step 3: Connect to Eclipse

Right Click on a package and select "Add-ins -> Connect External Project -> Eclipse"

Select the solution, and click Connect.
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Setting up subversion with Enterprise Architect9
This section explains how to setup subversion with Enterprise Architect.

Enterprise Architect requires that the  subversion credentials be cached before making a
connection. The initial SVN checkout will create the cache Enterprise Architect needs.

We recommend that you update to Wine 1.2.1 or Crossover 9.2 before attempting to use https or
http protocol with subversion.

Step 1: Install a subversion client.
You need to install a native subversion client into the same environment as Enterprise Architect.

At the command line, run the following.

 $ wine <PATH_TO_SVN_INSTALLER>

NOTE: The following clients have been tested
Subversion Client Version
SlikSVN 1.6.9

Versions known NOT to work
Subversion Client Version
CollabNet Subversion Client 1.6.12

Step 2: Check out initial repository

At the command line, run the following.

 $ wine <PATH_TO_SVN> co <PATH_TO_REPOSITORY> <OUTPUT_PATH>
--username <USERNAME> --password <PASSWORD>

WARNING:  Don't checkout the repository using the Native Linux/MAC client since the SVN
credentials will not be cached correctly.
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Step 3: Setup Version Control in Enterprise Architect

When you are prompted for "Are you using a Unix based Subversion Client" select "NO"

Step 4: Connect package to Version control.
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Debugging and Sampling10
This section explains how to set up Enterprise Architect under the WINE environment to Debug
or Profile your application.  We assume your application is installed successfully into the WINE
environment, and *ALL* dependencies are met, i.e. Install msxml6 if your application needs it but
isn't part of your installer.

NOTES:
This only applies to Native code (C/C++)·
Assumes you have built your program in Visual Studio with Debug or Release with PDB·
support.

Step 1. Copy All need Files to the WINE directory.
Copy all your source from your development machine to the WINE environment, the·
path *MUST* match exactly.  So if your source was compile in C:\source\yourApp.
then you must copy the code to ~/.wine/drive_c/source/yourApp.
At this stage you might have to create a drive in winecfg if you use a build machine, so·
the correct is path
For every EXE and DLL you wish to debug, you must have the PDB for that file.·
If you are using an Debug EXE, you might have to copy the MFC/ATL Debug SXS·
from your Windows machine to your WINE environment. C:\windows\WinSxS ->
~/.wine/drive_c/windows/winsxs

Step 2. Run your application
On the command line attempt to run your application manually.·

 $ wine PATH_TO_APPLICATION

If it runs, go to Step 3.·
Check any output from WINE, for missed dependencies, and install them as needed. If·
you are sure that no dependencies are missed, and the crash is due to something else
go to Step 3.

HINT: If a huge amount of output is generated by WINE, pipe the output to a file.

 $ wine PATH_TO_APPLICATION >& output.txt

Step 3. Import your Code (optional)
You don't have to import your code into Enterprise Architect, but it does help when·
you want to set breakpoints within your code.
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Step 4. Setup Enterprise Architect Build Scripts.
On a package, add a build script·
Setup the Run command.·
Setup the Debug command·

Set "Use Debugger:" to "Microsoft Native"·

Step 5. Breakpoints
Open a source file and place a breakpoint within the function to debug.·
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Step 6. Debugging your application
Open the Debugger Window or use the "Execution Analysis - Debug" workspace·
(preferred).
Select the Build Script you created in the previous step..·
Click the Play button.·

Notes
Check the breakpoint is bound, i.e. stays red, if it has a question mark it hasn't bound.·
If your breakpoint didn't bind, then DOUBLE check the source path match.·
Ensure PDB(s) are in the same directory as you EXE(s)·
Ensure EXE and PDB match, i.e. are from the same compile.·
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Appendix11

Appendix A: Links11.1
Sparx Systems http://www.sparxsystems.com
Sparx Systems Support http://www.sparxsystems.com/support/index.html

Wine http://www.winehq.com
Crossover Office http://www.codeweavers.com/
WineSkin (MAC only) http://wineskin.doh123.com/

Appendix B: ODBC Versions11.2
Results may vary depending on the version of ODBC drivers that you use. We have tested with
the following versions

MySQL 3.51.25 http://dev.mysql.com/downloads/connector/odbc/3.51.html
MySQL 5.1.6 http://dev.mysql.com/downloads/connector/odbc/
Postgresql 8.04.0200 http://www.postgresql.org/ftp/odbc/versions/msi/

NOTE: Once the ODBC driver is installed, you can configure the connection from
"Tools -> ODBC Data Source Administrator" menu item.

Appendix C: Known Issues and Workarounds11.3
Issue: Diagram scroll appears to be very slow
Solution: Change the renderer to Basic, which can be found under "Tools -> Option - Diagram
-> Appearance"

Issue: Enterprise Architect Crashes when Viewing a generated RTF document that uses bitmaps
to display diagrams
Solution: If you are using ODBC connections, disable "gdiplus" library on the EA.exe application
otherwise ensure that "oleaut32" is using "builtin,native".

Issue: Enterprise Architect crashes on startup
Solution 1: This usually caused by msxml4 not being registered correctly.  Override msxml4 via
winecfg and either install "msxml4" via winetricks or re-install Enterprise Architect.
Solution 2: If you have installed any Enterprise Architect Add-ins, try installing the VB6 Runtime
library and overriding "oleaut32"

Issue: Enterprise Architect crashes when creating a new project.
Solution: Unknown cause. Current status can be found at Reported Bug.

Issue 1: When connecting to an ODBC DBMS, Enterprise Architect crashes shortly after
connecting

http://www.sparxsystems.com/
http://www.sparxsystems.com/support/index.html
http://www.winehq.com/
http://www.codeweavers.com/
http://wineskin.doh123.com/Information.html
http://dev.mysql.com/downloads/connector/odbc/3.51.html
http://dev.mysql.com/downloads/connector/odbc/
http://www.postgresql.org/ftp/odbc/versions/msi/
http://bugs.winehq.org/show_bug.cgi?id=27290
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Issue 2: Clicking on the link "Connect to Server" displays a Error dialog.
Solution: Override "oledb32" and re-install MDAC

Issue: Enterprise Architect prompts with “Cannot create GUID” or “Error creating XML Parser”
when loading.
Solution: Install "msxml4" via winetricks

Issue: When attempting to Debug or Profile an application the Debugger/Profiler crashes
Solution: Ensure that SSampler and SSProfiler75 have WinXP as their windows version.

Issue: When attempting to Debug or Profile an application no data is returned.
Solution 1: Ensure that SSampler and SSProfiler75 have "dbghelp" overridden.
Solution 2: Ensure that the source path matches exactly to where it was originally compiled.

Issue 1: Help sometime doesn't display correctly or crashes Enterprise Architect
Issue 2: Help loads but you cannot change help topics.
Solution: Install "ie6" via winetricks

Issue: RTF Template editor, Linked Document editor and Note window Text appears corrupted
on load or after enter a carriage return.
Solution: This bug was introduced in Wine 1.1.43, current status can be found at Reported Bug.
This bug is fixed in Wine 1.2-rc3.

Issue: EA crashes on startup when using development Wine 1.3 series.
Solution:  This bug was introduced in Wine 1.3.0, current status can be found at Reported Bug.
Use EA build 861 or greater to avoid the crash.

http://bugs.winehq.org/show_bug.cgi?id=22909
http://bugs.winehq.org/show_bug.cgi?id=23827
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Issue: RTF document images have their text inverted.
Solution: Before generating the document set the "Diagram Format" to "Bitmap".
Using EA 9.0 or later forces this flag on.

Issue: RTF document images are offset incorrect when "Diagram Format" is "Bitmap"
Solution: In Tools -> Options -> Diagram -> Appearance, Set "Renderer: to "Enhanced -1"

Issue: When using the MAC and WineSkin, EA crashes with an OLE error
Solution: Use WineSkin crossover engine WS4WineCX.  NOTE: You will need crossover gecko
engine for help to work.

Issue: Images (PNG,WMF,EMF) within Linked Documents don't display correctly.
Solution: Disable "gdiplus" library on the EA.exe.

Issue 1: JScript files don't loop over collection properly.
Issue 2: JScript file doesn't support Recursion.
Solution: Install "Window Scripting" via winetricks

Issue: All text is mirrored when printing a Diagram.
Solution: Upgrade to WINE 1.3.12 or greater.
Solution: Upgrade to Crossover Office 10.1.0 or greater.

Issue: When Profiling an application for a long period of time, the machine locks up.
Workaround: Profile in smaller time periods.
Solution: No know solution.

Issue: Enterprise Architect runs at the end of the install.
Solution:  This is a regression in Wine 1.3.22, please upgrade to a newer version.



Installing Enterprise Architect inside WINE, Version 1.0.2 Page 24 of 24

Appendix D: Installing Wine dependencies for Linux 64 bit11.4
editions
This section explains how to install the 32 bit dependencies that Wine requires when running
Enterprise Architect.  This section can be skipped if you using a 32 bit distribution.

Step 1: Using Ubuntu 64

At the command line, run the following

 $ wget
http://winezeug.googlecode.com/svn/trunk/install-wine-deps.sh
 $ sudo sh install-wine-deps.sh

Step 2: Using other 64 bit Linux distributions
Check the following web pages for help
http://wiki.winehq.org/WineOn64bit
http://wiki.winehq.org/Recommended_Packages

http://wiki.winehq.org/WineOn64bit
http://wiki.winehq.org/Recommended_Packages
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